Download it now!
Bug 132940 - Crash mergedlo!vcl::Region::operator= (with really specific steps)
Summary: Crash mergedlo!vcl::Region::operator= (with really specific steps)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords:
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-05-11 09:20 UTC by Telesto
Modified: 2020-08-27 10:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (25.35 KB, application/vnd.oasis.opendocument.text)
2020-07-27 15:35 UTC, Telesto
Details
Example file (72.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-27 18:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-11 09:20:52 UTC
Description:
Crash mergedlo!vcl::Region::operator= (with really specific steps)

Steps to Reproduce:
1. Download attachment 159245 [details] (set it to read only)
2. Open the file
3. Click edit document -> Open a copy
4. CTRL+A
5. CTRL+X
6. CTRL+V
7. While pasting.. open the same file in read only mode
8. Scroll to bottom in both documents.. 
9. scroll Around.. sudden crash.. I reproduced it 3x already so surely something in this area

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-11 09:44:16 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha1+
Build ID: 86bc13248c1d9f63b10aac304bdf0361d1dcc47f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Could you please provide a screencast ?
What about older versions ?
Comment 3 Telesto 2020-07-27 15:35:45 UTC
Created attachment 163641 [details]
Example file

1. Open the attached file
2. CTRL+A
3. CTRL+X
4. CTRL+Z
5. CTRL+Y

Repeat Z/Y 5 or 6 times fast...
Comment 4 Telesto 2020-07-27 15:37:32 UTC
It smells as bug 134025  Seen the PolyPolygon crash too. And BT is in the same area
Comment 5 Telesto 2020-07-27 15:43:30 UTC
(In reply to Telesto from comment #3)
> Created attachment 163641 [details]
> Example file
> 
> 1. Open the attached file
> 2. CTRL+A
> 3. CTRL+X
> 4. CTRL+Z
> 5. CTRL+Y
> 
> Repeat Z/Y 5 or 6 times fast...

Possible not working once in a while (alternative)

1. Open the attached file
2. CTRL+A
3. CTRL+X
4. CTRL+V
5. CTRL+Z
6. CTRL+Y

This is crashing in mergedlo!OutputDevice::EnableMapMode

But probably again bug 134025
Comment 6 Telesto 2020-07-27 15:49:37 UTC
(In reply to Telesto from comment #5)
Sorry; I was talking about bug 134475 (bug 134025 earlier attempt)
Comment 7 Telesto 2020-07-27 18:42:57 UTC
Created attachment 163651 [details]
Example file

Another one
1. Open the attached file
2. Scroll to bottom (page 91 i think)
3. Hold backspace for 20-40 seconds.. should crash
Comment 8 Noel Grandin 2020-08-20 09:31:29 UTC
Patch here
https://gerrit.libreoffice.org/c/core/+/101044
Comment 9 Commit Notification 2020-08-20 14:38:30 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/445cf499666f21c2d480ce1df9ce6004b9450b64

tdf#132940 Crash in mergedlo!vcl::Region::operator=

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-08-27 10:51:01 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/39f42fbd3f91afad60dad2937d2dfed79b956485

tdf#132940 Crash in mergedlo!vcl::Region::operator=

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.