Bug 132945 - FILEOPEN DOCX VML shape changes from circle to square
Summary: FILEOPEN DOCX VML shape changes from circle to square
Status: RESOLVED DUPLICATE of bug 41466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: VML-Textbox
  Show dependency treegraph
 
Reported: 2020-05-11 12:16 UTC by NISZ LibreOffice Team
Modified: 2020-12-10 11:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-11 12:16:48 UTC
This is split off from bug #123622
The green shape in the document is a circle in Word, but square in Writer.

Steps to reproduce:
    1. Add a header to a Word document or open attachment #149475 [details]
    2. Insert Page Numbers, choose With Shapes -> Circle
    3. Save as compatibility mode docx.

Actual results:
Shape changes from circle to square. See attachment  #149476 [details]

Expected results:
Same appearance as in Word.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x86)
Build ID: 7e257697f0006d8247a23ac91...
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-11 13:36:21 UTC
Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 86bc13248c1d9f63b10aac304bdf0361d1dcc47f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)


Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 2 Commit Notification 2020-05-13 13:16:41 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6edcbde02520500812d969dd5bcba5ff68d59c58

Related tdf#132945: fix warning

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 NISZ LibreOffice Team 2020-09-03 13:35:59 UTC
Another VML shape with textbox imported as frame.
Comment 4 Balázs Regényi 2020-12-10 11:50:12 UTC

*** This bug has been marked as a duplicate of bug 41466 ***