Download it now!
Bug 132975 - UI: Ctrl+F11 does not bring focus on combo box 'Select Style'
Summary: UI: Ctrl+F11 does not bring focus on combo box 'Select Style'
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2020-05-12 11:26 UTC by Cor Nouws
Modified: 2020-06-13 20:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2020-05-12 11:26:05 UTC
Version: 7.0.0.0.alpha0+
Build ID: c79dd92480cbc409a7061da7f3dd3abaaf9a4883
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: nl-NL (en_US.UTF-8); UI-Language: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-03_07:05:49
Calc: threaded
Comment 1 Durgapriyanka 2020-05-13 20:34:57 UTC
Couldn't reproduce in 

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Dieter 2020-05-16 08:56:20 UTC
I confirm it with

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 99c337d1d3831ce9d2c7dc1cbff713f4ac49d6ac
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (de_DE); UI: en-GB
Calc: CL

As far as I can see cursor get's lost

Doesn't happen with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 3 Buovjaga 2020-06-10 18:32:39 UTC
Bibisected with Linux 6.5 repo to https://git.libreoffice.org/core/+/16309a9516c1f173056fc103c6428e74217c7927%5E!/
weld StylesPropertyPanel

and SvxStyleToolBoxControl, etc.

Adding Cc: to Caolán McNamara
Comment 4 Caolán McNamara 2020-06-10 19:52:25 UTC
I love how you can pull the most obscure keyboard shortcut out of your back pocket. I think I fixed this with https://cgit.freedesktop.org/libreoffice/core/commit/?id=ea1182c8c2c42c0c527e232f7e392196796940d7 while I was unaware of this bug report
Comment 5 Buovjaga 2020-06-12 20:10:55 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: de1b634a151c198584dc152676183f519c50a2da
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 12 June 2020
Comment 6 Cor Nouws 2020-06-13 20:43:32 UTC
(In reply to Caolán McNamara from comment #4)
> I love how you can pull the most obscure keyboard shortcut out of your back
> pocket.
Since I started playing violin, I learned the term 'muscle memory' 
I'm blessed with some of that, it seems ;)

> I think I fixed this with
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=ea1182c8c2c42c0c527e232f7e392196796940d7 while I was unaware of this bug
> report
Indeed - thanks :)