Bug 133016 - SVG in presentation mode not as crispy in Skia raster/vulkan compared to GDI
Summary: SVG in presentation mode not as crispy in Skia raster/vulkan compared to GDI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:7.0.1
Keywords:
: 133908 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-05-13 20:29 UTC by Telesto
Modified: 2020-08-26 08:01 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
GDI 400% zoom (46.42 KB, image/png)
2020-05-13 20:30 UTC, Telesto
Details
Skia Vulkan/Raster (60.08 KB, image/png)
2020-05-13 20:31 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-13 20:29:46 UTC
Description:
SVG in presentation mode not crispy Skia raster/vulkan

Steps to Reproduce:
1. Open attachment 160031 [details]
2. Open the magnifier; set it to 300%
3. Go to presentation mode and look at the SVG -> Not cripy

@Offtopic
And if properly rendered the flaw of the 'flat' area on the bottom gets visible too (but that really old got fixed in edit mode somewhere around 3.5.7.2. However presentation mode still has it

Actual Results:
Ugly compared to GDI

Expected Results:
GDI


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: f9790da286f2d2fa47f1748f8cfa6172c6622ca3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Vulkan; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-05-13 20:30:19 UTC
Created attachment 160786 [details]
GDI 400% zoom
Comment 2 Telesto 2020-05-13 20:31:31 UTC
Created attachment 160787 [details]
Skia Vulkan/Raster
Comment 3 V Stuart Foote 2020-05-13 21:15:15 UTC
Yes seeing some rendering issues Skia Vulkan, or raster, the rings are not smooth, and the gradients are streaked. 

And with a two headed 1920x1200px screen system (so different scaling factors) the presenter 'preview' frame of the slide is worse than the presented full screen slide. 

But with default GDI mode, while the gradient and rings are "smooth" on the presentation screen the rings do get the same segmented look on the presenter 'preview' when scaled differently.

Version: 7.0.0.0.alpha1+ (x64)
Build ID: f9790da286f2d2fa47f1748f8cfa6172c6622ca3
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulcan; VCL: win; 
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 Commit Notification 2020-06-16 07:53:24 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/120070f252585fccf36a2edc32d797306fdf7e33

implement Skia workaround for adjacent AA-ed polygons (tdf#133016)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Luboš Luňák 2020-06-16 07:54:59 UTC
*** Bug 133908 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-06-16 09:12:22 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c6ae09ecfa2a8a9746e72b3e52e5b32ece6b77cb

implement Skia workaround for adjacent AA-ed polygons (tdf#133016)

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-07-02 12:13:58 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/52ccf06081d7aea3aefb7c582862987ec5380a45

Revert "implement Skia workaround for ... (tdf#133016)" (tdf#134346)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-07-02 18:47:22 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bbcc31c7261daba266b31a8d7d58fe0c1c87febe

Revert "implement Skia workaround for ... (tdf#133016)" (tdf#134346)

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-07-16 14:02:05 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/777ac5456a1f24fea29931ede983b5b8ad9a063d

hack for gradients split into adjacent polygons (tdf#133016)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-07-16 14:03:15 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/12147e0322e0fdd1b561c94e7ebd3fdd69ceaac0

merge needlessly split polygons back in Skia drawing (tdf#133016)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-07-16 22:59:26 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ddf3b1226cf5816d2eefafe32a90b317fb172502

hack for gradients split into adjacent polygons (tdf#133016)

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-07-16 23:03:20 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ecb87936d43a6eabcfe11a8f749065d42fc9fc2d

merge needlessly split polygons back in Skia drawing (tdf#133016)

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.