Bug 133065 - FILESAVE DOCX OLE object wrap settings are not saved
Summary: FILESAVE DOCX OLE object wrap settings are not saved
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2020-05-15 12:54 UTC by NISZ LibreOffice Team
Modified: 2020-09-14 07:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Writer (49.88 KB, application/vnd.oasis.opendocument.text)
2020-05-15 12:54 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer as DOCX (35.06 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-15 12:54 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (68.32 KB, image/png)
2020-05-15 12:55 UTC, NISZ LibreOffice Team
Details
Better example file from Writer master, with embedded XLSX file (69.08 KB, application/vnd.oasis.opendocument.text)
2020-05-21 10:12 UTC, NISZ LibreOffice Team
Details
The better example file saved by Writer to docx (46.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-21 10:13 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in Writer master and the exported in Word (118.08 KB, image/png)
2020-05-21 10:14 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-15 12:54:04 UTC
Created attachment 160855 [details]
Example file from Writer

Attached simple ODT contains all supported wrap settings for a simple OLE object.
When saved as DOCX these are all saved as Wrap Through.

Steps to reproduce:
    1. Open attached ODT and save as DOCX

Actual results:
Wrap options become Wrap Through when DOCX is reopened.

Expected results:
Various wrap options are exported correctly.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 1ed7607454d1492f65c78443cb661d5873face6b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-05-15 12:54:43 UTC
Created attachment 160856 [details]
The original file saved by Writer as DOCX
Comment 2 NISZ LibreOffice Team 2020-05-15 12:55:27 UTC
Created attachment 160857 [details]
Screenshot of the original and exported document side by side in Writer
Comment 3 m.a.riosv 2020-05-15 13:04:47 UTC
Confirmed
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 30356cdb3581bc9e9118ef3dd2f3162d9256c3b6
CPU threads: 4; OS: Windows 10.0 Build 19608; UI render: Skia/Raster; VCL: win; 
Locale: es-ES (es_ES); UI: en-US Calc: CL
With:
LibreOffice 3.3.0 OOO330m19 (Build:6)tag libreoffice-3.3.0.4
even doesn't load images.

But it can't be inherited because Aoo doesn't save as docx, only read.
Comment 4 NISZ LibreOffice Team 2020-05-21 10:12:00 UTC
Created attachment 161068 [details]
Better example file from Writer master, with embedded XLSX file
Comment 5 NISZ LibreOffice Team 2020-05-21 10:13:09 UTC
Created attachment 161070 [details]
The better example file saved by Writer to docx
Comment 6 NISZ LibreOffice Team 2020-05-21 10:14:49 UTC
Created attachment 161071 [details]
Screenshot of the original document in Writer master and the exported in Word
Comment 7 Commit Notification 2020-06-10 09:13:20 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4bdff3c731a9f8ef11ffdae804a99a47f119ee50

tdf#133065 tdf#133602 DOCX export: fix OLE wrap regression

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-06-16 11:30:52 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e0ba88a08c9c16fd805e13956ac9676f4ddfd377

tdf#133065 tdf#133602 DOCX export: fix OLE wrap regression

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 NISZ LibreOffice Team 2020-09-14 07:45:03 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded