Bug 133159 - Navigator: Selected item changes to the previous one (gtk3)
Summary: Navigator: Selected item changes to the previous one (gtk3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2020-05-19 08:31 UTC by Xisco Faulí
Modified: 2021-03-24 11:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (936.91 KB, video/x-matroska)
2020-05-19 08:59 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-19 08:31:01 UTC
Steps to reproduce:
1. Open attachment 123371 [details] from bug 98493
2. Open the navigator
3. Expand Sheets items
4. Double click on the last item ( Fouille8_Scenario_1 )
5. Double click on the first item ( Fouille1 )

-> Repeat step 4 and 5 a few times. 

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-19 08:32:00 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5325ce6a3c791bd4a5ee6e71f95a403562ca811c

author	Caolán McNamara <caolanm@redhat.com>	2020-02-26 12:17:45 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-02-28 16:16:24 +0100
commit	5325ce6a3c791bd4a5ee6e71f95a403562ca811c (patch)
tree	6ba582c0887875ceb039b617d1b9344801b2c69c
parent	6a3e04abd653cb86550b911b62ca54e2942f957a (diff)
weld calc navigator

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-05-19 08:37:09 UTC
it seems to be gtk3 only. I can't reproduce it in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Caolán McNamara 2020-05-19 08:45:21 UTC
I don't see anything unusual. Do you mean that you double click on e.g. the first entry and the bottom entry reselects instead ?
Comment 4 Xisco Faulí 2020-05-19 08:59:15 UTC
Created attachment 160995 [details]
screencast
Comment 5 Xisco Faulí 2020-05-19 09:00:31 UTC
(In reply to Caolán McNamara from comment #3)
> I don't see anything unusual. Do you mean that you double click on e.g. the
> first entry and the bottom entry reselects instead ?

yes, that's right. see the screencast
Comment 6 Caolán McNamara 2020-05-19 11:44:15 UTC
how odd, what if you stretch that floating navigator tall enough that the scrollbar disappears and then redo it ? Does that make a difference ?
Comment 7 Commit Notification 2020-05-19 14:38:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/47654bc44e4aff1b251e17c07d42f8beb8ce09c8

Related: tdf#133159 minimize jumping around if content doesn't change

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2020-05-19 14:44:04 UTC
I wonder if that makes any differences, makes using the navigator less annoyingly jumpy anyway
Comment 9 Caolán McNamara 2020-09-22 10:45:34 UTC
did that solve the problem, or can it still be seen ?
Comment 10 QA Administrators 2021-03-22 04:19:52 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2021-03-22 09:45:02 UTC
Still reproducible in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5262a9e88037decc26da84e7fa62f2955d4cdb85
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 12 Caolán McNamara 2021-03-22 16:58:54 UTC
I think I can reproduce this now
Comment 13 Commit Notification 2021-03-23 08:46:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6472f8444717f0567c69ab62b93c7437d02b0226

tdf#133159 store current config before changing sheet

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2021-03-23 10:19:18 UTC
done in master, backport to 7-1 in gerrit
Comment 15 Commit Notification 2021-03-24 11:54:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/3c8c4d4976e977ab110b0b59941cce7b36603e55

tdf#133159 store current config before changing sheet

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.