Bug 133160 - Autofilter popup should be resizeable
Summary: Autofilter popup should be resizeable
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2020-05-19 08:55 UTC by NISZ LibreOffice Team
Modified: 2020-10-21 08:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc (13.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-05-19 08:55 UTC, NISZ LibreOffice Team
Details
How the example file looks in Calc (60.19 KB, image/png)
2020-08-31 09:06 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-19 08:55:54 UTC
Created attachment 160994 [details]
Example file from Calc

This is followup to bug #49813
There the width of the autofilter popup window was set to be at least the width of the column, if its’s more wide than a sensible default.
This still makes the filterable text unreadable if it’s in a column that is narrower than the text. 
User reaction is that the popup should be resizeable manually, since the new behavior is not intuitive / discoverable.

Steps to reproduce:
    1. Open attached document, open the autofilter popup and try to read the end of the long text in the popups checklist

Actual results:
End of the text is not readable unless you make the column A wider.

Expected results:
Dropdown is resizeable by dragging its bottom right corner, as that would be something visually discoverable / expected by Excel users.
Also: Excel has a horizontal scrollbar for the autofilter popup, which allows scrolling the filter options if they have very long texts – that could be nice to have too.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 557c6777ad33b54af28541a96bcf91596995b388
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 Commit Notification 2020-08-28 06:57:07 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2d43c425a0de003a37bc278c3786d89165ecaf76

tdf#133160 sc: fix width of Autofilter popup window

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Attila Szűcs 2020-08-31 08:49:49 UTC
I was not able to make the popup window resizeable manually, instead i made it automatically sized, and added horizontal scrollbar in case of really long texts.

My estimate for the width of the longest text in the list, is not perfect, but i think it will be good enoght now.
(Maybe i should use other OutputDevice for the calculation?)
In some cases, the window will be like 10% bigger as the text.

If anyone still want the popup window be resizeable manually, then make a new bug ticket about it, as this ticket was created from an older one.
Comment 3 NISZ LibreOffice Team 2020-08-31 09:06:03 UTC
Created attachment 164907 [details]
How the example file looks in Calc

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

In todays nightly:
- The dropdown still lacks the manual resize widget in the bottom right corner. But since there is now a scrollbar for long text, this is no longer a big problem.
- The text is visible, but the dropdown is way wider than the text.
- There is an empty column looking empty space under the "Hide only the current item" button which is not highlighted when an item is highlighted.
Comment 4 NISZ LibreOffice Team 2020-09-14 09:45:20 UTC
Verified in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded