Bug 133189 - Sidebar: Width and Height values not updated when changing measurement units
Summary: Sidebar: Width and Height values not updated when changing measurement units
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-20 09:32 UTC by Xisco Faulí
Modified: 2020-06-01 14:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-20 09:32:11 UTC
Steps to reproduce:
1. Clean the profile and launch LibreOffice
2. Open Page Panel in sidebar -> Width is 8.27″ and Height is 11.69″
3. Change Measurement units to cms ( Options - Writer - General )

-> Width is 8.27 cm and height 11.69 cm. they should be 21 cm and 29 cm

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-20 09:33:19 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cbca3beb990df9e75218e27ff0f1b563cf3a67da

author	Caolán McNamara <caolanm@redhat.com>	2019-12-19 12:36:12 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-19 22:08:28 +0100
commit	cbca3beb990df9e75218e27ff0f1b563cf3a67da (patch)
tree	2150b1d6d4968dcc5a423f34d85ce5f038bd1fb3
parent	e3a002c53a544de02e5119c5b0a2fd4f972156a8 (diff)
weld PageFormatPanel

bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 2 Commit Notification 2020-05-22 16:04:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7a222c57720d550acc760bbcbdc67b33d1d78fb3

Resolves: tdf#133189 values not updated when units changed

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-05-22 20:01:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ec11b7330fab72dc56d847c7c3691fddbb18096e

Related: tdf#133189 values not updated when units changed

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-05-24 21:44:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/94f9b77b73d8c8bc6579bcd54861c76dc1e94f22

tdf#133189, tdf#129267: sw: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-06-01 14:04:19 UTC
Setting to VERIFIED since there's a UItest.

@Caolán, thanks for fixing this issue!!