Bug 133191 - FILESAVE XLSX Pie chart data label custom angle setting not saved
Summary: FILESAVE XLSX Pie chart data label custom angle setting not saved
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-05-20 10:04 UTC by NISZ LibreOffice Team
Modified: 2020-05-25 13:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (13.04 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-05-20 10:04 UTC, NISZ LibreOffice Team
Details
The original file saved by Calc (7.97 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-05-20 10:05 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Excel and Calc (135.22 KB, image/png)
2020-05-20 10:05 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-20 10:04:43 UTC
Created attachment 161031 [details]
Example file from Excel

Attached pie chart has custom angle set for the data labels: 20 degrees for the whole data row and 50 degrees for the second data point.
These are imported correctly in Calc (as 340 and 310 degrees, due to clockwise-counterclockwise differences), but on saving all of these becomes 0 degrees.

Steps to reproduce:
    1. Create a simple pie chart in Excel, enable data labels.
    2. Go to Format Data Labels, Label Settings, Alignment. Set a Custom angle.
    3. Save the file as XLSX, open it in Calc and save it with another name.

Actual results:
Custom angle values become 0 degrees.

Expected results:
Custom angle values are retained.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-05-20 10:05:19 UTC
Created attachment 161032 [details]
The original file saved by Calc
Comment 2 NISZ LibreOffice Team 2020-05-20 10:05:36 UTC
Created attachment 161033 [details]
Screenshot of the original and exported document side by side in Excel and Calc
Comment 3 Commit Notification 2020-05-25 12:41:39 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/74d020fb1344dd904681b612739727351f183b78

tdf#133190 tdf#133191 Chart OOXML export: fix text wrap and rotation

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.