Download it now!
Bug 133216 - Objects are not printed (Win-only)
Summary: Objects are not printed (Win-only)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-21 09:15 UTC by Timur
Modified: 2020-06-16 19:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2020-05-21 09:15:24 UTC
Open ODT attachment 152744 [details] from bug 126368 and print. 
2 images on 2nd page have black background (seen in PDF with virtual printer). 
Repro in Windows with Skia as in PDF attachment 161062 [details] and no Skia as in PDF attachment 161063 [details]. LO 7.0+ and no LO 6.4. Regression. 
No repro Linux and no repro PDF export. 
Image on 1st page is Skia only problem bug 133215.
Comment 1 Xisco Faulí 2020-05-22 10:41:59 UTC Comment hidden (obsolete)
Comment 2 Timur 2020-05-22 13:12:50 UTC Comment hidden (obsolete)
Comment 3 Timur 2020-05-22 13:47:34 UTC
(In reply to Xisco Faulí from comment #1)
> Hi Timur,
> Skia related ?
Yesterday I wrote "repro with Skia and no Skia", so no. 
But with today's build and change in bug 133215, both with and without Skia prints are empty.
Comment 4 Dieter 2020-05-24 06:30:28 UTC
I confirm it with

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 0e5e935deb0527c64865cfcc53a0421e56b74b6f
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Pages are empty in a PDF
Comment 5 Timur 2020-05-24 07:09:17 UTC Comment hidden (obsolete)
Comment 6 Telesto 2020-05-24 13:17:00 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2020-05-24 13:33:47 UTC
(In reply to Telesto from comment #6)
> Sounds a lot like: Bug 129085

But Timur says it is fine in 6.4.
Comment 8 Timur 2020-05-24 13:58:25 UTC
Please test and bibisect. These are not JPG but objects.
Comment 9 Buovjaga 2020-05-24 17:30:21 UTC
Bibisected with win 6.5 repo to https://git.libreoffice.org/core/+/34a699f1894f30f68c3243784586617e01e60ab6%5E!/

vcl: refactor by creating GetActionAfterBackgroundAction() function

Adding Cc: to Chris Sherlock

I double-checked by flipping between the first bad & preceding commit.
Tested using MS print to PDF.
Comment 10 Buovjaga 2020-05-24 17:52:45 UTC
(In reply to Timur from comment #0)
> Open ODT attachment 152744 [details] from bug 126368 and print. 
> 2 images on 2nd page have black background

This is https://git.libreoffice.org/core/+/6fa6704a7e7c6970b7a7c695a4a548f8dc693d03%5E!/

vcl: move functionality out of checkRect(), rendering function obsolete
Comment 11 Chris Sherlock 2020-05-25 17:10:02 UTC
Looking at this now.
Comment 12 Chris Sherlock 2020-05-25 18:26:32 UTC
I've backed out a number of changes, can you please test out https://gerrit.libreoffice.org/c/core/+/94804 ?
Comment 13 Commit Notification 2020-05-26 16:28:50 UTC
Chris Sherlock committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/067342f063fa3ea6773297eea89e45cabbf04a56

tdf#133216 - Objects are not printed (Win-only)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Aron Budea 2020-05-27 01:01:30 UTC Comment hidden (obsolete)
Comment 15 Aron Budea 2020-05-27 04:16:51 UTC
(In reply to Aron Budea from comment #14)
> (In reply to Timur from comment #3)
> > But with today's build and change in bug 133215, both with and without Skia
> > prints are empty.
> The empty prints started with the following commit:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=34a699f1894f30f68c3243784586617e01e60ab6
> author		Chris Sherlock <chris.sherlock79@gmail.com>	2020-05-12 22:35:59 +1000
> committer	Tomaž Vajngerl <quikee@gmail.com>	2020-05-20 10:54:47 +0200
> 
> vcl: refactor by creating GetActionAfterBackgroundAction() function
Chris, the problem with this commit is in the following line:
https://opengrok.libreoffice.org/xref/core/vcl/source/gdi/print2.cxx?r=34a699f1#714
MetaAction* pCurrAct <= when passing a pointer like this, you don't get back the changed pointer, and the 'for' loop after this relies on the processed pCurrAct.
Comment 16 Xisco Faulí 2020-05-28 14:23:47 UTC
Since the commits were reverted, let's call it fixed
Comment 17 Dieter 2020-06-16 19:44:01 UTC
Verified with

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 33a720ab802491f15b247e09755cd36205b6f435
CPU-Threads: 4; BS: Windows 10.0 Build 19041; UI-Render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded