Bug 133296 - NEW: LibreOffice doesn't print emojis in PDF export
Summary: NEW: LibreOffice doesn't print emojis in PDF export
Status: RESOLVED DUPLICATE of bug 129523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-22 22:18 UTC by mathieu.tarral
Modified: 2021-11-05 15:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT document containing emoji (7.99 KB, application/vnd.oasis.opendocument.text)
2020-05-22 22:19 UTC, mathieu.tarral
Details
Export of Emoji to PDF fail on Ubuntu (940.59 KB, video/x-matroska)
2020-07-04 05:19 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mathieu.tarral 2020-05-22 22:18:45 UTC
Description:
When exporting an ODT file to PDF, the emojis are absent from the final document.

Steps to Reproduce:
1. insert emoji ✅
2. export to PDF
3. open PDF: emoji is absent

Actual Results:
emoji is absent from PDF

Expected Results:
emoji should have been included in the PDF


Reproducible: Always


User Profile Reset: No



Additional Info:
Version : 6.4.3.2
Build ID : 1:6.4.3-0ubuntu0.20.04.1
Threads CPU : 12; OS : Linux 5.4; UI Render : par défaut; VCL: x11; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 1 mathieu.tarral 2020-05-22 22:19:46 UTC
Created attachment 161172 [details]
ODT document containing emoji
Comment 2 ian 2020-05-25 01:24:42 UTC
Thank you for reporting the bug.

I had a couple of questions regarding this report:

-You included an attachment that only includes an emoji. 
Is this an issue with a document containing only emojis or is all content i.e. images and text not being exported, too?

If it's the latter, then this is a duplicate of bug 133213.

-When you export, are you using the "Export Directly as PDF" or "Export as PDF" option?

I have set the status of this report to "NEEDINFO". 
Please set it back to "UNCONFIRMED" once you have provided more information.
Comment 3 mathieu.tarral 2020-05-25 07:03:54 UTC
Hi

> Is this an issue with a document containing only emojis or is all content i.e. images and text not being exported, too?

only the emojis will not be exported, the text will be exported, as expected.

> -When you export, are you using the "Export Directly as PDF" or "Export as PDF" option?

Both options gave me the same results: no emojis in the final document

Thanks.
Comment 4 Telesto 2020-05-25 07:43:40 UTC
No issue with
Version: 7.0.0.0.alpha1+ (x64)
Build ID: b587de60d4e6aa96238766272d94f1499b22f696
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 5 Mike 2020-07-04 05:19:21 UTC
Created attachment 162628 [details]
Export of Emoji to PDF fail on Ubuntu
Comment 6 Mike 2020-07-04 05:20:33 UTC
I can reproduce it on Ubuntu, but not on Win

Version: 6.4.2.2
Build ID: 1:6.4.2-0ubuntu3
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.4.2 (x64)
Build-ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU-Threads: 4; BS: Windows 10.0 Build 18363; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL
Comment 7 Buovjaga 2020-11-16 13:30:14 UTC

*** This bug has been marked as a duplicate of bug 129523 ***