Bug 133741 - Display glitch related to cell Validity settings
Summary: Display glitch related to cell Validity settings
Status: RESOLVED DUPLICATE of bug 61623
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-06 22:27 UTC by Ming Hua
Modified: 2020-06-06 23:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file showing the glitch (7.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-06-06 22:27 UTC, Ming Hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2020-06-06 22:27:48 UTC
Created attachment 161701 [details]
Sample file showing the glitch

When cells have validity check (via Data > Validity...) set to a list of predefined items, Calc displays a button with down arrow (like one with drop-down list) when input focus in on such cells.

However, if one sheet has cells with such validity check in place, the down-arrow button sometimes show up in other sheets (which don't have any validity checks) as well, causing confusions.

Steps to reproduce:
1. Open attached sample file, which have the A column of the second sheet (named "Validity Check") set with validity check;
2. Click the sheet tab at the bottom to switch to the second sheet, click one cell in A column, say A5, the down-arrow button appears;
3. Click the sheet tab again to switch to the first sheet (named "Display Glitch");
4. Now the A5 cell in the first sheet, not focused, also has a down-arrow button next to it.

I see this with both 6.4.4 and 7.0.0 beta1 on Windows 10.

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU 线程: 2; 操作系统: Windows 10.0 Build 18363; 用户界面渲染: Skia/点阵; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 1 m.a.riosv 2020-06-06 23:10:42 UTC

*** This bug has been marked as a duplicate of bug 61623 ***