Bug 133743 - "Safe mode" is meaningless for most end-users
Summary: "Safe mode" is meaningless for most end-users
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Safe-Mode
  Show dependency treegraph
 
Reported: 2020-06-07 01:17 UTC by Olivier Hallot
Modified: 2020-07-02 15:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2020-06-07 01:17:55 UTC
Real end users barely understand the meaning of "Enter safe mode" in menu Help.

A better string is recomended.

"Fix %PRODUCTNAME"
"Repair my %PRODUCTNAME"
"Fix %PRODUCTNAME user profile"
"Fix user profile"
"Fix my profile"
"Repair my installation"
"Repair %PRODUCTNAME installation"
(...)

The issue raised because of the many, many end-user asks for support in askbot related to LO misbehavior, and too often the issue is (can be) a broken profile. Most of them will not catch the purpose of the "safe mode" and will overlook the feature.

Worse, in some cultures users re-install LibreOffice from scratch, expecting to fix a profile issue.

Changing the menu entry as suggested may help end-user, who is looking to fix his LibreOffice.
Comment 1 Julien Nabet 2020-06-07 08:55:31 UTC
I suppose "safe mode" term comes from Windows env.

About suggestion, since it doesn't really fix anything, I'd propose:
"Start %PRODUCTNAME with a brand new user profile"

Indeed, using brand new LO profile just workaround the real cause but I admit that most of times users are happy with it if they don't reproduce their pb after this.
Comment 2 Telesto 2020-06-07 13:40:13 UTC
(In reply to Julien Nabet from comment #1)
> I suppose "safe mode" term comes from Windows env.
> Indeed, using brand new LO profile just workaround the real cause but I
> admit that most of times users are happy with it if they don't reproduce
> their pb after this.

Proposed something in the similar direction bug 132127
Comment 3 V Stuart Foote 2020-06-07 14:28:55 UTC
True we do not repair anything, just replace fresh pulled from defaults--but that would be terrible to work into menu labels.

How universally understood  is "Safe mode", to me at least as common as "Hyperlink"

But, if we are going to change the labeling for the whole dialog--the Fix & repair strings Oliver suggests are probably better choices for the translators to work against.
Comment 4 Telesto 2020-06-07 14:40:53 UTC
(In reply to V Stuart Foote from comment #3)
> True we do not repair anything, just replace fresh pulled from defaults--but
> that would be terrible to work into menu labels.
> 
> How universally understood  is "Safe mode", to me at least as common as
> "Hyperlink"
> 
> But, if we are going to change the labeling for the whole dialog--the Fix &
> repair strings Oliver suggests are probably better choices for the
> translators to work against.

Maybe even better, directly add an  ' reset profile' button in the menu (or call it fix and repair). Instead of relabeling safe-mode to fix & repair and sending people to safe mode and let dive into the overwhelming options in the safe-mode wizard.. which the probably don't use..
Comment 5 Heiko Tietze 2020-06-16 16:13:52 UTC
(In reply to Julien Nabet from comment #1)
> "Start %PRODUCTNAME with a brand new user profile"

Way to long for the menu. My proposal: "Repair user profile" (but I agree with Stuart, "Save Mode" sounds pretty much clear to me).
Comment 6 Thomas Lendo 2020-06-18 10:34:03 UTC
I tend to vote to not change the term Safe mode. It's used in other programs as well (e.g. Firefox) and other terms will be not precise enough (if too short) or too complicated (if too long). Can a tooltip be helpful? Otherwise I think the help pages can help the user who doesn't know anything about Safe mode.
Comment 7 Telesto 2020-06-18 13:16:33 UTC
(In reply to Thomas Lendo from comment #6)
> I tend to vote to not change the term Safe mode. It's used in other programs
> as well (e.g. Firefox) and other terms will be not precise enough (if too
> short) or too complicated (if too long). 

-> Agree; and even confusing for people who do understand the meaning.. I renaming would confuse me..

Still tending to a reset (user)profile as separate option in help in or help about.. Say Help troubleshooting menu with 2 items: reset profile or start in safe mode. Or trouble shooting wizard.. [note only brainstorming]
Comment 8 V Stuart Foote 2020-06-23 16:46:43 UTC
Rather than "Safe mode" rename the dialog *and* the Help menu entry?

Since entire dialog is about user configuration and profile--why not just a "User Profile..." menu entry, with restart warning box title "Enter User Profile", and message "Are you sure you want to restart LibreOffice and reconfigure User Profile"?

I don't think there is any chance of confusion with Tools -> Options
Comment 9 Telesto 2020-06-24 07:03:19 UTC
(In reply to V Stuart Foote from comment #8)
> Rather than "Safe mode" rename the dialog *and* the Help menu entry?
> 
> Since entire dialog is about user configuration and profile--why not just a
> "User Profile..." menu entry, with restart warning box title "Enter User
> Profile", and message "Are you sure you want to restart LibreOffice and
> reconfigure User Profile"?
> 
> I don't think there is any chance of confusion with Tools -> Options

Still not a fan of renaming safe mode (or sending people to safe mode)

1) Safe mode is a command line switch
2) Safe mode has an entry in the start program LibreOffice menu
3) Safe mode is already existing terminology
4) User Profile doesn't match the settings in the safe mode dialog; it does touch it.. but isn't the essence; IMHO
5) Reset to factory settings isn't the first in the list of safe-mode 
6) It's called reset to factory settings in the dialog (terminology harmony)..
7) You have tick 1/2 checkboxes
Comment 10 Adolfo Jayme 2020-06-24 22:43:13 UTC
Some humor, while we’re in this topic… https://twitter.com/rorschachisgay/status/1273373208163627009

Maybe I would accept renaming this dialog “Troubleshooting Options” and the Start menu entry “%PRODUCTNAME (Troubleshooting)”. Is that term encompassing enough?
Comment 11 Heiko Tietze 2020-06-25 08:36:51 UTC
Quite a lot pondering over a simple and well-known term. Most comments are okay with the existing term. So let's resolve as WFM.
Comment 12 Telesto 2020-06-25 09:34:43 UTC
(In reply to Heiko Tietze from comment #11)
> Quite a lot pondering over a simple and well-known term. Most comments are
> okay with the existing term. So let's resolve as WFM.

Not to quick.. I don't think it's solved.. Comment 0 still stands like a house, IMHO.. The pondering is more how the solve this in a sensible way.

Comment 10 does go in the right direction. Problem is the difference between naming in the sense of 'what it used for' and "how it functions". 

Safe-mode is a fail safe mode, used to troubleshoot.


There are a few dimensions aspect to take in consideration
1. Safe-mode is a command line switch
2. Safe-mode is already present. Relabeling could cause confusion what to expect, IMHO.

Another urgent question is if the trouble shooting mode - safe-mode wizard - would work. So even if we rename, safe-mode to troubleshooting, can people work with the wizard. And does it solve the problem. 

I still find the troubleshooting wizard - safe mode wizard - hard to understand. I'm actually still skipping most of the options.

1) The radio button: Restore backup copy is preselected, without any checkbox checked.. So not preset to 'nudge'/push people in a direction...
2) Restore backup copy is number 1 setting. I never trust this option with a corrupted profile. They profile "works" to some extend.. so the probably 'good' is likely still corrupted; So I move on to restore factory settings by default..
3) Configuration/Extensions.. never used those.. and extensions issue only makes sense with new extension installed/or an extension update.. 
After an upgrade an extension reset could work.. but with the same likelihood be caused by some upgrade change
4) So mostly quick & easy issue resolving method is factory reset, but that's on position 4, so.. last thing to consider based on the wizard.. However the most effective way to solve an issue (assuming watchdog working properly regarding to OpenGL/OpenCL/Vulkan). Yes, its bit rigorous.. and not funny with plenty of extensions, user interface modifications etc.. 
5) The radio button factory settings has of course 2 checkboxes. Still not sure what happens with reset profile checked + restore settings and interface. I would say profile reset includes interface.. but he.. 

The most restrictive way would be 'go on in safe mode' and to check if the problem still present. And if the issue is gone in safe mode, resetting the profile.. but likely confusing/hassle. People not understanding the difference between safe-mode /regular mode

Bluntly resetting profile is the fastest course of action (I think desired; people don't want to spend lots of time figuring out the details) ideally combined with a automatic backup of the present profile.. For smaller group of cases where the old profile did contain something of importance.. Autocorrect lists + Extensions; UI modifications..
Comment 13 Heiko Tietze 2020-07-02 15:33:24 UTC
We discussed this topic in the design meeting. Safe mode is clear to all of us, and the question on ask.libreoffice.org do not show the opposite. Only one question is about the difference https://ask.libreoffice.org/en/question/200587/safe-mode-versus-standard-mode/

So the verdict is to not change the name.

This does not mean the actual dialog is easy to use. All concerns in comment 12 should be done on bug 120269.