Download it now!
Bug 133784 - [EDITING] Add option to toggle image resize-by-mouse aspect ratio behaviour
Summary: [EDITING] Add option to toggle image resize-by-mouse aspect ratio behaviour
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Images Object
  Show dependency treegraph
 
Reported: 2020-06-08 08:24 UTC by zzz
Modified: 2020-10-15 07:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zzz 2020-06-08 08:24:14 UTC
In current version, dragging an object pasted on worksheet results as following:
(a)image:
  plain drag: keep aspect ratio
  shift+drag: flexible aspect ratio
(b)images grouped into a group:
  plain drag: flexible aspect ratio
  shift+drag: keep aspect ratio
(c)graphic shape objects:
  plain drag: flexible aspect ratio
  shift+drag: keep aspect ratio

The difference between (a) and (b) is annoying, because I almost never want a photograph's aspect ratio distorted. I would call it almost a bug. I suggest to add options to independently toggle the mode for each types(a,b,c,textbox) of objects.
Comment 1 Heiko Tietze 2020-10-05 10:50:58 UTC
It's implemented by design that shapes are scaled non-proportional while images should keep its aspect ration (see bug 71669 about this and the respective patch in [1]). As a side note, it's recommended to keep the aspect also for shapes if the checkbox is set (bug 84385), which depends on the fact that we don't properly save this setting(bug 84565).

Remaining issue is the group and apparently it's handled like a shape when you put images and shapes into one object. The point is probably that we'd have to check the content of groups- that may contain other groups, to find out whether or not it contains of images. Sound like an overkill since working with images is not the primary use case for Calc.

What do you think, Tomaz?

[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=84acb10f5484489612ccc84215edfcfdef87ea13
Comment 2 Cor Nouws 2020-10-14 11:37:19 UTC
@zzz did you try differences with dragging on different handles? The ones at sides behave different from the ones in the corners. But this may be different in the various scenario's :D ..
Thanks !
Comment 3 zzz 2020-10-14 12:43:07 UTC
@Cor Nouws, thanks for your comment. I realized I haven't mentioned which handle I used for re-sizing. What I'm talking is about the corner handles.

As for the side handles, the current behaviour is re-size in one dimension, and I agree with that specification.

@Heiko, I agree that it would be unwise to autoswitch behaviour by detecting group's content type. Not just because it's complicated, but also because there would be no determination logic that is acceptable to everybody.

Another solution idea for this problem is to unify shiftkey behaviours:
* plain drag: behaviour can differ among object types
* shift+drag: always keep aspect ratio
* ctrl+drag: always flexible aspect ratio
By this way, I only have to remember one thing: "In LibreCalc, just always shift+drag for photos". Not perfect but still better that (a) and (b) behaving in a totally opposite way.
Comment 4 Heiko Tietze 2020-10-15 07:55:11 UTC
We discussed the idea in the design meeting and decided to resolve as WONTFIX.

While the use case is well described it has been decided some time ago to keep the aspect ratio for images while shapes (and groups) don't (bug 71669, [1]). Shift toggles the behavior in all cases. Introducing an option might be easy but clutters the UI and with the rare corner case, common behavior, and the simple alteration per shift we better abstain from adding an option.

[1] https://wiki.documentfoundation.org/Design/Meetings/2015-10-14