Bug 71669 - Scale images proportionally by default
Summary: Scale images proportionally by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
: 47579 77393 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-16 03:40 UTC by Mercury
Modified: 2016-03-04 21:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mercury 2013-11-16 03:40:28 UTC
Proportional scaling is more frequent operation than unproprotional one. So, when you drag a corner handle of the image, you should scale it proportionally.
Comment 1 Mercury 2013-11-16 03:41:37 UTC
Steps to reproduce.

1. Open Writer.
2. Paste an image.
3. Drag corner handle.

Expected: scale proportionally.
Actual: scale unproportionally.
Comment 2 Tomaz Vajngerl 2013-12-08 14:42:23 UTC
I agree.
Comment 3 Marco Ciampa 2014-02-12 08:54:41 UTC
Yes please!
Comment 4 Commit Notification 2014-02-16 22:15:10 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84acb10f5484489612ccc84215edfcfdef87ea13

fdo#71669 Poportionally scale images by default in Writer



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Adolfo Jayme 2014-02-16 23:38:29 UTC
This behavior change needs to be documented in release notes...
Comment 6 Samuel Mehrbrodt (CIB) 2014-02-17 08:09:30 UTC
Thank you Tomaž for fixing this.
The new default is much better :)
Comment 7 droumanet 2014-03-04 16:10:56 UTC
Was an old hope !!! great !!!
Comment 8 retired 2014-03-04 17:16:34 UTC
Can't wait to see this in the stable release.

Would a backport to 4.x make sense?
Comment 9 retired 2014-03-04 17:17:14 UTC
sorry, 4.2.x I mean :S
Comment 10 Tomaz Vajngerl 2014-03-05 22:23:34 UTC
I think we should not introduce a sudden change in behavior in the stable release. The change in the code itself is rather small tough..
Comment 11 Jean-Baptiste Faure 2014-04-14 07:27:18 UTC
*** Bug 77393 has been marked as a duplicate of this bug. ***
Comment 12 Milan Bouchet-Valat 2014-04-24 21:02:22 UTC
Really, that's a great idea!
Comment 13 Rpnpif 2014-09-01 05:41:30 UTC
But now it is impossible to scale unproportionnaly.
Well, not with shift key (4.3.1.2)
Comment 14 Rpnpif 2014-09-01 05:42:13 UTC
(In reply to comment #13)
> But now it is impossible to scale unproportionnaly.
> Well, not with shift key (4.3.1.2)

As described in https://wiki.documentfoundation.org/ReleaseNotes/4.3.
Comment 15 Samuel Mehrbrodt (CIB) 2014-09-07 20:50:25 UTC
Why is this bug REOPENED?
Comment 16 Rpnpif 2014-09-09 15:33:20 UTC
(In reply to comment #15)
> Why is this bug REOPENED?

I am sorry, but in my 4.3.1.2 (rc ?), unproportionnaly was impossible with keyboard.

This is fixed in 4.3.1.2 official.
Comment 17 Rpnpif 2014-09-09 16:14:47 UTC
But now, if I copy an image directly in writer, all works fine.
If I copy in Draw and from draw in writer, the key to scale in writer are not as expected but as before the fixing.

I expected that all key have the same effects to scale in any way the image is copied.
Comment 18 Luke 2014-09-27 16:41:52 UTC
Shouldn't dragging respect the checkbox Picture->Type->Keep Ratio? 

When "Keep Ratio" is checked, the default drag should maintain the object's proportions, and holding shift should reverse that behavior.
Comment 19 Tomaz Vajngerl 2014-09-27 18:14:45 UTC
Hmm.. yes good point, but currently it is more of a dialog specific option - the setting is remembered when dialog is closed but it is not a per shape setting. 
If this would be a per shape setting then I would agree (we could default to enabled for pictures and disabled for other) but now this can only be a global UI setting, for which the position/size dialog is the wrong location for this setting and it also doesn't solve this problem (proportional scale just for images).
Comment 20 Thomas Bertels 2014-10-02 07:12:02 UTC
*** Bug 47579 has been marked as a duplicate of this bug. ***
Comment 21 hardy 2015-01-27 21:15:42 UTC
This IS fixed in Writer (LO 4.3.3.2 under Ubuntu Linux).
Bis this is NOT fixed in Impress. Should we reopen this bug or shall I report a new bug?
Comment 22 Tomaz Vajngerl 2015-01-27 23:38:05 UTC
It is fixed in LO 4.4
Comment 23 hardy 2015-02-21 13:53:59 UTC
Yes, it's really fixed eventually in LO 4.4.0. Thanks!
Comment 24 Pierre C 2015-10-07 07:49:02 UTC
Hi,

Maybe this bug should be reopened. Draw objects are not scaled proportionnaly by default.

For example if you have a Draw object in Impress, you should press Shift key if you want to resize it without losing its proportions.

This behaviour should be the same for all objects that can be resized.
Comment 25 Samuel Mehrbrodt (CIB) 2015-10-07 10:24:55 UTC
(In reply to Pierre C from comment #24)
> Hi,
> 
> Maybe this bug should be reopened. Draw objects are not scaled
> proportionnaly by default.
> 
> For example if you have a Draw object in Impress, you should press Shift key
> if you want to resize it without losing its proportions.
> 
> This behaviour should be the same for all objects that can be resized.

This was intentional. Why do you think shapes should be resized proportioanlly by default?
Comment 26 Pierre C 2015-10-07 20:31:46 UTC
(In reply to Samuel Mehrbrodt from comment #25)
> 
> This was intentional. Why do you think shapes should be resized
> proportionality by default?

First, I think that all resizing actions should have the same behaviour, not sometimes keeping ratio by pressing shift key and other times keeping ration by without pressing shift key. 
Second, Keeping ratio should be the default behaviour, by the simplest action, i.e. without pressing shift key
Comment 27 Samuel Mehrbrodt (CIB) 2015-10-08 03:56:06 UTC
(In reply to Pierre C from comment #26)
> First, I think that all resizing actions should have the same behaviour, not
> sometimes keeping ratio by pressing shift key and other times keeping ration
> by without pressing shift key. 
> Second, Keeping ratio should be the default behaviour, by the simplest
> action, i.e. without pressing shift key

This is something that should be discussed in our Design Meetings. Will bring this in our next meeting. You are welcome to join: https://wiki.documentfoundation.org/Design/Meetings
Comment 28 Luke 2015-10-16 23:40:57 UTC
I've made quite a few flow charts in Draw. When using Draw, I almost never want drawings scaled proportionally. The current default is correct. When you're dealing with shapes, in general you don't care about proportions. However, when you're dealing with images, you rarely want to distort them. There is a solution that would makes everyone happy: 

The current "keep aspect ratio" should behave the same as every other Office Suite/Drawing software. It should control how dragging affects the aspect ratio. See Bug 84385 

If this were fixed, the we could use shapes and images styles to make both sides happy. Images styles could default to keep aspect, while shapes to not keep aspect. And if people didn't like it, they could change the default styles.
Comment 29 Pierre C 2015-10-17 07:46:28 UTC
(In reply to Luke from comment #28)
> I've made quite a few flow charts in Draw. When using Draw, I almost never
> want drawings scaled proportionally. The current default is correct. When
> you're dealing with shapes, in general you don't care about proportions.

I agree with that

> However, when you're dealing with images, you rarely want to distort them.
> There is a solution that would makes everyone happy: 
>

Yes.

My Porblem was with  a group of draw objects. Probably most people want this group keeping its proportions 
 
> The current "keep aspect ratio" should behave the same as every other Office
> Suite/Drawing software. It should control how dragging affects the aspect
> ratio. See Bug 84385 

OK
> 

> If this were fixed, the we could use shapes and images styles to make both
> sides happy. Images styles could default to keep aspect, while shapes to not
> keep aspect. And if people didn't like it, they could change the default
> styles.
Comment 30 Yousuf Philips (jay) 2015-10-21 21:16:35 UTC
The design team discussed this in last week's meeting and decided that its fine for shapes not to be scaled proportionality by default.