Bug 133807 - Closing Find All results doesn't focus Find & Replace dialog
Summary: Closing Find All results doesn't focus Find & Replace dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Find&Replace-Dialog
  Show dependency treegraph
 
Reported: 2020-06-08 20:20 UTC by Aron Budea
Modified: 2020-06-21 21:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-06-08 20:20:13 UTC
The steps are similar to bug 133780 's.
- Open eg. attachment 161777 [details].
- Press CTRL+H to search for number 3.
- Click on Find All.
- Close the search results dialog.

=> The Find & Replace dialog should get back focus, but it doesn't.

Observed using LO 7.1.0.0.alpha0+ (8aee8c0cf1bdda1866594e75b0f9bd4b9a69c724) & 6.3.0.4 / Ubuntu.
Fine in 6.2.0.3.
=> regression

Bibisected to the following commit using repo bibisect-linux-64-6.3. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f920e86fbf3968104e1dfc0e9934e80652ed0837
author		Caolán McNamara <caolanm@redhat.com>	2019-03-22 15:59:00 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-03-24 18:19:29 +0100

weld SvxSearchDialog
Comment 1 Caolán McNamara 2020-06-09 08:42:53 UTC
I don't think this worked by design previously, just a quirk of how vcl manages its window stack
Comment 2 Commit Notification 2020-06-09 14:29:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3dc30ae62f593a7130b5fe8f6e3b7febe845dde7

tdf#133807 represent a visible search dialog when search results is closed

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-06-09 15:52:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8f364a1f2786be2a9c0953f9548765928c0610ae

tdf#133807 represent a visible search dialog when search results is closed

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-06-09 16:00:38 UTC
fixed in master and 7-0, I won't backport further unless there's particular demand for it.
Comment 5 Aron Budea 2020-06-15 00:10:21 UTC
Strangely, it still focuses the main window for me after clicking Close in the search results dialog.

Version: 7.1.0.0.alpha0+
Build ID: 058fdc75afa9e5e69c6e11ab7879ddb9d51ae1c5
CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-06-16 15:21:42 UTC
(In reply to Aron Budea from comment #5)
> Strangely, it still focuses the main window for me after clicking Close in
> the search results dialog.
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 058fdc75afa9e5e69c6e11ab7879ddb9d51ae1c5
> CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded

True, but it only happens with gtk3. focus comes back to the dialog with gen.
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 7 Caolán McNamara 2020-06-16 15:32:30 UTC
works fine with gtk3 under wayland, must be an X thing
Comment 8 Caolán McNamara 2020-06-17 10:00:04 UTC
lets try via a short timeout
Comment 9 Commit Notification 2020-06-17 12:50:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/981b4e32933c9d3083f20bcb09ead4e4e2161768

tdf#133807 re-present search dialog after a short timeout

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-06-17 13:57:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9da14cf5461a1883718da9f92e03dd0dd6e28efd

tdf#133807 re-present search dialog after a short timeout

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2020-06-17 14:06:00 UTC
that seems to be sufficient
Comment 12 Aron Budea 2020-06-21 21:12:22 UTC
Yep, looks good in 7.1.0.0.alpha0+ (5054f7067cc5ee43933893b682e02540fce043b4), thanks for the fix, Caolán.