Bug 133917 - Freeze/ hang after undo (SwFrame::FindColFrame ; SwFormatField::dumpAsXml)
Summary: Freeze/ hang after undo (SwFrame::FindColFrame ; SwFormatField::dumpAsXml)
Status: RESOLVED DUPLICATE of bug 135412
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-11 21:11 UTC by Telesto
Modified: 2020-11-05 15:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (255.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-11 21:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-11 21:11:46 UTC
Description:
Freeze/ hang after undo (SwFrame::FindColFrame ; SwFormatField::dumpAsXml)

Steps to Reproduce:
1. Open the attached file
DOCX export of 1. Open https://bz.apache.org/ooo/attachment.cgi?id=12592 (https://bz.apache.org/ooo/show_bug.cgi?id=24576)

2. CTRL+A
3. CTRL+X
4. CTRL+SHIFT+V
5. CTRL+Z

Actual Results:
Hang/freeze & dump

Expected Results:
No hang freeze


Reproducible: Always


User Profile Reset: No



Additional Info:
SwFrame::FindColFrame	swlo	[unknown]	0	0x7ffab1710846
SwFormatField::dumpAsXml	swlo	[unknown]	0	0x7ffab186dbd8
SwTextGridItem::IsSnapToChars	swlo	[unknown]	0	0x7ffab1809ffd
SwViewOption::IsFieldName	swlo	[unknown]	0	0x7ffab18395a1
SwTextGridItem::IsSnapToChars	swlo	[unknown]	0	0x7ffab180a86a
SwDrawTextInfo::SetPosMatchesBounds	swlo	[unknown]	0	0x7ffab1806181
SwDrawTextInfo::SetPosMatchesBounds	swlo	[unknown]	0	0x7ffab1808bf3
Comment 1 Telesto 2020-06-11 21:12:04 UTC
Created attachment 161902 [details]
Example file
Comment 2 Roman Kuznetsov 2020-06-12 16:18:24 UTC
no problem in

Version: 7.1.0.0.alpha0+
Build ID: 2047a5978ac8188e61da9cd3b2f40d86df5570bb
CPU threads: 4; OS: Mac OS X 10.15.5; UI render: default; VCL: osx
Locale: en-US (ru_RU.UTF-8); UI: en-US
Calc: threaded

Telesto, please show your info from About dialog
Comment 3 Telesto 2020-06-12 18:01:33 UTC
1. Open the attached file
DOCX export of 1. Open https://bz.apache.org/ooo/attachment.cgi?id=12592 (https://bz.apache.org/ooo/show_bug.cgi?id=24576)

2. CTRL+A
3. CTRL+X
4. CTRL+SHIFT+V -> RTF paste
5. CTRL+Z

Version: 7.1.0.0.alpha0+ (x86)
Build ID: 26483950760f0aac7bc45e93db4127f66a98fdc6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 4 BogdanB 2020-09-18 20:26:13 UTC
It crash only if I press Ctrl+Z one more time after step 5.
Comment 5 Xisco Faulí 2020-11-05 14:05:52 UTC
No crash in

Version: 7.1.0.0.alpha1+
Build ID: 9c8ed8c8526b9b696d0bf592eb7d963950f3cef4
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Telesto, please try with a recent daily build
Comment 6 Kevin Suo 2020-11-05 15:02:33 UTC
I do encounter the crash with build-id 26483950760f0aac7bc45e93db4127f66a98fdc6. However, no crash on master as of today. So, I did a reverse-bibisect using my own bibisect repo [1], then identified the range:
5070c0095433e5169dd4a34b1c6a6469726c197c..10ae7ba661dff57a7d08174792565ec5e33fae9b

This indicates that it must have been fixed in the following commit:

commit	10ae7ba661dff57a7d08174792565ec5e33fae9b
tdf#135412 tdf#135888 sw: fix copying of linked text-boxes

A look at bug 135412 shows a similar crash. As a result, marking this one as a duplicate of bug 135412.

*** This bug has been marked as a duplicate of bug 135412 ***
Comment 8 Xisco Faulí 2020-11-05 15:04:28 UTC
Nice Kevin,
Thanks a lot!