Download it now!
Bug 133971 - Crash in validity list + conditional formatting
Summary: Crash in validity list + conditional formatting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: haveBacktrace
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-06-13 20:28 UTC by Jean-Baptiste Faure
Modified: 2020-06-15 10:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (11.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-06-13 20:29 UTC, Jean-Baptiste Faure
Details
backtrace (65.81 KB, text/x-log)
2020-06-13 21:06 UTC, Regis Perdreau
Details
backtrace (81.34 KB, text/x-log)
2020-06-13 21:32 UTC, Regis Perdreau
Details
bt with debug symbols (3.27 KB, text/plain)
2020-06-14 08:20 UTC, Julien Nabet
Details
Valgrind trace (33.00 KB, application/x-bzip)
2020-06-14 13:48 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2020-06-13 20:28:45 UTC
Description:
Calc crashes when selecting a value in a dropdown list if the cell has a conditional formatting.

Steps to Reproduce:
1. Open the attached test file
2. Go to cell E3
3. Click on the dropdown list and change the value  => No crash
4. Go to cell B3
5. Click on the dropdown list and change the value

Actual Results:
Crash.
The difference between cells E3 and B3 is that B3 has a conditional formatting when E3 has not.

Expected Results:
No crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.0.beta1+
Build ID: 68535d0f9100e83d644175695d470c33eda6fb0b
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Ubuntu_18.04_x86-64
Calc: threaded
Comment 1 Jean-Baptiste Faure 2020-06-13 20:29:59 UTC
Created attachment 161964 [details]
Test file
Comment 2 Regis Perdreau 2020-06-13 20:55:07 UTC
Reproduced in Version: 7.1.0.0.alpha0+
Build ID: eb0d68a963d42e07d4b1572f6b6546ffb607e2c1
Threads CPU : 4; OS : Linux 5.0; UI Render : GL; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: CL


can't reproduce in
Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Regis Perdreau 2020-06-13 21:06:39 UTC
Created attachment 161966 [details]
backtrace
Comment 4 Regis Perdreau 2020-06-13 21:32:00 UTC
Created attachment 161968 [details]
backtrace

complete backtrace
Comment 5 Julien Nabet 2020-06-14 08:20:46 UTC
Created attachment 161978 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 6 Julien Nabet 2020-06-14 09:06:45 UTC
Caolán: I noticed https://cgit.freedesktop.org/libreoffice/core/commit/?id=41c465b5ee443ec04441077b5eb80f263336ea8a
tdf#133855 return early if disposed by FilterSelect

but I don't know why, it seems it doesn't help here.
Any idea?

(hope VclPtr will disappear one day...)
Comment 7 Julien Nabet 2020-06-14 13:48:54 UTC
Created attachment 161983 [details]
Valgrind trace
Comment 8 Commit Notification 2020-06-14 19:11:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3781ef174707fc48ed775306443e5662e35288a6

tdf#133971 hold self-ref until we return

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-15 01:50:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/47a9fcccb2bf8d66d97d37c59cea1b0e03792599

tdf#133971 hold self-ref until we return

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2020-06-15 06:25:44 UTC
No crash anymore in master and LO 7.0 beta1+ with these fixes.

tested on:
Version: 7.0.0.0.beta1+
Build ID: 47a9fcccb2bf8d66d97d37c59cea1b0e03792599
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Ubuntu_18.04_x86-64
Calc: threaded

and:
Version: 7.1.0.0.alpha0+
Build ID: 5cce65171b12cd652d6a9857a9c0bad1c608a65c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Ubuntu_18.04_x86-64
Calc: threaded

Thank you very much.

Best regards. JBF
Comment 11 Jean-Baptiste Faure 2020-06-15 10:29:42 UTC
From comment #10 set at Verified Fixed.

Best regards. JBF