Bug 134288 - FILEOPEN PPTX: text box renders vertically instead of horizontally
Summary: FILEOPEN PPTX: text box renders vertically instead of horizontally
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.2.0 target:7.1.0.2
Keywords: bibisected, bisected
Depends on:
Blocks: PPTX PPTX-Textbox
  Show dependency treegraph
 
Reported: 2020-06-24 22:56 UTC by Gerald Pfeifer
Modified: 2021-01-25 09:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slide (PPTX) (14.98 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-06-24 22:56 UTC, Gerald Pfeifer
Details
How it looks in LibreOffice (9.04 KB, image/png)
2020-06-24 22:59 UTC, Gerald Pfeifer
Details
How it should look (and looks in Office 365) (7.52 KB, image/png)
2020-06-24 23:09 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-06-24 22:56:31 UTC
Created attachment 162385 [details]
Sample slide (PPTX)

This is the third time I report a bug along these lines, albeit not a 
duplicate of my previous reports in
https://bugs.documentfoundation.org/show_bug.cgi?id=126060 and
https://bugs.documentfoundation.org/show_bug.cgi?id=132282 .
Comment 1 Gerald Pfeifer 2020-06-24 22:59:42 UTC
Created attachment 162386 [details]
How it looks in LibreOffice
Comment 2 Gerald Pfeifer 2020-06-24 23:09:09 UTC
Created attachment 162387 [details]
How it should look (and looks in Office 365)
Comment 3 Regina Henschel 2020-06-24 23:46:46 UTC
For me a shape with width=0 and height=0 is a faulty shape.
Comment 4 Gerald Pfeifer 2020-06-25 07:18:33 UTC
(In reply to Regina Henschel from comment #3)
> For me a shape with width=0 and height=0 is a faulty shape.

That makes sense.

I did encounter this in the wild, in a "professional" presentation created
by a PowerPoint user and extracted it from there (with Office 365). So somehow
PowerPoint must have created this in the first place? Maybe an undocumented
"feature"?
Comment 5 Xisco Faulí 2020-06-25 11:02:18 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 42bf9bdf3d551eb59604f952204c49f7d7a1e913
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-06-25 11:17:21 UTC
Current behaviour is reproducible since https://cgit.freedesktop.org/libreoffice/core/commit/?id=d0119ff7f2c68aa05286bd303128f3a69c6bbd6a.
Before that, nothing was displayed on the slide
Comment 7 Gerald Pfeifer 2020-09-05 14:56:22 UTC
(In reply to Xisco Faulí from comment #6)
> Current behaviour is reproducible since
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=d0119ff7f2c68aa05286bd303128f3a69c6bbd6a.
> Before that, nothing was displayed on the slide

Noel, that is a contribution of yours, that improved the situation already
by showing the text (when it wasn't shown before).

Maybe this one is interesting?  "Just" the orientation is off now for this
zero size textbox...
Comment 8 Commit Notification 2021-01-06 11:24:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/65e2ef43f186164729e1cc071b805bc1a7125cfe

tdf#134288 svx: fix rendering of text on a zero-width shape

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Miklos Vajna 2021-01-07 08:30:08 UTC
I think this is now fixed on master.
Comment 10 Xisco Faulí 2021-01-07 09:37:17 UTC
Hi Miklos,
Yes the text is horizontal in

Version: 7.2.0.0.alpha0+
Build ID: 6bb6eb1692d7dd432103d0e7278534390084caf6
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

OTOH, it becomes vertical when it's being edited ( Not happening with Powerpoint 2010). Should I fill a new ticket for that ?
Comment 11 Commit Notification 2021-01-07 09:52:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/0d55c821b72a4eba6f1696504888419ebcb23a20

tdf#134288 svx: fix rendering of text on a zero-width shape

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Miklos Vajna 2021-01-07 09:54:42 UTC
> Should I fill a new ticket for that ?

Yes, please. Thanks!
Comment 13 Xisco Faulí 2021-01-12 20:38:19 UTC
(In reply to Miklos Vajna from comment #12)
> > Should I fill a new ticket for that ?
> 
> Yes, please. Thanks!

Done in bug 139570