Bug 134314 - Auto Complete does weird stuff when comes to Umlauts in German Version 6.4.4.2
Summary: Auto Complete does weird stuff when comes to Umlauts in German Version 6.4.4.2
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 139308 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2020-06-26 08:01 UTC by c.voelker
Modified: 2021-01-15 04:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description c.voelker 2020-06-26 08:01:39 UTC
Description:
My auto complete function has collected words during use, among them "Gründungsjahr" and "ermächtigen". I updated to 6.4.4.2 yesterday. 

Now when typing "ermä" I get the suggestion "ermchtigen" instead of "ermächtigen". 

When typing "Grü" two thing happen, that are unexpected. I dont get a suggestion, but the letters get replaced no matter how. I get "Grndungsjahr". 

I tried to remove the letters "ndungsjahr" using backspace and type again, but bummer, the same again. I want to write "Grünen" in this case actually. The solution I found was to type "Gruenen" and replace "ue" afterwards. 

Besides sucking away umlauts, auto complete has changed behaviour inadvertently. It does not add a space after completing any longer.

I tried more words, where umlauts appear later. "Beschlussfassung" and "Beschäftigte" are both cached words. When typing "Bes" I first get a suggestion of "Beschlussfassung" which I might accept. Going on typing "Besch" the suggestion remains until I type "Beschä". In this very moment, I get a replacement with "Beschftigte" without ä which I am not able to reject, just as with "Grndungsjahr".


In the options dialog, the settings "Leerzeichen anhängen" (attach space) and "Als Tipphilfe anzeigen" (show as suggestion) are not checked. Based on former behaviour I assume that the former one had been checked before updating.

In the options dialog, the button "Löschen" above the list of collected words apparently does nothing. The expected behaviour is, list gets emptied and after closing the settings window no completion of the words mentioned in the examples above happens. When clicking the Button, the list remains filled as is and after closing the settings dialog with "OK", forced autocompletion as described with "Grndungsjahr" goes on. This is also the case when unchecking the box Wörter sammeln" bevor hitting "Löschen".

Finally, the check box "Gesammelte Wörter beim Schließen eines Dokuments entfernen" at the bottom below the word list in the options window helped me to solve the issue for now.

Well, not completely, the setting "Leerzeichen anhängen" still is ignored. But I am fed up testing.

Steps to Reproduce:
1. type Gründungsjahr to fill the auto complete word list
2. type Grü
3.

Actual Results:
Grndungsjahr is inserted without the possibilty to reject the suggestion.

Expected Results:
Gründungsjahr offered as a suggestion where I am able to type on to enter Grünen instead as intended.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
[MacBookLV:~] cvoelker% glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce 9400M OpenGL Engine
OpenGL version string: 2.1 NVIDIA-10.4.14 310.90.30.05b27
OpenGL shading language version string: 1.20
OpenGL extensions:

This is a white MacBook from 2009 running macOS 10.13.6 High Sierra.

Resetting UserProfile: I removed the list of collected words before becoming aware of such thing as running LibreOffice in protected mode. As such I cant check this any more.
Comment 1 Thomas Lendo 2020-08-14 18:56:23 UTC
Cannot reproduce the issue with
Version: 7.1.0.0.alpha0+
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-AT (de_AT.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-05_04:03:50
Calc: CL

I can use word completion with Umlaut words like Gründungsjahr and ermächtigen. Also the Autocorrect options works correct and I can delete a word in the list of collected words.

Maybe a Mac issue? Or one of the issues that cannot be reproduced due to user profile problems.
Comment 2 Milan Bouchet-Valat 2020-09-05 08:53:53 UTC
I also observed the same problem in French on a Mac OS Catalina and LibreOffice 6.4.6 and 7. When typing an accentuated character such as é, the word was automatically autocompleted without leaving the choice (and the accentuated character is missing from the word). This means you can't type any word with accentuated characters, making Writer completely unusable.

Going back to LO 6.3.6 fixed the problem. So given that c.voelker saw in on 6.4.4.2, the regression must have been introduced in 6.4.0, 6.4.1, 6.4.2 or 6.4.4.

c.voelker: Has the bug reappeared after some time or did emptying the words list fix it forever?
Comment 3 c.voelker 2020-09-05 23:59:39 UTC
Now it gets really weird.

My (not neccessarily complete) Update history is as follows. I am updating about every two month. I had installed
6.4.0 in February
6.4.3 in April
6.4.4 in June
7.0.0 since August
As such I used 6.4.3 for two month and I did not notice the behaviour. I dont type much (I actually do, but mostly Emails, not formatted documents), but I should have noticed within this timeframe, so it feels save to say, that the issue started in 6.4.4.

I just checked and found my word list to be empty. I dont know why. The option "clear word list when closing a document" was not checked, so there should have been at least some words, unless they did not get cleaned out during major Update from 6.x to 7.x.

I opened a new text document and entered the words mentioned in the first report, among them Gründungsjahr, ermächtigen, Beschlußfassung and Beschäftigte. The collected words list now contains Gründungsjahr, ermächtigen and Beschäftigte in several forms such as
Comment 4 c.voelker 2020-09-06 00:14:26 UTC
Oops -sent inadvertently- I continue where I left.

The collected words list contains only three of four sample words, but these words in several forms obviously generated automatically, such as ermächtige, ermächtigen and ermächtigt, but also forms that dont make sense as Beschäftig without any useful ending. The word Beschlußfassung did not get saved in the list.

I kept the new document open and typed the same words again. 

Typing "erm" gives me the chance to accept "ermächtigt" and the word gets inserted including the Umlaut if I do. If I go on typing the Umlaut as a fourth letter myself "ermä", ignoring the suggestion, I get it replaced immediately with "ermchtigte" without Umlaut and without a chance to reject the suggestion. 

With Gründungsjahr it is different as I dont get a suggestion when typing only two letters "Gr", but as soon as I type "Grü", it get immediate replacement with "Grndungsjahr", loosing my "ü" and without a chance to reject  the replacement.

Beschäftigte same situation described for ermächtigen.
Comment 5 Uwe Auer 2020-09-16 12:19:54 UTC
There was another question on ask site (German section) about this issue: https://ask.libreoffice.org/de/question/266237/unerwunschte-auto-korrektur-in-writer/

System of the questioner: LO-Version: 7.0.1.2, OS: MacOS Catalina, Version 10.15.6
Comment 6 Dieter 2021-01-15 04:29:23 UTC
*** Bug 139308 has been marked as a duplicate of this bug. ***