Bug 134344 - Give names to shapes upon creation (Calc)
Summary: Give names to shapes upon creation (Calc)
Status: RESOLVED DUPLICATE of bug 34828
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2020-06-27 16:07 UTC by Buovjaga
Modified: 2020-06-29 09:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2020-06-27 16:07:24 UTC
1. Open Calc
2. Add a shape
3. Open Navigator, observe shape is not listed
4. Right-click shape, name it

Writer does it differently. For a new shape it produces:
<draw:custom-shape text:anchor-type="paragraph" draw:z-index="0" draw:name="Shape1" draw:style-name="gr1" svg:width="1.015cm" svg:height="1.751cm" svg:x="2.247cm" svg:y="2.702cm">

Calc:
<draw:custom-shape draw:z-index="0" draw:style-name="gr1" draw:text-style-name="P1" svg:width="1.781cm" svg:height="1.488cm" svg:x="0.398cm" svg:y="0.904cm">
Comment 1 Heiko Tietze 2020-06-29 08:14:04 UTC
Duplicate of bug 34828? See also bug 90244 and bug 111839.
Comment 2 Buovjaga 2020-06-29 09:45:35 UTC
Yep, apparently was thrown off in searches by the older report having component "UI"

*** This bug has been marked as a duplicate of bug 34828 ***