Download it now!
Bug 134399 - Find Dialog Pre-Populated with Last Search
Summary: Find Dialog Pre-Populated with Last Search
Status: RESOLVED DUPLICATE of bug 136161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-06-29 17:57 UTC by Joel Madero
Modified: 2020-09-17 14:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2020-06-29 17:57:33 UTC
Description:
When you do a ctrl + f find in Sheets it now is pre-populated with the last thing that was searched. Problem is that the value is not highlighted and the cursor is before the text.

Result is that if you do a ctrl + f and want to quickly search for something other than what you previously searched for, you need to then do a ctrl + a and a delete to clear what was previously there creating two additional steps to get a quick task done. It's also a change from previous behavior and therefore users are not expecting it, causing confusion and irritation along the way.

Steps to Reproduce:
1.Start calc
2.Ctrl + f
3. Search for "test"
4. Close search (esc)
5. Ctrl + f


Actual Results:
You'll see "test" is still in the find box and the cursor is before the first "t", if you start typing "for instance if you want to search for Frank, you'll now have "Franktest".

Expected Results:
As before, the find dialog should be by default empty, or, if the idea is to have it pre-populated, it should be highlighted so that if you type something else, the previous text goes away without having to highlight and delete it with two additional steps.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+
Build ID: 680444880097aa708e01d49cb55a8d31e3d4cfa3
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


NOT reproduced on:
Version: 6.3.5.2
Build ID: 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Joel Madero 2020-06-29 17:58:59 UTC
@Xisco - another regression found. Someone may claim that it's a purposeful change....if so, I recommend the change I detailed in my original report to make it more functional as I think users who expect a quick and seamless find experience are going to get quite annoyed with this one.
Comment 2 BogdanB 2020-06-29 18:22:52 UTC
Bibiscted

236b1ede2ae1c72706b9a8d2c38be5b7e5a4e9e8 is the first bad commit
commit 236b1ede2ae1c72706b9a8d2c38be5b7e5a4e9e8
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Apr 16 20:38:50 2020 +0200

    source sha:bc0e0f633b05c4f91b6695488fc9e5c127507ba5
    
    source sha:bc0e0f633b05c4f91b6695488fc9e5c127507ba5

 instdir/program/libvclplug_gtk3_kde5lo.so          | Bin 3527968 -> 3533384 bytes
 instdir/program/libvclplug_gtk3lo.so               | Bin 2400560 -> 2410064 bytes
 instdir/program/versionrc                          |   2 +-
 instdir/share/config/images_breeze.zip             | Bin 1832522 -> 1832522 bytes
 instdir/share/config/images_breeze_dark.zip        | Bin 1828136 -> 1828136 bytes
 instdir/share/config/images_breeze_dark_svg.zip    | Bin 1501306 -> 1501306 bytes
 instdir/share/config/images_breeze_svg.zip         | Bin 1498905 -> 1498905 bytes
 instdir/share/config/images_colibre.zip            | Bin 2515159 -> 2515159 bytes
 instdir/share/config/images_colibre_svg.zip        | Bin 2270737 -> 2270737 bytes
 instdir/share/config/images_elementary.zip         | Bin 3995943 -> 3995943 bytes
 instdir/share/config/images_elementary_svg.zip     | Bin 4899826 -> 4899826 bytes
 instdir/share/config/images_karasa_jaga.zip        | Bin 4836086 -> 4836086 bytes
 instdir/share/config/images_karasa_jaga_svg.zip    | Bin 18979388 -> 18979388 bytes
 instdir/share/config/images_sifr.zip               | Bin 2022602 -> 2022602 bytes
 instdir/share/config/images_sifr_dark.zip          | Bin 2024484 -> 2024484 bytes
 instdir/share/config/images_sifr_dark_svg.zip      | Bin 1679671 -> 1679671 bytes
 instdir/share/config/images_sifr_svg.zip           | Bin 1675909 -> 1675909 bytes
 instdir/share/config/images_sukapura.zip           | Bin 2922273 -> 2922273 bytes
 instdir/share/config/images_sukapura_svg.zip       | Bin 15254800 -> 15254800 bytes
 instdir/share/config/images_tango.zip              | Bin 1751903 -> 1751903 bytes
 .../modules/swriter/ui/navigatorpanel.ui           |   2 -
 .../share/config/soffice.cfg/vcl/ui/combobox.ui    | 103 +++++++++++++++++++++
 22 files changed, 104 insertions(+), 3 deletions(-)
 create mode 100644 instdir/share/config/soffice.cfg/vcl/ui/combobox.ui
Comment 3 Aron Budea 2020-09-12 07:46:46 UTC
That is the following commit. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=bc0e0f633b05c4f91b6695488fc9e5c127507ba5
author		Caolán McNamara <caolanm@redhat.com>	2020-04-09 11:41:00 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-04-16 20:28:24 +0200

tdf#131120 use a replacement for GtkComboBox
Comment 4 Caolán McNamara 2020-09-17 14:43:53 UTC
Sounds a duplicate of bug 136161. If I'm wrong feel free to reopen

*** This bug has been marked as a duplicate of bug 136161 ***