Bug 134445 - "About Libre Office" should enable copy (like it used to)
Summary: "About Libre Office" should enable copy (like it used to)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2020-07-01 17:55 UTC by Jim Avera
Modified: 2020-07-06 19:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
about > copy button not labeled (182.43 KB, image/png)
2020-07-02 08:20 UTC, steve
Details
7.0.0.1RC1 copy button fixed (162.57 KB, image/png)
2020-07-06 19:40 UTC, steve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2020-07-01 17:55:58 UTC
Description:
Help->About Libre Office shows version info, etc.  As of 7.1 this is has been made facier, with hyperlinks to release notes, etc.

However, in the process copying to the clipboard (e.g. with Ctrl-C) has been disabled.  This prevents copying the version info, e.g. to put into a bug report.

At several points the bug system asks users to copy "the information in Help->About Libre Office" into a bug report, but now this is impossible.

To summarize: The "About" box text should be copyable

Steps to Reproduce:
1. Help->About Libre Office
2. Try to copy information there into another app

Actual Results:
You can't (can't select text, so can't copy it)

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Telesto 2020-07-01 18:34:08 UTC
It's replaced by a copy about info button; next to Version information..

They old - 'initial' copy button was more obvious, but for some reason replaced but a little button without label (not sure what the argument was..).. Lets bring it up again, just because it's a lovely topic ;-). And Heiko can't get enough of it. The about window, the most precious part of LibreOffice.
Comment 2 Jim Avera 2020-07-01 18:59:15 UTC
Ok, that wan't obvious to me.  Please do add an idiot-proof label such as "Copy Version to Clipboard".

I tried it, and it suffers from the "Clipboard persistence bug" where you have to paste while LO is still running.  If you exit LO first, there is nothing actually in the clipboard to paste.

See https://wiki.ubuntu.com/ClipboardPersistence for more about this.
Comment 3 Jan-Marek Glogowski 2020-07-01 20:01:20 UTC
For more discussion, see https://gerrit.libreoffice.org/c/core/+/95791. Even more info in bug 133662, which went a bit out of scope ;-)

Personally I would put a button with text just next to the close button, like the previous "Copy Version Info". For me the little icon button looks out of place and isn't obvious (also for the reporter).

And it would be nice, if someone could restore the Ctrl+C functionality, but I don't consider this essential with the button.
Comment 4 steve 2020-07-02 08:19:48 UTC
Slightly hijacking this bug: 7.0b2 shows the copy button, but there is no description. Not sure if that should be a separate bug, but that tiny unlabeled button is certainly not the intended way it should be displayed. (see screenshot)

So when that is fixed, that would solve this bug here?

The lost clipboard problem does not exist on macOS, thus it is a problem in the linux distribution being used and should be solved on an OS level and would be notourbug.
Comment 5 steve 2020-07-02 08:20:07 UTC
Created attachment 162584 [details]
about > copy button not labeled
Comment 6 Heiko Tietze 2020-07-02 08:29:18 UTC
(In reply to Telesto from comment #1)
> And Heiko can't get enough of it.

\o/

(In reply to Jan-Marek Glogowski from comment #3)
> And it would be nice, if someone could restore the Ctrl+C functionality, but
> I don't consider this essential with the button.

That's the only option I would implement. The discussion where to place the copy button was long and fruitless. Way too much bike-shedding.

I suggest to bring this request into bug 133728, which I took as shortcut enhancement ticket though it's about macOS.
Comment 7 Telesto 2020-07-02 10:08:15 UTC Comment hidden (no-value)
Comment 8 Heiko Tietze 2020-07-02 10:17:23 UTC
(In reply to Telesto from comment #7)
> ... attempt to dodge  'translation' discussion of bug 133662 this way

Yes, localization of "Copy version info" becomes too large on the button (which was not that widely accepted anyway).


And therefore all terms longer than Copy will fail. We also discussed to have a stock copy button where only the is. No objection, but in this case we have to move the button back to right. Adding more people with stakes.
Comment 9 Buovjaga 2020-07-02 10:31:36 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Telesto from comment #7)
> > ... attempt to dodge  'translation' discussion of bug 133662 this way
> 
> Yes, localization of "Copy version info" becomes too large on the button
> (which was not that widely accepted anyway).
> 
> 
> And therefore all terms longer than Copy will fail. We also discussed to
> have a stock copy button where only the is. No objection, but in this case
> we have to move the button back to right. Adding more people with stakes.

I am fine with the current situation when it comes to the button. I changed what you see in attachment 162584 [details] so the button is next to the Version Information text.

- the button has a tooltip telling what it does
- screenreader users can focus in it and the reader explains what it does (just tested)

Ctrl-C is a nice to have, if someone wants to implement.
Comment 10 Telesto 2020-07-02 12:20:37 UTC
(In reply to Buovjaga from comment #9)
> I am fine with the current situation when it comes to the button. I changed
> what you see in attachment 162584 [details] so the button is next to the
> Version Information text.
> 
> - the button has a tooltip telling what it does

Hmm we starting to deviation from the initial topic. Not saying that the current situation isn't workable for everyone who knows.  

This is for the people unaware. There is an issue of being noticed.. as comment 0 illustrates. And the tooltip isn't enough to resolve that.. It's already present

Not sure if a different position solve that.. 

1) Moving back to right, yes.. Adding more people with stakes -> what are the assumed stakes; i'm not seeing the issue nor did I hear them complain, yet.. 

About the text label: 
A) Copy -> With objection of missing what precisely. But that's the purpose right, creating some mystery/attention :-). And other part can be sovled with the tooltip; 
B) Copy about -> Complain not the whole about being copied?
C) Copy about info -> Too long (no go. translation.. )

Would go for A. But needs adding some people from bug 133662 to check up first. Else we end up re-opening another can of worms (bug 133662) about the label
Comment 11 Buovjaga 2020-07-02 12:25:34 UTC
(In reply to Telesto from comment #10)
> About the text label: 
> A) Copy -> With objection of missing what precisely. But that's the purpose
> right, creating some mystery/attention :-). And other part can be sovled
> with the tooltip; 
> B) Copy about -> Complain not the whole about being copied?
> C) Copy about info -> Too long (no go. translation.. )
> 
> Would go for A. But needs adding some people from bug 133662 to check up
> first. Else we end up re-opening another can of worms (bug 133662) about the
> label

Would go with none of them as there has been quite enough churn here already. I, too, would have preferred text, but this is getting way out of hand.
Comment 12 Telesto 2020-07-02 12:42:03 UTC
(In reply to Buovjaga from comment #11)
> (In reply to Telesto from comment #10)
> > About the text label: 
> > A) Copy -> With objection of missing what precisely. But that's the purpose
> > right, creating some mystery/attention :-). And other part can be sovled
> > with the tooltip; 
> > B) Copy about -> Complain not the whole about being copied?
> > C) Copy about info -> Too long (no go. translation.. )
> > 
> > Would go for A. But needs adding some people from bug 133662 to check up
> > first. Else we end up re-opening another can of worms (bug 133662) about the
> > label
> 
> Would go with none of them as there has been quite enough churn here
> already. I, too, would have preferred text, but this is getting way out of
> hand.

It only shows interest that people care about the about dialog :-). Not seeing this going really 'out of hand'. It only needs everybody being in the loop, without being surprised by something

I ask for 'English' about text. Got a button copy, which is actually even better. Except the copy about being still partly translated.. I complained about that.. but not solvable without (major) effort. 
Next step was the issue the label (too long) and the tooltip showing about in English, however still being partly translated (not doing what described to do).
Comment 13 Adolfo Jayme 2020-07-02 18:44:40 UTC
The issue with the empty button will be fixed in the next build. It’s already solved by https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-7-0&id=34e1eb170e394b464b9686cfbc0a56fb07d85893 , which I pushed after the beta was cut. Mala mía :(
Comment 14 steve 2020-07-06 19:40:26 UTC
Created attachment 162729 [details]
7.0.0.1RC1 copy button fixed
Comment 15 steve 2020-07-06 19:40:56 UTC
fixed. see attached screenshot.
Version: 7.0.0.1
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
CPU threads: 8; OS: Mac OS X 10.15.5; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded