Bug 134619 - FILESAVE: DOCX: Color and size of bullets lost after RT
Summary: FILESAVE: DOCX: Color and size of bullets lost after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.0.6
Keywords: bibisected, bisected, regression
: 137197 138150 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists 135774
  Show dependency treegraph
 
Reported: 2020-07-07 15:16 UTC by Xisco Faulí
Modified: 2021-02-26 12:20 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (73.50 KB, application/msword)
2020-07-07 15:16 UTC, Xisco Faulí
Details
Comparison before and after RT in LibreOffice 7.1 (18.85 KB, image/png)
2020-07-07 15:18 UTC, Xisco Faulí
Details
Superfluous Example file (8.94 KB, application/vnd.oasis.opendocument.text)
2020-09-07 08:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-07-07 15:16:07 UTC
Created attachment 162758 [details]
sample file

Steps to reproduce:
1. Open attached document
2. Save it as DOCX
3. Open the new generated document

-> Color and size of bullets are lost. See comparison image

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 9af38b4504ccda57a0c32eb8bdd03e5a8ca29ddc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-07-07 15:18:51 UTC
Created attachment 162759 [details]
Comparison before and after RT in LibreOffice 7.1
Comment 2 Xisco Faulí 2020-07-07 15:20:05 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=598ca431de96d8bfcf18fa2945e9e30f98387474

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2020-05-09 14:35:25 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-05-11 10:42:13 +0200
commit	598ca431de96d8bfcf18fa2945e9e30f98387474 (patch)
tree	508ead485cf73b0e77797a76c162cd6ac3b40901
parent	628cde6409eb471024a6aca5a8262b00f448c8cf (diff)
tdf#132766: DOCX export: always try to set bullet font for list

Bisected with: bibisect-linux64-7.0

Adding Cc: to Vasily Melenchuk
Comment 3 Telesto 2020-09-07 08:45:45 UTC
Created attachment 165220 [details]
Superfluous Example file

1. Open file
2. Save as DOCX
3. File reload

Added because the current issue maybe masking another one (font color overriding bullet color)
Comment 4 BogdanB 2020-10-02 20:01:19 UTC
*** Bug 137197 has been marked as a duplicate of this bug. ***
Comment 5 Timur 2020-11-23 12:02:49 UTC
*** Bug 138150 has been marked as a duplicate of this bug. ***
Comment 6 Justin L 2021-01-27 09:49:49 UTC
repro 7.2+. Confirmed this is an export bug since Word 2003 also opens the resulting DOCX file with "simple" bullets.

This commit should just be reverted.
The logic changed to say "if we have a font, then export the font information, otherwise export all the properties." with
+        else
+            m_rExport.OutputItemSet(*pOutSet, false, true, i18n::ScriptType::LATIN, m_rExport.m_bExportModeRTF);
Comment 7 Justin L 2021-01-27 13:38:12 UTC
It is instructive to know that at the beginning of LO 7.0 (and ever since at least 5.1 which was as far back as I tested), the round-trip had only tiny bullets - although they were nice and colourful.

The correct sizes were retained early on in 7.0 because of work done by
author Jan-Marek Glogowski on 2019-12-06 13:02:00 +0100
commit	6ed12ab2d0742f86ce25defec3c776562dbfad9a
tdf#120546 fix DOCX overriding numrule format
Comment 8 Justin L 2021-01-27 20:08:05 UTC
OK - I took a shot at fixing it. See http://gerrit.libreoffice.org/c/core/+/110034
Comment 9 Commit Notification 2021-01-30 13:43:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0ce7284ec75be275ef6aa803c6497400c179cab4

tdf#134619 docxexport: don't skip font properties in NumberingLevel

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-02-08 12:10:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/5031a2932e9146db8b163ecfcaaf29e59cc4cc9d

tdf#134619 docxexport: don't skip font properties in NumberingLevel

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2021-02-08 12:11:17 UTC
I do confirm the issue is fixed in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: faadf530c22d1874640936b8554845d7ff36f263
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Justin Luth, thanks for fixing this issue!! Closing...
Comment 12 Commit Notification 2021-02-26 12:20:54 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2f40c8f59cb23106e36071082d2570e2dbca4d22

tdf#134619 docxexport: don't skip font properties in NumberingLevel

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.