Bug 134626 - assertion in SwTextNode::~SwTextNode()
Summary: assertion in SwTextNode::~SwTextNode()
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2 tar...
Keywords: haveBacktrace
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2020-07-07 18:36 UTC by Telesto
Modified: 2021-01-15 17:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["CompareSwOutlineNodes::operator()(SwNode * const &,SwNode * const &)"]


Attachments
Example file (90.96 KB, application/vnd.oasis.opendocument.text)
2020-07-07 18:36 UTC, Telesto
Details
backtrace on Linux (11.76 KB, text/plain)
2020-07-17 23:00 UTC, Terrence Enger
Details
a simpler version which has the same assert (8.92 KB, application/vnd.oasis.opendocument.text)
2020-11-17 12:17 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-07 18:36:11 UTC
Created attachment 162770 [details]
Example file

This bug was filed from the crash reporting server and is br-16b4cfb2-19c6-4f22-b667-3667b22d660f.
=========================================

1. Open the attached file
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V
6. CTRL+V
7. CTRL+Z
8. CTRL+Z
9. CTRL+Y
10. CTRL+Y
11. CTRL+Z

Probably a duplicate.. but at least pretty basic example
Comment 1 Telesto 2020-07-07 18:41:45 UTC
No crash with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

Following the exact steps..
A step 12: CTRL+V causes a crash in 4.4.7.2
Comment 2 Telesto 2020-07-07 18:43:25 UTC
Also fine in
Version: 5.4.0.2
Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Telesto 2020-07-07 18:45:15 UTC
Already crashing in
Version: 6.1.0.0.alpha0+
Build ID: 2e4805442a9eeedb32d6b570c4c11594aca7c642
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 MM 2020-07-07 22:05:06 UTC
Confirmed on windows 10 x64 with Version: 6.4.5.2 (x64)
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: default; VCL: win

https://crashreport.libreoffice.org/stats/crash_details/2dad4e94-1c1c-4df8-902f-4dab0a4a3a60
Comment 5 Telesto 2020-07-08 16:31:27 UTC
To give people some choice between the type of issue the are bibisecting..
Comment 6 Buovjaga 2020-07-11 18:15:03 UTC
Seemed to have appeared in 6.0, but I got a bogus result with win32-6.0 repo.
Comment 7 Xisco Faulí 2020-07-13 11:14:48 UTC
I'm not sure it's a regression. it also crashes for me at some point in the steps in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 8 Telesto 2020-07-13 12:17:34 UTC
No issue with
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Even including step 12
Comment 9 Terrence Enger 2020-07-17 23:00:01 UTC
Created attachment 163214 [details]
backtrace on Linux

I see the reported failure at step 10 (the second <ctrl>+Y) in a local
build of commit e54ff4c1, configured

    --with-vendor=Terrence Enger
    --with-jdk-home=/usr/lib/jvm/default-java
    --enable-split-debug
    --enable-gdb-index
    --enable-ld=gold
    --enable-option-checking=fatal
    #--enable-dbgutil
    --enable-debug
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    --without-package-format

built and running on debian-buster.  The terminal message (rewrapped
to subvert bugzilla's line splitting) is:

    soffice.bin:
        /home/terry/lo_hacking/git/libo6/sw/source/core/txtnode/ndtxt.cxx:250:
        virtual SwTextNode::~SwTextNode(): Assertion
        `!GetNodes().GetOutLineNds().Seek_Entry(this, &foo)' failed.


I am changing title from "Crash in: swlo.dll" to "assertion in
SwTextNode::~SwTextNode()", and I am adding keyword haveBacktrace.
Comment 10 Terrence Enger 2020-07-18 19:28:07 UTC
Still working on debian-buster.  Contrary to comments 7 and 8,
I see failures all the way back to bibisect-43all version oldest
(LibreOffice 3.5.0 Build ID:d6cde02).

The bibisect repositories are built without assertions, so the
failures are different from comment 9:

    64-7.1 latest : sigabrt,   SwOutlineNodes::Seek_Entry is frame #1
    44max  oldest : segfault,  ditto
    43all  latest : segfault,  SwOutlineNodes::Seek_Entry is frame #0
    43all  oldest : segfault,  SwOutlineNodes::Seek_Entry is not in the bt,
                               Nodes::UpdtOutlineIdx is frame #1

I am leaving keyword bibisectRequest, in the hope that somebody else
will be more successful.
Comment 11 Terrence Enger 2020-07-20 17:09:34 UTC
*** Bug 134780 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2020-07-20 17:37:27 UTC
@M. Stahl,
Not sure if you're interest in even more crashes.. You have pretty long todo list already.. but anyhow
Comment 13 Telesto 2020-07-20 17:40:32 UTC
This likely again a duplicate of a previous report of mine: bug 119241
Comment 14 Telesto 2020-07-26 21:44:32 UTC

*** This bug has been marked as a duplicate of bug 119241 ***
Comment 15 Caolán McNamara 2020-11-17 12:17:33 UTC
Created attachment 167361 [details]
a simpler version which has the same assert
Comment 16 Commit Notification 2020-12-01 09:13:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/138cf950dcdc8a1240452cad6867e197279f42b0

tdf#134626 assertion in ~SwTextNode

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2020-12-01 11:05:13 UTC
Closing this a RESOLVED FIXED since there is a commit for it
Comment 18 Commit Notification 2020-12-01 11:05:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/b1acda00fecb2d158c4cb4b0c36add34caebc84b

tdf#134626 assertion in ~SwTextNode

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-12-01 14:26:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/0b4257bae19500083f530fa78afb6a67f68db75a

tdf#134626 assertion in ~SwTextNode

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-12-03 08:42:43 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/480d00625534c356dabd96c503d992f07c99d152

tdf#134626: sw_uiwriter: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Xisco Faulí 2020-12-03 09:14:16 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 480d00625534c356dabd96c503d992f07c99d152
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 22 Commit Notification 2020-12-10 12:35:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b4365b985178e1866c74afd757a104aad1d405a9

tdf#134626 sw: fix UBSan warning about deleted SwTextFormatColl

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2021-01-15 17:21:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/d01fb1a86ead0ce6441906838878835b299a3dfb

tdf#134101, tdf#134626 sw: fix UBSan warning about deleted SwTextFormatColl

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.