Download it now!
Bug 134708 - Erratic behaviors in Basic IDE
Summary: Erratic behaviors in Basic IDE
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Thorsten Wagner
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords: bibisected, bisected, regression
: 134892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-10 08:55 UTC by blank15927
Modified: 2020-09-19 19:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blank15927 2020-07-10 08:55:04 UTC
Description:
Erratic behaviors in Basic IDE

Steps to Reproduce:
Windows 10, LibreOffice 7.0.0.1

1 Open the macro Editor
2 Create a dialog box
3 Create a button (or anything else) with a text
4 Change the font color to red, for example
5 Validate
6 Same problem with a ProgressBar : can't change the FillColor.


Actual Results:
No red in LO 7.0, OK in LO 6.4.5.2

Expected Results:
Apply color


Reproducible: Always


User Profile Reset: No



Additional Info:

Go back to Police > Color : Red color is still present
Click Reset
Nothing happens

----

Other problem :

1 On the dialbox, insert any number of controls, let's say 3 buttons
2 Select the 3 items with the mouse
3 Try to change Position X to align them perfectly
4 Enter to validate : nothing happens
5 Click in an other field somewhere. If you're lucky, it's only at this moment that these items will align.
6 But something else happens : try to click a few times between Position X and position Y : suddenly position Y is set to 0.
7 And the layout is messed up.
8 And I've also seen the width field reset to 0...
9 And the layout is even more messed up.


For both problems, repeat the same steps in LO 6.4.5 : everything works fine.
(Except the Enter key that has never validated anything in this section of the editor)


Generally speaking: the editor is full of little erratic behaviors.
I understand it's not a priority but I hope that one day, the editor will get more love and attention.

----

And also, this infuriating behavior, in all LO versions :
Close the Standard library tree
Double click my library - The Standard library tree opens by itself.
Close again Standard library - Double click a module in my library
The Standard library opens. Again.

=============================

Version: 7.0.0.1 (x64)
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
Threads CPU : 8; OS : Windows 10.0 Build 18363; UI Render : Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded

Version : 6.4.5.2 (x64)
Build ID : a726b36747cf2001e06b58ad5db1aa3a9a1872d6
Threads CPU : 8; OS : Windows 10.0 Build 18363; UI Render : GL; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: CL
Comment 1 Xisco Faulí 2020-07-10 16:20:38 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8d11b953c0a69f4f5eb5ca42dec3812a62d0cd0f

author	Thorsten Wagner <thorsten.wagner.4@gmail.com>	2020-02-23 21:11:05 +0100
committer	Tomaž Vajngerl <quikee@gmail.com>	2020-03-06 20:36:23 +0100
commit	8d11b953c0a69f4f5eb5ca42dec3812a62d0cd0f (patch)
tree	4061d4c9cd64871154a1fc843eae5cfbb6d22788
parent	4ba09be7e260ce2a79a23465db7b2837422cde30 (diff)
tdf#125532: White text on default/action buttons and selected tabs on macOS

Bisected with: bibisect-linux64-7.0

Adding Cc: to Thorsten Wagner
Comment 2 Xisco Faulí 2020-07-10 16:21:54 UTC
@Caolán, I thought you might be interested in this issue...
Comment 3 Thorsten Wagner 2020-07-10 22:39:11 UTC
Confirming on macOS too, will take a look!

The second issue does not seem to be related to coloring - please file a different issue for this.
Comment 5 Thorsten Wagner 2020-07-25 23:13:03 UTC
*** Bug 134892 has been marked as a duplicate of this bug. ***
Comment 6 Thorsten Wagner 2020-07-27 22:40:55 UTC
Patch submitted to Gerrit:

https://gerrit.libreoffice.org/c/core/+/99564
Comment 7 Commit Notification 2020-08-27 10:56:18 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/84b2849512bdb19597739d9515dd55e2d3ba9504

tdf#134708 Text coloring of buttons within forms amended

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-09-01 16:16:24 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 828914a94fe93d5b300bda1d23a049ae92c159e1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Thorsten Wagner, thanks for fixing this issue!!
Comment 9 Commit Notification 2020-09-09 06:27:36 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6be0a806dcce864fb4d604be68e8b3711fc604d6

tdf#134708 Text coloring of buttons within forms amended

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.