Bug 125532 - Characters rendered black on selected dialog tabs on macOS
Summary: Characters rendered black on selected dialog tabs on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Thorsten Wagner
URL:
Whiteboard: target:7.0.0
Keywords:
: 125088 130466 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist Dialog
  Show dependency treegraph
 
Reported: 2019-05-27 20:17 UTC by Thorsten Wagner
Modified: 2020-09-19 19:45 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (37.74 KB, image/png)
2019-05-27 20:18 UTC, Thorsten Wagner
Details
Screenshot with patch (320.30 KB, image/png)
2020-01-17 19:44 UTC, Thorsten Wagner
Details
Screenshot 3 (245.31 KB, image/png)
2020-03-01 19:09 UTC, Thorsten Wagner
Details
Screenshot 4 (297.83 KB, image/png)
2020-03-01 19:09 UTC, Thorsten Wagner
Details
screenshot, white text on grey default button macos catalina darkmode (27.57 KB, image/png)
2020-09-02 11:59 UTC, ted bug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2019-05-27 20:17:44 UTC
Description:
With LO 6.3 selected buttons are rendered with white characters correctly now. Selected tabs are still rendered with black characters (see screenshot). They should be rendered correctly with white characters too. 

Steps to Reproduce:
(1) Open a LO application, e.g. Writer

(2) Open a dialog with tabs, e.g. File / Properties

Actual Results:
Selected tabs are rendered with black characters

Expected Results:
Selected tabs are rendered with white characters


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Thorsten Wagner 2019-05-27 20:18:08 UTC
Created attachment 151713 [details]
Screenshot
Comment 2 Alex Thurgood 2019-05-28 07:16:33 UTC
Confirming

Version: 6.3.0.0.alpha1+
Build ID: 92b0b8d78d69bd917842b09af7888b402144baeb
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Thorsten Wagner 2020-01-17 19:44:00 UTC
A patch will be submitted to Gerrit in short. Patch should resolve the following issues (see screenshot attached):

(1) White text on default buttons (currently black)

(2) White text on action buttons (currently black)

(3) White text on default and action buttons during roll-over or pressing

(4) White text on selected tabs (currently black)

Some additional colors have to be defined within settings.hxx and settings.cxx. These colors are set to black as default for all VCL backends. Changing to white is implemented within macOS specific VCL backend code. Thus other VCL backends should not be affected.
Comment 4 Thorsten Wagner 2020-01-17 19:44:34 UTC
Created attachment 157235 [details]
Screenshot with patch
Comment 5 Thorsten Wagner 2020-01-17 19:55:19 UTC
Patch submitted to gerrit:

https://gerrit.libreoffice.org/c/core/+/87001
Comment 6 Alex Thurgood 2020-02-12 09:34:36 UTC
*** Bug 130466 has been marked as a duplicate of this bug. ***
Comment 7 Thorsten Wagner 2020-02-23 20:42:38 UTC
Uploaded a new revision of patch with some housekeeping:

https://gerrit.libreoffice.org/c/core/+/89313
Comment 8 Thorsten Wagner 2020-03-01 19:09:09 UTC
Created attachment 158288 [details]
Screenshot 3
Comment 9 Thorsten Wagner 2020-03-01 19:09:33 UTC
Created attachment 158289 [details]
Screenshot 4
Comment 10 Thorsten Wagner 2020-03-01 19:15:24 UTC
Current revision of patch contains a mimic to handle non key windows on macOS correctly. Attached screenshots 3 und 4 to show buttons, which have white text as long as called dialog is visible without this mimic. This kind of behaviour is handled by passing information about renderig text on controls to the backend. It has to be clarified whether is kind of handling is really needed. Maybe it could be an implementation problem of the buttons shown by the screenshots too.
Comment 11 Commit Notification 2020-03-06 19:37:35 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8d11b953c0a69f4f5eb5ca42dec3812a62d0cd0f

tdf#125532: White text on default/action buttons and selected tabs on macOS

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2020-03-06 20:46:52 UTC
Thorsten: do you think we can consider tdf#125088 as dup of this one?
Comment 13 Thorsten Wagner 2020-03-06 21:46:05 UTC
Yes,  tdf#125088 is a dup.
Comment 14 Julien Nabet 2020-03-06 22:09:01 UTC
*** Bug 125088 has been marked as a duplicate of this bug. ***
Comment 15 Mihkel Tõnnov 2020-06-12 12:38:04 UTC
This fix caused a regression with KDE5/QT5 VCL backends on Linux when using Breeze Dark theme - see bug 133929.
Comment 16 ted bug 2020-09-02 11:59:08 UTC
Created attachment 165021 [details]
screenshot, white text on grey default button macos catalina darkmode

white text on grey button and almost invisible
i previously reported in bug 127769, got fixed, and now happening again

reopen?
thanks.
Comment 17 ted bug 2020-09-02 12:00:27 UTC
(In reply to ted bug from comment #16)
> Created attachment 165021 [details]
> screenshot, white text on grey default button macos catalina darkmode
> 
> white text on grey button and almost invisible
> i previously reported in bug 127769, got fixed, and now happening again

Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

> 
> reopen?
> thanks.
Comment 18 Thorsten Wagner 2020-09-02 12:36:53 UTC
Fix is sheduled for 7.0.2 and 7.1