Bug 125088 - Default buttons have the wrong text color on macOS
Summary: Default buttons have the wrong text color on macOS
Status: RESOLVED DUPLICATE of bug 125532
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: high trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 114989 127531 127769 129654 129665 130410 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-02 18:40 UTC by Andrew Hyatt
Modified: 2020-03-06 22:09 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch which resolves this issue (1005 bytes, patch)
2019-05-02 18:43 UTC, Andrew Hyatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Hyatt 2019-05-02 18:40:47 UTC
Description:
On macOS, default buttons (blue background) have a different text color than regular buttons. LibreOffice applications use the same text color for all buttons and the end result is that they don't look quite right alongside native macOS applications.

Steps to Reproduce:
Compare default (blue) buttons in LibreOffice to that of any Cocoa app.

Actual Results:
LibreOffice default buttons have black text

Expected Results:
LibreOffice default buttons should have white text


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Andrew Hyatt 2019-05-02 18:43:50 UTC
Created attachment 151139 [details]
Patch which resolves this issue
Comment 2 Julien Nabet 2019-05-02 19:25:54 UTC
Great you've already got a patch for this!
Thought you might be interested in submitting your patch, see https://wiki.documentfoundation.org/Development/GetInvolved

Everything is detailed in this page or its links.

The whole process consists on these steps:
- retrieve sources and build LO locally.
- create an account gerrit and config.
- send a message about license
- create (already done in your case!) and submit your patch on gerrit

Don't hesitate to ping if you need more help, there's also dev forum mailing list and dev irc.
Comment 3 Tor Lillqvist 2019-05-02 20:18:08 UTC
Ah! Good catch, fun that nobody has paid attention before.
Comment 4 Tor Lillqvist 2019-05-02 20:20:34 UTC
You should use #ifdef MACOSX, though, to match existing code, not #ifdef __APPLE__.
Comment 5 Andrew Hyatt 2019-05-02 22:59:45 UTC
(In reply to Julien Nabet from comment #2)
> Great you've already got a patch for this!
> Thought you might be interested in submitting your patch, see
> https://wiki.documentfoundation.org/Development/GetInvolved
> 
> Everything is detailed in this page or its links.
> 
> The whole process consists on these steps:
> - retrieve sources and build LO locally.
> - create an account gerrit and config.
> - send a message about license
> - create (already done in your case!) and submit your patch on gerrit
> 
> Don't hesitate to ping if you need more help, there's also dev forum mailing
> list and dev irc.

Thanks! I sent the license email and set up Gerrit. I pushed my changes to it, is there anything I have to do to link this bug report to it?

(In reply to Tor Lillqvist from comment #4)
> You should use #ifdef MACOSX, though, to match existing code, not #ifdef
> __APPLE__.

Good to know, I changed the the patch on Gerrit to use that macro instead.
Comment 6 Telesto 2019-05-03 06:02:04 UTC
Probably the same/related bug 96359
Comment 7 Julien Nabet 2019-05-03 06:34:59 UTC
(In reply to Andrew Hyatt from comment #5)
> >...
> 
> Thanks! I sent the license email and set up Gerrit. I pushed my changes to
> it, is there anything I have to do to link this bug report to it?
> ...
Yes, you can just prefix the first line of your commit with the tdf.
Eg: tdf#125088 ...
Don't bother, I did it for you.

If needed, you can use "amend" option to update a patch.
Comment 8 Commit Notification 2019-05-03 10:15:45 UTC
Andrew Hyatt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/89775fd396e413daaf0e71710211075450bdc0ed%5E%21

tdf#125088 Make button text white for blue buttons on macOS

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Tomaz Vajngerl 2019-05-04 14:32:20 UTC
A better solution would be to add a new color to the StyleSetting and set it to black by default and white in the macOS backend. No need to that ugly ifdef...
Comment 10 Adolfo Jayme 2019-06-01 03:27:28 UTC
*** Bug 114989 has been marked as a duplicate of this bug. ***
Comment 11 Adolfo Jayme 2019-06-01 03:29:10 UTC
Please don’t hardcode white; call the proper variable instead. This patch has caused bug 125610.
Comment 12 Adolfo Jayme 2019-06-13 06:03:59 UTC
The commit above seems to have caused bug 125795 as well.
Comment 13 Alex Thurgood 2019-09-04 05:55:04 UTC
And also bug 127302 ...
Comment 14 Commit Notification 2019-09-05 03:03:41 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ebd7af9aebb5b76255aa299dd8047cb4266215a4%5E%21

tdf#125610: Revert "tdf#125088 Make button text white for blue buttons on macOS"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-09-05 03:09:55 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/ab5da884b16aa54aab8e9773a6e8dbf24e752c36%5E%21

tdf#125610: Revert "tdf#125088 Make button text white for blue buttons on macOS"

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Alex Thurgood 2019-09-13 06:00:52 UTC
*** Bug 127531 has been marked as a duplicate of this bug. ***
Comment 17 EarlsFurniture 2019-09-13 06:24:03 UTC
As it seems my bug 127351 was a duplicate, the patch works for everything but when Graphite is selected as the MacOS highlight color. (white is used instead of graphite in LO)
Comment 18 Alex Thurgood 2019-10-01 05:36:23 UTC
*** Bug 127769 has been marked as a duplicate of this bug. ***
Comment 19 Alex Thurgood 2019-10-01 05:37:29 UTC
(In reply to Alex Thurgood from comment #18)
> *** Bug 127769 has been marked as a duplicate of this bug. ***

The same problem occurs with dark mode, per bug 127769.
Comment 20 Xisco Faulí 2019-12-27 16:03:24 UTC
*** Bug 129654 has been marked as a duplicate of this bug. ***
Comment 21 Alex Thurgood 2020-02-05 07:10:19 UTC
*** Bug 130410 has been marked as a duplicate of this bug. ***
Comment 22 Alex Thurgood 2020-02-05 07:11:35 UTC
*** Bug 129665 has been marked as a duplicate of this bug. ***
Comment 23 Julien Nabet 2020-02-05 08:16:55 UTC
Andrew: do you want to give a try to Tomaz's suggestion from https://bugs.documentfoundation.org/show_bug.cgi?id=125088#c9 ?
No obligation of course but if you don't feel like to do it, unassign yourself from the bug so other people may take it.
Comment 24 Thorsten Wagner 2020-02-05 10:46:24 UTC
Already submitted a patch for this issue too:

https://bugs.documentfoundation.org/show_bug.cgi?id=125532

For this patch extended style settings have been implemented to resolve missing white text tabs as well as on push buttons too.

Patch is available for Gerrit review.

As both patches will be conflicting, a decision is required which one to choose.
Comment 25 Xisco Faulí 2020-02-19 17:12:00 UTC
Changing priority to 'high' since the number of duplicates is 5 or more
Comment 26 Julien Nabet 2020-02-20 14:53:37 UTC
Let's unassign since no feedback from Andrew since the revert.
Moreover, Thorsten submitted a patch here:
https://gerrit.libreoffice.org/c/core/+/87001
Comment 27 Julien Nabet 2020-03-06 22:09:01 UTC
I put this one as the dup because the tdf referenced for the fix is tdf#125532

*** This bug has been marked as a duplicate of bug 125532 ***