Download it now!
Bug 96359 - Focused button’s text is not inverted on OS X, thus hard to see
Summary: Focused button’s text is not inverted on OS X, thus hard to see
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: accessibility
: 98047 104246 116988 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2015-12-09 14:46 UTC by libreoffice
Modified: 2019-05-03 12:39 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
blue OK Button (7.05 KB, image/png)
2015-12-10 13:11 UTC, libreoffice
Details
grey button (6.84 KB, image/png)
2015-12-10 13:12 UTC, libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice 2015-12-09 14:46:37 UTC
Some buttons (e.g. "OK" in Preferences) have black text on a dark blue button surface. That's hard to read.

=> Can the button surface be lighter, or the text be white instead?

MacOS 10.11.1
System Preferences/General/Appearance = Blue
Comment 1 Alex Thurgood 2015-12-10 08:14:58 UTC
Confirming on 

Version: 5.2.0.0.alpha0+
Build ID: eb38493c4101d8777052267ee83a5d4f883dd9ac
Threads 2; Ver: -; Render: default; 

Locale: fr-FR (fr.UTF-8)

The default for OSX apps is to switch to white text when a button or dropdown toolbar is selected, which is clearer than black on gradient blue.
Comment 2 Yousuf Philips (jay) (retired) 2015-12-10 12:10:19 UTC
Would be good to get a screenshot of how back this looks.
Comment 3 libreoffice 2015-12-10 13:11:25 UTC
Created attachment 121201 [details]
blue OK Button
Comment 4 libreoffice 2015-12-10 13:12:56 UTC
Created attachment 121202 [details]
grey button
Comment 5 Yousuf Philips (jay) (retired) 2015-12-11 09:59:28 UTC
It would be interesting to know if it is possible to have a per button label color as it seems that the label color is a single setting for all buttons from the screenshots.
Comment 6 Alex Thurgood 2015-12-14 16:34:31 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> It would be interesting to know if it is possible to have a per button label
> color as it seems that the label color is a single setting for all buttons
> from the screenshots.

Hi Jay,

From an OS user prefs level, the blue colour is attributed to buttons, windows, and menus as a whole, and there doesn't appear to be any finer-grained setting such as the one you indicate above (unless this is hidden in the general OS UI API). I would assume that the inverted font colour is also a standardized, i.e. non-customizable property as well. On the whole apps are expected to respect the Apple HIG (which LO clearly does not), so perhaps there is no provision for "messing about" with such a setting. It would need someone with OSX UI programming experience to find out, I guess.
Comment 7 isaacaweiss 2016-02-16 16:56:58 UTC
I see this issue is marked as applying to all Mac OS X versions. However, versions of OS X prior to 2014 actually used a slightly different UI, and LibreOffice's buttons look correct with it. (See, for example, the "New features in LibreOffice 5.1" videos, apparently made on OS X 10.8 or 10.9.) This is only a bug with versions since 2014. Is there a way to more precisely mark which systems are affected?
Comment 8 libreoffice 2016-02-16 17:50:43 UTC
I am currently running the following while observing this issue:
- Libre Office 5.1.0.3
- Macos 10.11.3

Could the graphics driver, or graphics card be the culprit?
Comment 9 isaacaweiss 2016-02-16 18:28:52 UTC
(In reply to libreoffice from comment #8)
> I am currently running the following while observing this issue:
> - Libre Office 5.1.0.3
> - Macos 10.11.3
> 
> Could the graphics driver, or graphics card be the culprit?

That's an interesting question. I'm inclined to doubt it, though. Wouldn't every other application be utilizing the same thing?
Comment 10 isaacaweiss 2016-02-22 00:05:25 UTC
I feel certain this one is easy to fix for a very significant benefit. Somewhere in LibreOffice's code it specifies that the text of buttons <i>must</i> be black, and removing those lines will let the color follow the default system UI. The question is, where are those lines of code?
Comment 11 Alex Thurgood 2016-03-21 08:45:38 UTC
*** Bug 98047 has been marked as a duplicate of this bug. ***
Comment 12 Julien Nabet 2016-06-20 19:37:46 UTC
Ok button from prefs comes from src/hrc. I wonder if only these are concerned.
Anyway, even if it's the case, I don't know where the color is defined for them.
Comment 13 Adolfo Jayme 2016-11-29 06:32:59 UTC
*** Bug 104246 has been marked as a duplicate of this bug. ***
Comment 14 QA Administrators 2017-11-30 06:26:14 UTC Comment hidden (obsolete, spam)
Comment 15 Adolfo Jayme 2018-04-13 12:13:45 UTC
*** Bug 116988 has been marked as a duplicate of this bug. ***
Comment 16 QA Administrators 2019-04-14 02:50:01 UTC Comment hidden (obsolete)