Bug 134825 - Blank comment disappears if not filled in immediately
Summary: Blank comment disappears if not filled in immediately
Status: RESOLVED DUPLICATE of bug 73446
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-07-15 10:05 UTC by Orwel
Modified: 2020-07-17 13:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orwel 2020-07-15 10:05:11 UTC
Description:
If you want to start to fill a new blank comment with a copied text, you can not create it before you clipboard the text firstly as if you create a blank new comment and try to copy the text from other location of the document (text or other comment), you loose the new comment.

This is annoying as you have to remember firstly copy the text, than only create the comment.

Steps to Reproduce:
1.open an .odt file, write some text
2.this step is not necessary) click insert comment and fill it with some text
3.move your cursor to another word
4.click insert comment
5.move the cursor (lefrt click mouse button) to previous comment (or text in the document). 

Actual Results:
The comment disappears.

Expected Results:
The comment should preserve.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.6.2 (x64)
Build ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: sk-SK (sk_SK); UI-Language: en-GB
Calc: threaded
Comment 1 Heiko Tietze 2020-07-16 09:29:52 UTC
Quite handy, on the other hand, when the comment disappear after text has been deleted. Otherwise you always have to find the Delete function in the tiny menu. Weights more to me, what do you think?
Comment 2 Orwel 2020-07-16 09:48:10 UTC
Ok, if this is a intended behaviour... But in my opinion this is not useful. 
If you want to delete comment by deleting text, these are the possibilities:
1.long press backspace/delete
2.CTRL+A, DELETE
3. 2 clicks with mouse (small menu, delete comment).
1/2 has neither less steps nor is time saving.

I mean, if I PUT a comment,Ii do not want it disappears only because it is empty... There are many reasons to keep it empty (e. g. you want to look for some text in the document by scrolling it, you want to enter the text into the comment later, you want to copy some text into the comment....). In all this cases an empty preserved comment make the work easier. if it disappears, you have to look the correct position for inserting the comment one more time. I work with documents a lot, and this behaviour is in my opinion very time wasting and strange. 

The one and only advantage is "auto-delete" of the comment, when you manually delete the text in in, what is in my opinion much more less likely then using a blank comment for purposes I described above.
Comment 3 Timur 2020-07-16 14:04:20 UTC
Rule of thumb is search before reporting, to save other people's time. 
Looks duplicate. 


Heiko, please see that opposite request is for Calc, this should be unified behavior. https://bugs.documentfoundation.org/show_bug.cgi?id=83575

*** This bug has been marked as a duplicate of bug 73446 ***
Comment 4 Telesto 2020-07-16 14:15:34 UTC
(In reply to Timur from comment #3)
> Rule of thumb is search before reporting, to save other people's time. 
> Looks duplicate. 
> 
> 
> Heiko, please see that opposite request is for Calc, this should be unified
> behavior. https://bugs.documentfoundation.org/show_bug.cgi?id=83575
> 
> *** This bug has been marked as a duplicate of bug 73446 ***

This is maybe related to bug 83575, but not a duplicate. Writer and Calc a different things. And don't even share that much code as far I'm aware..
Comment 5 Telesto 2020-07-16 14:31:29 UTC
Hmm.. Lets say
I'm still not a fan of disappearing empty text boxes (of course different topic, but some similarity)

In that line I would agree with Orwel. Word does the same thing as Orwel expects (not that copying gui of other programs is an argument). But they probably had the same argument at some place some day somewhere.

And If you insert a comment, you probably want to use it. So disappearing of you copy something isn't what you would expect. And I don't like programs doing things by its own..

Comment boxes should be delete manually; empty/unempty. Emptying out a comment box and leaving it, does remove the comment box too.. Not a fan. Yes, you might call it feature/service. But you could also be up to something else, and that makes it very frustrating.

The story for not disappearing is better, compared to the argument of disappearing comment; IMHO

[As said, same holds true for the text box (off-topic, but arguing along the same line]. I those boxes are disappearing every time, I have to type place holders to be able to paste!, but that's a different bug I reported a long time ago. And stuck at the 'hidden frame' issue. Still wanting the kind of borders as Impress used for the template text boxes]
Comment 6 Timur 2020-07-16 15:30:23 UTC

*** This bug has been marked as a duplicate of bug 73446 ***
Comment 7 Timur 2020-07-16 15:31:51 UTC
I marked as a duplicate of Writer bug, just read more carefully.
Comment 8 Heiko Tietze 2020-07-17 12:31:35 UTC
(In reply to Timur from comment #3)
> opposite request is for Calc in bug 83575

Smells like an option, though I'd prefer a clear solution. Same but different is the situation with empty text boxes. And I think it's easier to enter a dummy character if text has not been copied than deleting the object with two clicks or some hard to figure interaction. Smart solution might be to keep the object when created newly but remove when it had content before. This would be my choice.
Comment 9 Telesto 2020-07-17 13:52:59 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Timur from comment #3)
> > opposite request is for Calc in bug 83575
> 
> Smells like an option, though I'd prefer a clear solution. Same but
> different is the situation with empty text boxes. And I think it's easier to
> enter a dummy character if text has not been copied than deleting the object
> with two clicks or some hard to figure interaction. Smart solution might be
> to keep the object when created newly but remove when it had content before.
> This would be my choice.

LibreOffice should refrain interfering with user actions; if you have an empty comment/textbox whatever.. you should delete it manually; same way as insert.
And it's not to hard, you delete shapes/images the same way. Click/Delete.

And why does the Interactive frame work differently.  \

Moving to less convincing arguments: 
* Why not delete an empty table too ;-). 
* Or LibreOffice should learn mindreading. So insert an comment box/text box at the point you need it. 

I really want to be in control; Software attempting being smart, but doing the opposite is quite frustrating. I prefer to be in control. And putting placeholders to keep things around, sounds like workaround. And if this behaviour is a service (like the autocorrect markdown support), make it an option. Yes bloating the interface, I know. 

I lost textboxes because I wanted to move it first (but was empty). Because I wanted to paste and it was empty. every time I have remember.. but something in it first. And have to make sure it gone. And a empty comment box/text box won't disappear if you press CTRL+Z afterwards