Download it now!
Bug 134841 - Print Preview: Image not displayed (gtk3 and win)
Summary: Print Preview: Image not displayed (gtk3 and win)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0
Keywords: bibisected, bisected, regression
: 134808 135183 (view as bug list)
Depends on:
Blocks: Regressions-cairo-speedup
  Show dependency treegraph
 
Reported: 2020-07-15 20:03 UTC by Xisco Faulí
Modified: 2020-08-28 06:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
GTK3 vs GEN ( 7.1 master ) (182.11 KB, image/png)
2020-07-15 20:03 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-07-15 20:03:03 UTC
Created attachment 163078 [details]
GTK3 vs GEN ( 7.1 master )

Steps to reproduce:
1. Open attachment 163060 [details] from bug 134792
2. File - Print Preview
3. Go to page 2

-> Image is blank. See screenshot comparing GTK3 and GEN


reproduced in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-15 20:05:10 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=828504974d70111e4a35b31d579cf42fe660a660

author	Armin Le Grand (Collabora) <armin.le.grand@me.com>	2020-02-21 16:58:17 +0100
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2020-02-21 20:16:59 +0100
commit	828504974d70111e4a35b31d579cf42fe660a660 (patch)
tree	4c2f7720b3efaecf55b8fa7b9b3eeccb278160e6
parent	813cde918338bccc4f711230616340cad2c1d4a0 (diff)
tdf#130768 speedup huge pixel graphics Cairo

Bisected with: bibisect-linux64-7.0

Adding Cc: to Armin Le Grand
Comment 2 Xisco Faulí 2020-07-15 20:05:37 UTC
@Caolán, I thought you might be interested in this issue
Comment 3 Xisco Faulí 2020-07-15 20:22:28 UTC
oh, actually it's also reproducible in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 616a47c9570f9ce67b18a124f08f4a342bff3468
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

interesting it's not reproducible with gen
Comment 4 Caolán McNamara 2020-07-15 20:32:55 UTC
as a data point
export SAL_DISABLE_MM02_GOODIES=1
makes no difference
Comment 5 Davor 2020-07-16 05:48:02 UTC Comment hidden (obsolete)
Comment 6 Caolán McNamara 2020-07-16 08:58:01 UTC
while reverting the hunk affecting vcl/source/outdev/bitmap.cxx does make a difference
Comment 7 Caolán McNamara 2020-07-16 10:10:44 UTC
Dumping the surface to be painted looks good, and the position is correct. But it appears to be clipped entirely so nothing gets painted. The clip region used seems bogus.
Comment 8 Caolán McNamara 2020-07-16 10:15:17 UTC
https://gerrit.libreoffice.org/c/core/+/98892
Comment 9 Xisco Faulí 2020-07-16 11:20:12 UTC
*** Bug 134808 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2020-07-16 13:15:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fa47f9781fff89698a68353f9f37ea3ac6bda43c

tdf#134841 image totally clipped out

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-07-16 15:00:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d44ddfce0766f57ac7d14978dd9e12813af93ce7

tdf#134841 image totally clipped out

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-07-16 15:02:16 UTC
didn't check windows but I assume its the same problem and should work now too
Comment 13 Commit Notification 2020-07-17 09:20:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-0":

https://git.libreoffice.org/core/commit/e04cc65a04443d0399f685f00db077a81cf91838

tdf#134841 image totally clipped out

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2020-07-20 10:20:26 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 15 Xisco Faulí 2020-07-20 11:30:11 UTC
Also verified in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1db7decf3fb172542f5fce03ce7bf0cb310d1ffc
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded
Comment 16 Timur 2020-07-28 07:29:32 UTC
*** Bug 135183 has been marked as a duplicate of this bug. ***