Bug 134865 - Some characters not exported to PDF
Summary: Some characters not exported to PDF
Status: RESOLVED DUPLICATE of bug 129523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2020-07-16 13:46 UTC by Fiable.biz
Modified: 2020-11-27 12:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file (10.77 KB, application/vnd.oasis.opendocument.text)
2020-07-16 13:48 UTC, Fiable.biz
Details
The exported PDF file. (2.89 KB, application/pdf)
2020-07-16 13:48 UTC, Fiable.biz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fiable.biz 2020-07-16 13:46:40 UTC
Description:
Some characters visible in a document disappear when it is printed, and seem to be hidden when it is exported into PDF, though they are still visible in print preview and are in the PDF file.

Steps to Reproduce:
1.In LibreOffice for Fedora 32 workstation 64 bits, open a new document (either Writer, Calc, Drawing, Presentation, Formula, HTML, XML or Business card).
2.Copy the character "Motor scooter" Unicode AF6F5 from your character manager and paste it into the LibreOffice document,
3.Choose File→Export as→Export directly as PDF (or, for the components where such an option doesn't exist, "Export as PDF"→ "Export", without modifying the default options).
4.Open the PDF document with LO Drawing, with GIMP and with Evince, and print it on Samsung Xpress M2070.

Actual Results:
The scooter appears in Drawing, but not in Gimp, Evince nor on the paper.

Expected Results:
The scooter should appear on all outputs.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
It seems the character is not converted into an image, so that the applications relying on pictures don't show it.

$ sudo glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 2000 (SNB GT1)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.1.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 20.1.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 20.1.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 Fiable.biz 2020-07-16 13:48:06 UTC
Created attachment 163115 [details]
Writer file

The one character LO file.
Comment 2 Fiable.biz 2020-07-16 13:48:42 UTC
Created attachment 163116 [details]
The exported PDF file.
Comment 3 Fiable.biz 2020-07-16 14:09:01 UTC
I wrongly copied the Unicode code: read "1F6F5" (instead of "AF6F5").
Comment 4 Telesto 2020-07-16 19:57:24 UTC
No issue on Windows with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 5 Fiable.biz 2020-07-16 20:18:07 UTC
I've found this:
https://ask.libreoffice.org/en/question/142583/a-character-appears-blank-when-exporting-as-pdf
which proves the problem also exists (or existed 2 years ago) in McOS and Microsoft Windows, but I don't understand the explanation, because PDF is supposed to include the font, not only the character code. So if LO exported the correct font, there should be no problem. Is it possible that LO substitute silently a font for the screen display, but don't make the substitution when exporting to PDF?
Comment 6 Buovjaga 2020-11-25 18:42:03 UTC
Not reproduced, displays fine in Okular and GIMP

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+
Build ID: c638985dd3a63cdf76b2af67cd890f656a9c38eb
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 November 2020
Comment 7 Buovjaga 2020-11-27 12:12:22 UTC
I found a relevant duplicate

*** This bug has been marked as a duplicate of bug 129523 ***