Bug 134942 - Tab character not allowed at beginning of line, removed from middle of line
Summary: Tab character not allowed at beginning of line, removed from middle of line
Status: RESOLVED DUPLICATE of bug 134548
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-19 02:09 UTC by www.MKRD.info
Modified: 2020-07-19 08:31 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description www.MKRD.info 2020-07-19 02:09:34 UTC
Noticed immediately with 6.4.5.2 install on Linux Mint (not tested on Winblows). Confirmed by another user on forum.
1) On beginning of an empty line, I am forbidden from entering a TAB character. NOTHING happens when TAB key is pressed. TAB is allowed if characters are present on the line, and are typed FIRST before the position on which tab is to be inserted. It then works fine if it is not the first item on the line.
2) Opening an existing document into which I inserted TAB characters in middle of lines, to force a certain formatting, with TABS being in middle of a sentence to manually "indent" it from the left side, has caused those pre-existing tab stops to be WIPED OUT. All formatting is now NOT how I intended to be.
I want the old behavior back. If I want to put a tab character ANYWHERE I damn please, then I better be able to put a tab stop anywhere I want.
Comment 1 www.MKRD.info 2020-07-19 02:36:07 UTC
Looking at this a bit further, it appears that tab space is entered, it is just "useless" and "invisible". Tab spaces appear to be invisible because while they have stopped indenting space, however it takes same number of backspace hits as the number of tabs I have entered, before moving cursor position backwards, thus tab has become "invisible" and useless.
Comment 2 Telesto 2020-07-19 08:31:05 UTC
A known bug. Slipped into 6.4 branch with 6.4.5. Will be solved with 6.4.6. Alternative is reverting to 6.4.4

*** This bug has been marked as a duplicate of bug 134548 ***