Download it now!
Bug 134948 - FILESAVE/OPEN DOC: Anchor is added to a new bullet
Summary: FILESAVE/OPEN DOC: Anchor is added to a new bullet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.1.0
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-07-19 10:41 UTC by Telesto
Modified: 2020-09-01 17:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (236.64 KB, application/vnd.oasis.opendocument.text)
2020-07-19 10:41 UTC, Telesto
Details
df2123RT.pdf: output from LO 6.4 after saving and loading in .doc format. (335.35 KB, application/pdf)
2020-08-05 09:58 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-19 10:41:31 UTC
Description:
FILESAVE/OPEN DOC: Anchor is added to a new bullet 

Steps to Reproduce:
1. Open the attached file
2. Save as DOC
3. Blue shape anchor has separate bullet 

Actual Results:
Empty bullet holding the anchor

Expected Results:
No empty bullet for anchor


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
4.4.7.2

Not in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 1 Telesto 2020-07-19 10:41:43 UTC
Created attachment 163262 [details]
Example file
Comment 2 Telesto 2020-07-19 10:42:10 UTC
Step 2b -> File Reload
Comment 3 Xisco Faulí 2020-08-04 12:12:21 UTC
I've tried to bisect it with bibisect-44max and it points me to https://cgit.freedesktop.org/libreoffice/core/commit/?id=bfb978334cea775b8ae5c40ceea050ea0660d80a, which doesn't seems related.

@Buovjaga, could you please give it a try on windows ?

@Justin, I thought you might be interested in this issue
Comment 4 Buovjaga 2020-08-04 13:15:55 UTC
(In reply to Xisco Faulí from comment #3)
> I've tried to bisect it with bibisect-44max and it points me to
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=bfb978334cea775b8ae5c40ceea050ea0660d80a, which doesn't seems related.
> 
> @Buovjaga, could you please give it a try on windows ?

Can't right now as I don't have the repos.
Comment 5 Justin L 2020-08-04 13:24:37 UTC
I got the same results as the other version of this file for bug 134951.
linux bibisect-44max commit 54d52f6062dffaa930f008c9e1655132dd395c83
    commit 80fd9fb7209cfd5c0622ee99d59e42e6db32f021
    Author:     Umesh Kadam <umesh.kadam@synerzip.com>
    CommitDate: Thu May 22 02:31:53 2014 -0500
        tdf#78333 : SdtContent and a Shape overlapping causes corruption

So, this too seems to be related to bPostponedText. I'm afraid to touch this stuff even with a 10-foot pole.
Comment 6 Justin L 2020-08-05 09:58:49 UTC
Created attachment 163961 [details]
df2123RT.pdf: output from LO 6.4 after saving and loading in .doc format.

It is not so much that a new bullet is created, but that the text is postponed till the next line - so there are two entries in one on the that line, and an empty paragraph in the previous line.

"Recep Tayyip Erdoğan(2014-....)ürkiye Cumhuriyeti’nin Cumhurbaşkanları: 7"
Comment 7 Commit Notification 2020-08-14 06:46:38 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6457d46967f8dbb41199b750d59edde839f24b5d

tdf#132726 tdf#134948 doc/rtf export: don't PostponeWritingText

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.