Bug 135104 - Feedback on Styles Inspector
Summary: Feedback on Styles Inspector
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-07-24 15:50 UTC by Luke Kendall
Modified: 2020-08-15 14:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2020-07-24 15:50:38 UTC
Okay, so the Styles Inspector is reached via
Tools-> Options -> Advanced -> Enable experimental features
After a restart of LO, there's a new icon for the Styles Inspector under the Navigator icon in the Manage Styles Dialog

1/
A couple of tiny points:
- It's not resizeable at the moment (the panel is, but not the part displaying the styles)
- ContinueingPreviousSubTree boolean under Direct Formatting: "continuing" = tiny typo?

2/
Under Paragraph Styles in my document I have just
> Default Paragraph Style
> Text Body
> Chapter Body
Character Styles

I vaguely remember the suggestion that vertical placement maybe meant the style was derived from the one above?
Note: without any indentation, there's no problem with showing complex hierarchies (e.g. when multiple different styles all derive from, say, Text Body), because a paragraph can't be two different 'leaf' styles.

I still think at least a pixel or few of indentation would make the structure clearer.

3/
Selecting the TOC, I see the styles change, now listing Index and Contents 1.
So now I can see it shows the styles of the current text.

4/
I'm certain my main text is all in my Chapter Body paragraph style.
But the existing para style text box (up near the top left of the doc window, under Files, Edit etc.) incorrectly shows Text Body.

I'm also certain the 1st paragraph of each chapter is in my ChapterBdy1st style.
It too is showing as just Text Body.

* Maybe a bug introduced by the experimental feature?

5/
The para style displayed in the Styles Inspector (SI) APPEARS to show that the first para of the chapter is Text Body style, simply because Text Body style is visible and 'unfolded'.

It was only when I scrolled down in the SI I realised that indeed the inheritance tree now shows
> Default[...]
> Text Body
> Chapter Body
> ChapterBdy1st

* That seems a mild usability problem: having the visible style showing a parent style rather than the actual style is misleading.
** Suggestion: Show the styles "folded up", not "unfolded" by default:
   in that case you'd very likely see the actual style.
** Suggestion alternative: scroll the SI view to focus on the actual (leaf)
   style, not a parent style

6/
It's super hard to compare styles, because when you click to a different paragraph the SI refreshes and goes back to its default place.

7/
Direct Formatting is really confusing to me in what it's showing.
I'm in a paragraph of text that I believe has no DF.
The DF section in the SI shows:
Oh. I can't copy and paste that text. So to compare it I'll need to either laboriously write each one down myself, or take a screenshot. :-(
Okay, I've done that: the 2nd para shows all the same DF but adds one more thing: "Rsid 304289352"
I don't understand why there are any items under DF because as far as I know I applied no DF.

8/
I'm also puzzled that ParaStyleName appears under DF. Does that mean because I have applied a paragraph style the para is somehow now styled by Direct Formatting?
Selecting the para and clearing DF (Ctrl-M) clears most of those items, even though they were all properties provided by the paragraph style; to take just two examples, CharHeight 10.5 and CharFontName Georgia, which were provided by the paragraph style, not by DF (as far as I'm aware!)

9/
Likewise, very puzzled that the PageStyleName appears under DF.

10/
I have no idea what Character Styles in the SI is; maybe it's not implemented yet?
Or maybe there are no character styles applied in that paragraph?

11/
It doesn't appear as though Heiko Tietze's suggestion for Find & Replace has been addressed in this build - having separate Styles and Text tabs for the different kinds of searches for F&R.

Personal overall assessment:
Looks promising, though it has some usability issues and may be a bit confusing at present.

HTH!
Comment 1 Luke Kendall 2020-07-24 15:53:57 UTC
Also, when I just closed the Styles Inspector panel just after submitting the earlier comment in the wrong place (the meta bug), Writer crashed.

After it restarted, the SI window appeared to be "rolled up". It wasn't, the main body was just drawn about 1 pixel high. I could drag it to resize it.

Closing it after the recovery was fine.
Comment 2 Mike Kaganski 2020-07-24 16:45:39 UTC
(In reply to Luke Kendall from comment #0)
> 10/
> I have no idea what Character Styles in the SI is; maybe it's not
> implemented yet?
> Or maybe there are no character styles applied in that paragraph?

The latter. Please apply a character style, and check.

> 11/
> It doesn't appear as though Heiko Tietze's suggestion for Find & Replace has
> been addressed in this build - having separate Styles and Text tabs for the
> different kinds of searches for F&R.

I'm sorry, what is this about? I don't remember anything related to F&R in the context of this project...? Probably something had fall out of the scope? Could you please point to this. Thanks!
Comment 3 Luke Kendall 2020-07-24 16:50:00 UTC
(In reply to Mike Kaganski from comment #2)
> (In reply to Luke Kendall from comment #0)
> > 10/
> > I have no idea what Character Styles in the SI is; maybe it's not
> > implemented yet?
> > Or maybe there are no character styles applied in that paragraph?
> 
> The latter. Please apply a character style, and check.
> 
> > 11/
> > It doesn't appear as though Heiko Tietze's suggestion for Find & Replace has
> > been addressed in this build - having separate Styles and Text tabs for the
> > different kinds of searches for F&R.
> 
> I'm sorry, what is this about? I don't remember anything related to F&R in
> the context of this project...? Probably something had fall out of the
> scope? Could you please point to this. Thanks!

https://bugs.documentfoundation.org/show_bug.cgi?id=133300

My involvement was because of the feature request to be able to find where a page style was applied.
Comment 4 Mike Kaganski 2020-07-24 16:53:29 UTC
(In reply to Luke Kendall from comment #3)
> (In reply to Mike Kaganski from comment #2)
> 
> https://bugs.documentfoundation.org/show_bug.cgi?id=133300

This is a separate issue, and has nothing to do with Styles Inspector (a GSoC project with limited scope), although I also would like to have that issue solved. Just not in this issue :-)
Comment 5 Shivam Kumar Singh 2020-08-07 03:43:15 UTC
(In reply to Luke Kendall from comment #0)
> Okay, so the Styles Inspector is reached via
> Tools-> Options -> Advanced -> Enable experimental features
> After a restart of LO, there's a new icon for the Styles Inspector under the
> Navigator icon in the Manage Styles Dialog
> 
> 1/
> A couple of tiny points:
> - It's not resizeable at the moment
Fixed at tdf#135344

> - ContinueingPreviousSubTree boolean under Direct Formatting: "continuing" =
> tiny typo?
Fixed at patch for human readable and translatable proeprties. tdf#134560 tdf#135107

> 2/
> Under Paragraph Styles in my document I have just
> > Default Paragraph Style
> > Text Body
> > Chapter Body
> Character Styles
> 
> I vaguely remember the suggestion that vertical placement maybe meant the
> style was derived from the one above?
All the styles should be on the same level. NOT A BUG

> 3/
> Selecting the TOC, I see the styles change, now listing Index and Contents 1.
> So now I can see it shows the styles of the current text.


> 4/
> I'm certain my main text is all in my Chapter Body paragraph style.
> But the existing para style text box (up near the top left of the doc
> window, under Files, Edit etc.) incorrectly shows Text Body.
Resolved at tdf#135178


> I'm also certain the 1st paragraph of each chapter is in my ChapterBdy1st
> style.
> It too is showing as just Text Body.
Resolved at tdf#135178

> 5/
> The para style displayed in the Styles Inspector (SI) APPEARS to show that
> the first para of the chapter is Text Body style, simply because Text Body
> style is visible and 'unfolded'.
> 
> It was only when I scrolled down in the SI I realised that indeed the
> inheritance tree now shows
> > Default[...]
> > Text Body
> > Chapter Body
> > ChapterBdy1st
> 
> * That seems a mild usability problem: having the visible style showing a
> parent style rather than the actual style is misleading.
> ** Suggestion: Show the styles "folded up", not "unfolded" by default:
>    in that case you'd very likely see the actual style.
> ** Suggestion alternative: scroll the SI view to focus on the actual (leaf)
>    style, not a parent style
> 
> 6/
> It's super hard to compare styles, because when you click to a different
> paragraph the SI refreshes and goes back to its default place.
> 
> 7/
> Direct Formatting is really confusing to me in what it's showing....
> Okay, I've done that: the 2nd para shows all the same DF but adds one more
> thing: "Rsid 304289352"
> I don't understand why there are any items under DF because as far as I know
> I applied no DF.
Resolved at tdf#135106

> 
> 8/
> I'm also puzzled that ParaStyleName appears under DF. Does that mean because
> I have applied a paragraph style the para is somehow now styled by Direct
> Formatting?
Resolved at tdf#135106
 
> 9/
> Likewise, very puzzled that the PageStyleName appears under DF.
Resolved at tdf#135106
> 
> 10/
> I have no idea what Character Styles in the SI is; maybe it's not
> implemented yet?
> Or maybe there are no character styles applied in that paragraph?
Apply a character style other than Default and please check again

> 11/
> It doesn't appear as though Heiko Tietze's suggestion for Find & Replace has
> been addressed in this build - having separate Styles and Text tabs for the
> different kinds of searches for F&R.

> Personal overall assessment:
> Looks promising, though it has some usability issues and may be a bit
> confusing at present.
> 
> HTH!

Thank you for this amazing testing. Most of the issues are resolved now. Would request you to kindly test again with the latest patch build.
Comment 6 Luke Kendall 2020-08-07 06:51:59 UTC
(In reply to Mike Kaganski from comment #2)
> (In reply to Luke Kendall from comment #0)
> > 10/
> > I have no idea what Character Styles in the SI is; maybe it's not
> > implemented yet?
> > Or maybe there are no character styles applied in that paragraph?
> 
> The latter. Please apply a character style, and check.
> 
> > 11/
> > It doesn't appear as though Heiko Tietze's suggestion for Find & Replace has
> > been addressed in this build - having separate Styles and Text tabs for the
> > different kinds of searches for F&R.
> 
> I'm sorry, what is this about? I don't remember anything related to F&R in
> the context of this project...? Probably something had fall out of the
> scope? Could you please point to this. Thanks!

https://bugs.documentfoundation.org/show_bug.cgi?id=133300

My involvement was because of the feature request to be able to find where a page style was applied.

Shivam asked if I could try out the latest build.
I've found https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/2020-08-05_04.03.50/master~2020-08-05_04.03.50_LibreOfficeDev_7.1.0.0.alpha0_Linux_x86-64_deb.tar.gz but I'm right now having a look around to see if I can find an AppImage, as that made trying it out super easy.
Comment 7 Luke Kendall 2020-08-07 06:54:54 UTC
Hmm, looks like they stopped being made a week ago?
https://dev-builds.libreoffice.org/pre-releases/deb/x86_64/
Comment 8 Luke Kendall 2020-08-07 07:06:04 UTC
I found https://github.com/antoniofaccioli/libreoffice-appimage which looks like I can roll my own. Doing so now.
Comment 9 Luke Kendall 2020-08-15 14:02:49 UTC
I finally built an AppImage and I'm now trying it.

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-11_15:13:29
Calc: threaded

SI = Styles Inspector.
Numbers like 1/ refer to my original comment.

1/
Great: SI is now resizeable.

2/ & 5/
Paragraph Styles are now intuitive to me, appearing in order of inheritance/derivation.


12/
Clicking on Styles icon after clicking on Styles Inspector crashed Writer.

13/
When Writer restarted, the Styles Inspector showed a somewhat more graphics inspector. I think maybe it represented a paragraph style but I wasn't sure.
Hitting F11 (I wanted to open the styles dialogue and examine a paragraph style in detail with that), changed the Styles panel to a less graphical mode.

I opened the Paragraph Style inspector, and wanted to compare some of those properties to what I had seen in the view of the SI I'd seen upon restart. But I discovered that none of the SI icons arranged vertically on the right side function while the Paragraph Styles dialogue is open. I don't understand why. It makes it hard to compare. I suspect I'd need to take a screenshot image and view that screenshot separately.

14/
Closing the Paragraph Styles dialogue let me click on icons on the right of the SI. I clicked on Styles (I think) and the SI panel closed.

15/
With the SI panel open, clicking on the 4th icon on the stack of SI icons closes the SI panel. That makes no sense to me. A bug? F11 reopens the SI.

16/
Clicking on the Gallery icon on the SI crashed Writer.

17/
Upon restart, the SI panel is once more displaying the more graphical UI, and I see it's titled Properties. Examining the SI more closely I see now it's the 2nd icon (Properties) that's for some reason now selected.

16/
Clicking on the bottom-most icon, Design, crashed Writer too.

17/
Upon each crash restart, the document has lost the page I was on (first chapter, cursor at start of first paragraph) and instead displays the first page, with cursor positioned at the very start of the document.

18/
Back in the SI, I observe the immediate parent of the actual paragraph style includes properties displayed in black (like Char Difference Height and Char Property Height), as well as many displayed in grey (like Char Font Char Set and Char Font Name).

19/
I can't guess why some are in black and some are in grey.

20/
Some of the properties listed are totally unfamiliar (Para Adjust (2) and Para Bottom Margin Relative (100)).

21/
Many of the properties have values whose meaning I can't guess.
Some I know - like the Char Height of 10.5 because that's the font size, so I know it's in pt. Para First Line Indent = 508, and I can't guess its units. Some I suspect are percentages.
Suggestion: for numbers which are units, print the units alongside the value.

22/
The actual paragraph style for the (selected) paragraph lists just 8 properties, all in black (not grey).
Some are known to me (Follow Style, Para First Line Indent, Para Left Margin and right), others are unfamiliar (Para First Line Indent Relative, Para is Auto First Line Indent, Para Left Margin Relative and right).

23/
Under Direct Formatting, 8 properties are listed, but as there's no direct formatting in the paragraph that I'm aware of, I don't understand what it's telling me.
Char Font Char Set

12/
4th and 9th icons are identical (A with paintbrush). 4th is Styles, 9th is Design
Comment 10 Luke Kendall 2020-08-15 14:38:21 UTC
I finally built an AppImage and I'm now trying it.

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-11_15:13:29
Calc: threaded

SI = Styles Inspector.
Numbers like 1/ refer to my original comment.

1/
Great: SI is now resizeable.

2/ & 5/
Paragraph Styles are now intuitive to me, appearing in order of inheritance/derivation.

3/
Is still true, and seems very obvious now, and good.

4/
Fixed, great!

5/
The SI still displays the set of paragraph styles unfolded by default.
I still think this is a UX error because it hides the actual paragraph style down at the bottom, so the user must scroll (or fold up the parent paragraph styles above it) to discover it.

I still think my suggestions would be better:
* That seems a mild usability problem: having the visible style showing a parent style rather than the actual style is misleading.
** Suggestion: Show the styles "folded up", not "unfolded" by default:
   in that case you'd very likely see the actual style.
** Suggestion alternative: scroll the SI view to focus on the actual (leaf)
   style, not a parent style

6/
Still applies, still a problem. That the SI always unfolds each paragraph style, instead of either remembering which were folded last time, or presenting them folded by default, is annoying and I would confidently say is the wrong choice for most use cases.

7/
The Direct Formatting section's information is more understandable.
That there is any DF information visible still mystifies me.

Under Direct Formatting, 8 properties are listed, but as there's no direct formatting in the paragraph that I'm aware of, I don't understand what it's telling me.
Char Font Char Set 76
Char Font Family 0 (O?)
Char Font Name Georgia
Char Font Pitch 2
Char Font Style Name Regular
Char Height 10.5
Char Posture normal
Char Weight normal
I have no idea why any of these are listed, especially the Georgia/Regular/10.5 as those are all properties set by my paragraph style.

9/
Fixed. (Page Style Name no longer appears under DF).

10/
Still no clue what Character Styles does.
Suggestion: If there are no character styles applied, have a line under it that says "no styles applied" or something.
Mike K said:
"The latter. Please apply a character style, and check."
I set the character style of a word to use a different font: the Character Styles did not change.
I set another word's colour: the Character Styles did not change.
(I failed to find a way to make the Accept Change icon appear in the UI, but used the menu to apply it so I could see the colour rather than the Track Changes colour.)
It occurred to me to apply a Character Style (Internet Link).
I did so, and the Character Styles displayed that, and its properties.
Direct Formatting also changed, now displaying "Char Weight". That made no sense to me, as I had not changed the character weight with direct formatting.
Selecting the text I had changed to red showed a different set of DF properties. The Char Color made sense (0xff0000), but only that one.
I think the confusion in this user's mind is that when I apply DF by hitting OK on the Character Format inspector, in my mind only the properties or values which I have changed from those determined from the style have been changed.
Writer seems instead to bypass any such comparison, and decide that (every?_ Property is now provided by DF. If true, that seems a massive usability error being caused by Writer itself, and is perhaps a major contributor to the whole "DF is bad" feeling.

New things I noticed:

12/
Clicking on Styles icon after clicking on Styles Inspector crashed Writer.

13/
When Writer restarted, the Styles Inspector showed a somewhat more graphics inspector. I think maybe it represented a paragraph style but I wasn't sure.
Hitting F11 (I wanted to open the styles dialogue and examine a paragraph style in detail with that), changed the Styles panel to a less graphical mode.

I opened the Paragraph Style inspector, and wanted to compare some of those properties to what I had seen in the view of the SI I'd seen upon restart. But I discovered that none of the SI icons arranged vertically on the right side function while the Paragraph Styles dialogue is open. I don't understand why. It makes it hard to compare. I suspect I'd need to take a screenshot image and view that screenshot separately.

14/
Closing the Paragraph Styles dialogue let me click on icons on the right of the SI. I clicked on Styles (I think) and the SI panel closed.

15/
With the SI panel open, clicking on the 4th icon on the stack of SI icons closes the SI panel. That makes no sense to me. A bug? F11 reopens the SI.

16/
Clicking on the Gallery icon on the SI crashed Writer.

17/
Upon restart, the SI panel is once more displaying the more graphical UI, and I see it's titled Properties. Examining the SI more closely I see now it's the 2nd icon (Properties) that's for some reason now selected.

16/
Clicking on the bottom-most icon, Design, crashed Writer too.

17/
Upon each crash restart, the document has lost the page I was on (first chapter, cursor at start of first paragraph) and instead displays the first page, with cursor positioned at the very start of the document.

18/
Back in the SI, I observe the immediate parent of the actual paragraph style includes properties displayed in black (like Char Difference Height and Char Property Height), as well as many displayed in grey (like Char Font Char Set and Char Font Name).

19/
I can't guess why some are in black and some are in grey.

20/
Some of the properties listed are totally unfamiliar (Para Adjust (2) and Para Bottom Margin Relative (100)).

21/
Many of the properties have values whose meaning I can't guess.
Some I know - like the Char Height of 10.5 because that's the font size, so I know it's in pt. Para First Line Indent = 508, and I can't guess its units. Some I suspect are percentages.
Suggestion: for numbers which are units, print the units alongside the value.

22/
The actual paragraph style for the (selected) paragraph lists just 8 properties, all in black (not grey).
Some are known to me (Follow Style, Para First Line Indent, Para Left Margin and right), others are unfamiliar (Para First Line Indent Relative, Para is Auto First Line Indent, Para Left Margin Relative and right).

23/
The properties in the SI appear to be able to be selectable. I can't see why, as you can't do anything with the item (not even copy it). 
I was trying to determine if the Char Font Family value was a zero or the letter capital-O.

24/
4th and 9th icons are identical (A with paintbrush). 4th is Styles, 9th is Design.

HTH