Bug 135250 - There is no autofit to page option for tables or height adjustment option in table properties.
Summary: There is no autofit to page option for tables or height adjustment option in ...
Status: RESOLVED DUPLICATE of bug 104443
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2020-07-29 03:46 UTC by Pavel Sayekat
Modified: 2020-07-31 12:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
For_height_adjustment_option (46.72 KB, image/png)
2020-07-29 06:15 UTC, Pavel Sayekat
Details
Screenshot MSO (13.69 KB, image/png)
2020-07-30 08:39 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Sayekat 2020-07-29 03:46:26 UTC
It will be very convenient if there will be an option like autofit to page in table properties or at least table height adjustment option in LibreOffice Writer, saves time and effort.
Comment 1 Pavel Sayekat 2020-07-29 06:15:35 UTC
Created attachment 163716 [details]
For_height_adjustment_option
Comment 2 V Stuart Foote 2020-07-29 14:08:31 UTC
Actually I believe there is already with a simple work flow...

1.) Define your table, rows & columns. By default will be within current page margins. 

2.) Zoom out to expose full page on screen. 

3.) place focus on the table, and grab the bottom line of the new empty (or an existing) table. 

4.) Drag bottom edge of table down to the height required. Just the bottom row of the table will increase in height.

5.) Select the full table.

6.) Use the Table -> Size -> 'Optimal Row Height' menu action, also on the Table toolbar's Optimize Size split button, to distribute the table rows into the new table height.

Should be apparent that you can perform this on a blank page to size table to margins. Also that to revert and start over, simply select the table and apply 'Minimize Row Height'.

@Justin, what do you think? Would it be possible to have a action to set Table size to page margins?

And it seems odd that none of the Row or table Height attributes are available via the 'Table Properties...' dialog. Would a tab for Rows, like Columns make sense?
Comment 3 Justin L 2020-07-29 14:27:28 UTC
(In reply to V Stuart Foote from comment #2)
> @Justin, what do you think? Would it be possible to have a action to set
> Table size to page margins?
I don't think you would add something just for tables. If something like this would be done, I would expect it to be for all shapes.

Writer has a "relative size" on its tables, but that ends up causing confusion. And Draw is much different than Writer, since the concept of margins is almost irrelevant. In any case, it doesn't seem to hard to me to resize a table, and a copy/paste works well if someone wants many tables.

I'm a little confused about the scope of this report, because the component is marked as Writer, but it doesn't seem like we are talking about Writer. I assume draw, but perhaps Impress is primarily in view?
Comment 4 V Stuart Foote 2020-07-29 16:00:42 UTC
No, I think this would just be for Writer module. But I am OK with a WONTFIX resolution as the work flow for tables in Writer is pretty functional.

Like I mentioned though, the lack of a Row tab, or any height attribute(s), on the Table Properties... dialog seems an omission.
Comment 5 Justin L 2020-07-29 16:24:00 UTC
Height management for tables is pretty much useless as it grows with content. "Correctness" will always be in the eye of the beholder, and while columns are a reasonably finite number, rows tend towards infinity.

Width management already exists for Writer with relative size (as already clearly pointed out in comment 1).
Comment 6 V Stuart Foote 2020-07-29 16:54:19 UTC
Lets run this by the borader UX Advise community.

Personally IMHO the WONTFIX for auto sizing tables to page margins in Writer would be fine. Manual work flow now is suitable to task.

Just not clear if a generalized fit 'to page margins' could benefit handling of all objects, including Tables as here.

And, would it be worth any effort to have Table height and Row heights exposed in the Table properties dialog?
Comment 7 V Stuart Foote 2020-07-29 18:00:17 UTC
Sorry for that noise, Meta to bug 103100 not bug 107830...
Comment 8 Pavel Sayekat 2020-07-30 02:49:48 UTC
(In reply to V Stuart Foote from comment #2)
> Actually I believe there is already with a simple work flow...
> 
> 1.) Define your table, rows & columns. By default will be within current
> page margins. 
> 
> 2.) Zoom out to expose full page on screen. 
> 
> 3.) place focus on the table, and grab the bottom line of the new empty (or
> an existing) table. 
> 
> 4.) Drag bottom edge of table down to the height required. Just the bottom
> row of the table will increase in height.
> 
> 5.) Select the full table.
> 
> 6.) Use the Table -> Size -> 'Optimal Row Height' menu action, also on the
> Table toolbar's Optimize Size split button, to distribute the table rows
> into the new table height.
> 
> Should be apparent that you can perform this on a blank page to size table
> to margins. Also that to revert and start over, simply select the table and
> apply 'Minimize Row Height'.
> 
> @Justin, what do you think? Would it be possible to have a action to set
> Table size to page margins?
> 
> And it seems odd that none of the Row or table Height attributes are
> available via the 'Table Properties...' dialog. Would a tab for Rows, like
> Columns make sense?

As of now, I have managed to do it that way but I am talking about convenience / productivity, like 5-6 years ago, MS office had that feature, can't say about now, it saves time and effort but anyone can disagree with that.
Comment 9 Heiko Tietze 2020-07-30 08:39:06 UTC
Created attachment 163755 [details]
Screenshot MSO

We have bug 104443 about row height tab. I think a solution where both width and height for the entire table are defined on the same tab (as in the screenshot) has a lot of drawbacks. But on the other hand, all height related issues also apply to the width. Thinking about to define a table height of 5cm height using a paragraph style of 1cm and 5 rows. What happens when you add a row, adjust the paragraph or the table?

Double checked MSO and I don't see any setting for the table height. Just settings for the rows. Pavel, would it be sufficient for your workflow if row height can be set individually?
Comment 10 Pavel Sayekat 2020-07-31 03:00:04 UTC
(In reply to Heiko Tietze from comment #9)
> Created attachment 163755 [details]
> Screenshot MSO
> 
> We have bug 104443 about row height tab. I think a solution where both width
> and height for the entire table are defined on the same tab (as in the
> screenshot) has a lot of drawbacks. But on the other hand, all height
> related issues also apply to the width. Thinking about to define a table
> height of 5cm height using a paragraph style of 1cm and 5 rows. What happens
> when you add a row, adjust the paragraph or the table?
> 
> Double checked MSO and I don't see any setting for the table height. Just
> settings for the rows. Pavel, would it be sufficient for your workflow if
> row height can be set individually?

So I was wrong about MSOffice's "autofit to window" as it only applies to the table width, my bad and what do you mean by "row height can be set individually", the option is already there, are you talking about "table height"? Or if you ask me to be satisfied with the features currently available for LibreOffice, I am. If my requested enhancement seems stupid or seems too mach hassle to implement in the code in comparison to the feature's usefulness, I would understand.
Comment 11 Heiko Tietze 2020-07-31 12:37:04 UTC
(In reply to Pavel Sayekat from comment #10)
> ...what do you mean by "row height can be set individually"

It's requested in bug 104443. Currently you can define the width for each column individually but not the row height. Making this ticket a duplicate to keep track of the workflow.

*** This bug has been marked as a duplicate of bug 104443 ***