Bug 135413 - CRASH: importing document (gen)
Summary: CRASH: importing document (gen)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-08-03 12:20 UTC by Xisco Faulí
Modified: 2022-03-03 22:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt1 (28.84 KB, text/plain)
2020-08-03 18:28 UTC, Julien Nabet
Details
bt2 (24.45 KB, text/plain)
2020-08-03 18:28 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-08-03 12:20:37 UTC
Steps to reproduce:
1. Open attachment 72701 [details] from bug 59153 with SAL_USE_VCLPLUGIN=gen

-> Crash.

X-Error: BadDrawable (invalid Pixmap or Window parameter)
	Major opcode: 55 (X_CreateGC)
	Resource ID:  0x0
	Serial No:    2376 (2376)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging
Application Error


Version: 7.1.0.0.alpha0+
Build ID: 32090b018d9ff81659a4c9ed41c64109ebebe4fc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-08-03 12:22:22 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cbc992e7370ab006ea7c0f8520896845f79f7749

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-07-19 19:26:14 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-07-20 20:29:11 +0200
commit cbc992e7370ab006ea7c0f8520896845f79f7749 (patch)
tree 71000129a35f40d680279134efae7fac1c4e6a52
parent 133da6ed83b278b9e6059c5c1a3d49f9f402792e (diff)
tdf#118662 Cleanup old hack with cloned SdrCaptionObj

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 2 Julien Nabet 2020-08-03 18:27:49 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
With gdb, no crash but lots of errors like:
X-Error: RenderBadPicture (invalid Picture parameter)
	Major opcode: 139
	Minor opcode: 10
	Resource ID:  0x3400099
	Serial No:    55428 (55428)
X-Error: RenderBadPicture (invalid Picture parameter)
	Major opcode: 139
	Minor opcode: 26
	Resource ID:  0x3400099
	Serial No:    55890 (55890)

if I launch Writer, then attach gdb, then I try to open the file, I got a crash.
But I tested twice, I had 2 different bts.
Comment 3 Julien Nabet 2020-08-03 18:28:38 UTC
Created attachment 163910 [details]
bt1
Comment 4 Julien Nabet 2020-08-03 18:28:58 UTC
Created attachment 163911 [details]
bt2
Comment 5 Julien Nabet 2020-08-03 18:29:45 UTC
On console, I got:
warn:legacy.osl:4074:4074:svx/source/unodraw/shapepropertynotifier.cxx:116: PropertyChangeNotifier::notifyPropertyChange: no factory!
warn:writerfilter.dmapper:4074:4074:writerfilter/source/dmapper/DomainMapper_Impl.cxx:2905: PushShapeContext() com.sun.star.beans.UnknownPropertyException message: CharInteropGrabBag /home/julien/lo/libreoffice/svx/source/unodraw/unoshape.cxx:1730
warn:vcl:4074:4074:vcl/unx/x11/xlimits.cxx:23: overlarge pixmap: 114272 x 35882
X-Error: BadDrawable (invalid Pixmap or Window parameter)
	Major opcode: 55 (X_CreateGC)
	Resource ID:  0x0
	Serial No:    97996 (97996)
Comment 6 Gabor Kelemen (allotropia) 2022-03-03 11:03:36 UTC
I can no longer reproduce the instant crash in bibisect-linux 7.2 after

https://git.libreoffice.org/core/+/943c108071c82541c619ea3071fe97634a7a8bab

author	Caolán McNamara <caolanm@redhat.com>	Mon Nov 23 15:26:22 2020 +0000
committer	Caolán McNamara <caolanm@redhat.com>	Mon Nov 23 20:57:46 2020 +0100

ofz#27519 only generate bitmap preview when needed

Still after this a bit of scrolling, clicking, dialog opening, focus changing could crash Writer with the same error on console.

This seems to be also solved in 7.2-bibisect master, but would need more bibisecting to find out the exact commit(s).
Comment 7 Commit Notification 2022-03-03 22:07:03 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/58f2c1e6ab3052e0746dabb36e6061125779b034

tdf#135413: sw: Add UItest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.