Bug 135416 - Fonts are not embedded when creating form fields in Writer on GNU/Linux
Summary: Fonts are not embedded when creating form fields in Writer on GNU/Linux
Status: RESOLVED DUPLICATE of bug 50879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Embedded
  Show dependency treegraph
 
Reported: 2020-08-03 14:44 UTC by Daniel James
Modified: 2021-04-15 09:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test form using one text field (11.00 MB, application/vnd.oasis.opendocument.text)
2020-08-03 14:46 UTC, Daniel James
Details
Result of exporting PDF form in Writer 6.1.5 (10.45 KB, application/pdf)
2020-08-03 14:48 UTC, Daniel James
Details
Result of exporting PDF form in Writer 6.4.5 (2.80 KB, application/pdf)
2020-08-03 14:49 UTC, Daniel James
Details
Fonts in form fields are not embedded even when the same font is already embedded (46.87 KB, image/png)
2020-08-05 15:32 UTC, Daniel James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel James 2020-08-03 14:44:45 UTC
Description:
In Libre Office Writer version 6.1.5.2 from Debian stable (buster) and version 6.4.5 from buster-backports, the fonts set for the content of form fields are not embedded in the exported PDF. Fonts for the rest of the document are embedded correctly.

This behaviour causes the PDF form to be unusable in Adobe Reader (for example version 9 for GNU/Linux, which shows an error message about being unable to find the font of the form field).

I attempted to embed Type 1 PDF standard fonts (e.g. Courier) in the form fields, but Libre Office apparently no longer supports this legacy type of font. I also tried Safe Mode.

The form will work using a default font in evince and apparently other Free Software PDF viewers. So it's really an interoperability issue when sending forms to other platforms where people still use Adobe Reader.

Steps to Reproduce:
1. Create a form in Writer
2. Export to PDF, selecting the 
3. Try filling in the text fields in Adobe Reader

Actual Results:
The text cannot be read on the Adobe Reader screen (substitute characters)

Expected Results:
Shown the content of the text fields as entered.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.5.2
Build ID: 1:6.1.5-3+deb10u6
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 1 Daniel James 2020-08-03 14:46:11 UTC
Created attachment 163900 [details]
Test form using one text field
Comment 2 Daniel James 2020-08-03 14:48:15 UTC
Created attachment 163901 [details]
Result of exporting PDF form in Writer 6.1.5
Comment 3 Daniel James 2020-08-03 14:49:25 UTC
Created attachment 163902 [details]
Result of exporting PDF form in Writer 6.4.5
Comment 4 Daniel James 2020-08-03 14:51:35 UTC
Comment on attachment 163902 [details]
Result of exporting PDF form in Writer 6.4.5

Also please note that in Writer 6.4.5 the regular text in the document only renders in roughly every other export, but that does not happen in Writer 6.1.5 so that might be a separate regression.
Comment 5 Robert Großkopf 2020-08-05 13:54:31 UTC
I just wanted to write about the same bug. Thought I had already done ...

If I open an exported *.pdf-Form I get 
NotoSans Regular /usr/share/fonts ...
for the properties of the font in the form controls.

This forms are unusable in Acrobat Reader it the font isn't installed. It is impossible to add content to the fields with this editor. I have to switch the font to the font of the text-content of my Writer document ad it worked.

All tested with LO 7.0.0.3 on OpenSUSE 15.1 64bit rpm Linux an other LO-Versions before.
Comment 6 Daniel James 2020-08-05 15:31:57 UTC
Hi Robert, in Writer 6.* the form field font is not embedded even when it is the exact same font as embedded for the main text. I will attach a screenshot showing this anomaly.
Comment 7 Daniel James 2020-08-05 15:32:45 UTC
Created attachment 163976 [details]
Fonts in form fields are not embedded even when the same font is already embedded
Comment 8 Timur 2021-04-15 09:08:39 UTC
Rule of thumb is search before reporting and confirming. 
Please read duplicate bug and bug 137421.

*** This bug has been marked as a duplicate of bug 50879 ***
Comment 9 Daniel James 2021-04-15 09:51:18 UTC
Hi Timur, I did search for similar bug reports but did not see those others you have found, thanks for the links.

I don't see in these other bug reports any mention of LibreOffice 5.3 deprecating Type 1 fonts including those from the original 'standard' PDF set, which might be the cause of this bug.