Bug 135432 - Crash when opening an ODT document written in Japanese/Chinese (Android viewer)
Summary: Crash when opening an ODT document written in Japanese/Chinese (Android viewer)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-08-04 10:42 UTC by baffclan
Modified: 2020-08-19 09:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2020-08-04 10:42:04 UTC
Description:
Crash when opening an ODT document written in Japanese/Chinese


Steps to Reproduce:
1. Download a ODT file
   https://github.com/ikunya/libo-writer/blob/master/libreoffice-writer-book.odt (https://github.com/ikunya/libo-writer)
  OR
  attachment 150543 [details] (bug 124536)

2. Open this document at LibreOffice Viewer


Actual Results:
Crash a LibreOffice Viewer


Expected Results:
Open ODT Document



Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice Viewer / Android
Version: 7.1.0.0.alpha0+
BuildID: e3d623a

Similar to bug 124536, bug 128101.
Comment 1 Michael Weghorn 2020-08-18 11:59:59 UTC
Reproduced on x86 AVD with:

Version: 7.1.0.0.alpha0+
Build-ID: 4a31ceba3bf8


ADB logcat output contains this:

> 08-18 13:53:37.741 11670 11761 W cppuhelper: 1:cppuhelper/source/shlib.cxx:288: unknown constructor name "i18npool_BreakIterator_ja_get_implementation"



Looks like a regression from

commit 155c056b1d4674d5ff73bbb5e1ad1dcd1e6aae36
Author: Noel Grandin <noelgrandin@gmail.com>
Date:   Wed Jul 29 20:04:44 2020 +0200

    i18npool: create instances with uno constructors


not fixed by

commit ed8bce1909f658d8e3d950f374931242f91ba811
Author: Noel Grandin <noel.grandin@collabora.co.uk>
Date:   Wed Aug 12 16:02:41 2020 +0200

    fix i18n constructors and android scripts



Fix pending at https://gerrit.libreoffice.org/c/core/+/100915
Comment 2 Commit Notification 2020-08-18 12:59:12 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b1b1b8f8c1afc35589c3fc7a713def39f71ede97

tdf#135432 native-code: Add missing include for locales

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 baffclan 2020-08-19 09:58:11 UTC
Cannot reproduce new build.

Android-ARM@86-TDF / 2020-08-19_01.31.25
Version: 7.1.0.0.alpha0+
BuildID: 9f4f44b

Thanks for fixing this!