Bug 135481 - Crash when opening Any Writer doc on MacOS
Summary: Crash when opening Any Writer doc on MacOS
Status: RESOLVED DUPLICATE of bug 128233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-05 21:48 UTC by Spood
Modified: 2020-08-06 08:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error Attatchment (104.83 KB, image/png)
2020-08-05 21:48 UTC, Spood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Spood 2020-08-05 21:48:47 UTC
Created attachment 163991 [details]
Error Attatchment

Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Installation by download and replace previous version
Open Libreoffice
Select Writer to open/create new document
Error message displays the following:-

"Due to an error, Libreoffice crashed. All the files you were working on will now be saved....." Refer to attached screenshot

If I select "Ok" | "Discard" | "Yes" - This cycle loops and repeats
If I select "Ok" | "Start" | "Finish" - This cycle loops and repeats

Every option to open a new or exiting document with Writer causes this error/crash
Comment 1 Spood 2020-08-05 23:12:04 UTC
Just to add the Volume is APFS Case-sensitive
Comment 2 Telesto 2020-08-06 07:38:41 UTC
It's probably or a broken profile or codesign, I think

Instructions resetting user profile
https://wiki.documentfoundation.org/UserProfile/en

For fixing code signing
Open a terminal an type 
codesign -vvv --deep --strict /Applications/LibreOffice.app
Comment 3 Spood 2020-08-06 08:12:35 UTC
Hi

I carried out the action as stated above (codesign -vvv --deep --strict /Applications/LibreOffice.app)

Rebooted just to ensure all caches etc were cleared and I have now started Liboffice 7.0.0.3 and opened existing and created new documents about 6 times and all appears to be good :-)
Comment 4 Alex Thurgood 2020-08-06 08:22:44 UTC
We should close this as either WFM or else mark it as DUP of the known bug reporting similar behaviour.
Comment 5 Telesto 2020-08-06 08:24:23 UTC

*** This bug has been marked as a duplicate of bug 132025 ***
Comment 6 Telesto 2020-08-06 08:25:56 UTC
Duplicate; like this being solved somehow.. it should run -vvv --deep --strict /Applications/LibreOffice.app automatically

*** This bug has been marked as a duplicate of bug 128233 ***