Bug 135506 - Relative paths are shown as absolute paths
Summary: Relative paths are shown as absolute paths
Status: RESOLVED DUPLICATE of bug 128216
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-06 18:07 UTC by S.Zosgornik
Modified: 2021-02-12 22:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S.Zosgornik 2020-08-06 18:07:51 UTC
Description:
After reading several bug-reports related to this topic and testing did I found out that LibreOffice Writer is very capable to handle links relative to the main file.

If chosen in the options, all links inside the document itself are actually written as relative paths in the content.xml file inside the zipped document container.

Also creating several files inside a folder, link them together as relative links and then move the folder along the file-system does work for me.

However - and that is certainly what most users confuse is that all relative links are shown as absolute paths inside the UI e.g. under Format > Sections... or Navigator > Images.

Steps to Reproduce:
1.Make sure Options > Load/Save > General > Save URLs relative to file system is enabled
2. Create a new folder
3. Create a new document and add images, audio files and text files to the just created folder
4. Link the images, audio files and text files to the new document
5. Check the links ---> they are shown as absolute paths
6. Close the document and move the folder around the file-system
7. Re-open the document, all content is shown correctly
8. Re-check the links ---> they are updated correctly but still shown as absolute paths

Actual Results:
Relative linked files are wrongly shown as absolute paths

Creating a relative path inside the path field is not possible

Expected Results:
Relative links should actually shown as relative paths

Users should be able to create relative and absolute paths corresponding the syntax inside the path field e.g. "C:\User\Documents\Frontpage.odt" and "Subfolder\Frontpage.odt"


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Bug 86785 already informs about this behaver in later comments.
Comment 1 Dieter 2020-12-18 11:46:12 UTC
Thanks for reporting the bug. I haven't tested, but it sounds to me like a duplicate of bug 128216. Waht do you think?
=> NEEDINFO
Comment 2 S.Zosgornik 2020-12-18 20:12:38 UTC
Yes, it is the same bug.

P.S. Just re-checked and it's still the same behavior in Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082

Also bug 135508 is related to relative path.

*** This bug has been marked as a duplicate of bug 128216 ***