Download it now!
Bug 135522 - UI ENHANCEMENT:Make the tabbed interface visual more appealing (color shemes)
Summary: UI ENHANCEMENT:Make the tabbed interface visual more appealing (color shemes)
Status: RESOLVED DUPLICATE of bug 121877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2020-08-07 08:42 UTC by Telesto
Modified: 2020-08-07 19:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (45.00 KB, image/png)
2020-08-07 08:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-07 08:42:20 UTC
Description:
UI ENHANCEMENT:Make the tabbed interface visual more appealing (color schemes)

Steps to Reproduce:
1. Open the attached screenshot

Actual Results:
* Hamburger sticks out
* They tab buttons don't visually fit in with the theming and such (semi transparent?)
* Tab buttons file bit over-sized (for my taste)
* The undo/redo/ print doesn't match the style (c
* Cream color of the toolbar (buttons) doesn't match theme  
* They color of the toolbar doesn't match with the gray of the sidebar [it bites]

Expected Results:
* Hamburger semi-transparent or so?
* They tab buttons don't visually fit in with the theming and such; make the same transparent or something 
* Tab buttons file bit over-sized (for my taste): shrink them (size depending on font size)
* The undo/redo/ print doesn't match the style; an't they position in a they bar at the left &  permanently visible
* Cream color of the toolbar (buttons) doesn't match theme  Should it not follow theming in same way? 
* They color of the toolbar doesn't match with the gray of the sidebar [it bites] -> No clue, ideally the sidebar show follow theming too;



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: ru-RU (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-07 08:43:26 UTC
Created attachment 164026 [details]
Screenshot
Comment 2 Telesto 2020-08-07 08:45:12 UTC
Not knowing to much about design; nor how easy it is to tweak this; or all considerations which have been gone into this
Comment 3 andreas_k 2020-08-07 08:59:12 UTC
I'm all for make ALL UI's more appealing. 

So if someone is interested or has an code pointer where an designer can play with, let me know. The main issue is that the layout is different compare to the VCL backend.
Comment 4 Telesto 2020-08-07 10:41:26 UTC
@Caolan
You might know

(In reply to andreas_k from comment #3)
> I'm all for make ALL UI's more appealing. 
> 
> So if someone is interested or has an code pointer where an designer can
> play with, let me know. The main issue is that the layout is different
> compare to the VCL backend.
Comment 5 V Stuart Foote 2020-08-07 19:12:05 UTC

*** This bug has been marked as a duplicate of bug 121877 ***