Download it now!
Bug 135550 - List Box not triggering any event macros
Summary: List Box not triggering any event macros
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:7.2....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-08 09:47 UTC by Claudio Chiffi
Modified: 2021-01-26 09:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
an ODB-file for verifying the reported bug (12.73 KB, application/vnd.sun.xml.base)
2020-08-08 09:47 UTC, Claudio Chiffi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Chiffi 2020-08-08 09:47:18 UTC
Created attachment 164041 [details]
an ODB-file for verifying the reported bug

In LO 7.0.0, when assigning an event macro to a list box within a table control, then the event does not trigger the execution of the macro. No kind of event is triggering a macro.

When opening the very same form with Libreoffice 6.4.1 (testet on Linux machine, Debian Buster) or Libreoffice 6.4.5 (tested on as Windows 10 machine), then all assigned event macros are triggered.

When doing the same with a stand-alone list box, then the event macros are triggered in LO 7.0.0 as well as in LO 6.4.5 or LO 6.4.1.

The bug must have appeared somewhen between Version 6.4.5 and 7.0.0.

Tested on Linux (Debian Buster) and on Windows 10, both 64bit-Versions.
Tested with Java OpenJDK Version 14.0.2 and Version 12.0.2 (does not make any difference for this bug here)
 
This bug can make many existing LO documents useless. Therefore I'd say it is a severe bug.



with kind regards,
Claudio
Comment 1 Robert Großkopf 2020-08-08 14:27:32 UTC
Could confirm the buggy behavior.

Tested with LO 7.0.0.3 on OpenSUSE 15.1 64bit rpm Linux.
Event doesn't trigger the msgbox.
Changed the event for the listbox inside the tablecontrol.
Next event doesn't trigger the msgbox.

This all works well with LO 6.4.5.2.
Comment 2 Xisco Faulí 2020-08-13 11:50:20 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8477bbf8d6867e656b8132f0ddd682d08590a547

author	Caolán McNamara <caolanm@redhat.com>	2020-05-13 16:57:07 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-21 09:53:46 +0200
commit	8477bbf8d6867e656b8132f0ddd682d08590a547 (patch)
tree	11d1f70190b6478bf3b070480393f364d58c81ab
parent	c764b37489fb5f639c9e1c4faba64ebe405cc347 (diff)
weld ListBoxControl

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 3 Xisco Faulí 2020-08-13 11:51:06 UTC
While opening 'note_form' a dialog should be displayed
Comment 4 Commit Notification 2020-08-14 15:28:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/937f800cdb644b22b4c7bd18b35a8940bcede7ce

tdf#135550 make XListBox Item status changed event work again

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-08-14 16:00:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/186def8f48e273c3a3b4d23b3ab2efd0d8664731

tdf#135550 FmXListBoxCell does need to implement XListBox after all

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-08-16 16:05:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/704297ed099e1732db360669abe2443d24f6c252

tdf#135550 make XComboBox Item status changed event work again

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-08-20 11:08:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/23c965a299315398c0931ecefbca49824cc21261

tdf#135550 make XComboBox Item status changed event work again

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-08-24 10:16:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/4771535e40feb6ec7f15e160e00592b2f253f3a5

tdf#135550 make XListBox Item status changed event work again

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-08-24 10:20:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8c6c9077ba6588bfcd7a14a3685d64941a9fd983

tdf#135550 FmXListBoxCell does need to implement XListBox after all

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2020-08-24 10:21:39 UTC
That makes this case work. If there turn out to be more cases do let me know.
Comment 11 Xisco Faulí 2020-08-31 10:13:22 UTC
(In reply to Caolán McNamara from comment #10)
> That makes this case work. If there turn out to be more cases do let me know.

Hi Caolán,
I do confirm the issue is fixed when selecting another item in the dropdown list, however, the message box is not displayed when opening the form. Before the commit mentioned in comment 2, the message was displayed opening the form. was this behaviour erratic and it's fixed now, or is it another problem introduced by the commit ? 

Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 12 Caolán McNamara 2020-08-31 10:56:30 UTC
re "Before the commit mentioned in comment 2, the message was displayed opening the form". I don't see than happening on 6-4 or 6-3, if I right click on the form in base and edit and right click on the 2nd column and use column... and the events tab I see "item status changed" to trigger the macro which I feel is unexpected to happen on just opening the document. I can roll back to before 8477bbf8d6867e656b8132f0ddd682d08590a547 to see if it happens locally.
Comment 13 Caolán McNamara 2020-08-31 14:37:00 UTC
building c764b37489fb5f639c9e1c4faba64ebe405cc347 which is just before 8477bbf8d6867e656b8132f0ddd682d08590a547 and I don't see anything on just loading the odb and launching the form. Maybe it was a different document ?
Comment 14 Aron Budea 2021-01-03 08:35:38 UTC
(In reply to Caolán McNamara from comment #13)
> building c764b37489fb5f639c9e1c4faba64ebe405cc347 which is just before
> 8477bbf8d6867e656b8132f0ddd682d08590a547 and I don't see anything on just
> loading the odb and launching the form. Maybe it was a different document ?
I can see the dialog when opening the sample in that previous build in the bibisect repo, and even if I go back to an old version, like 4.4.0.3. Double-clicking on 'note_form' in the Forms part of the window brings up the form, and pops up the dialog.
Comment 15 Caolán McNamara 2021-01-22 16:04:25 UTC
oddly it doesn't happen for me most times under gen, which is what I think I was testing in comment #12, but with gtk3 in the older versions I can indeed see that the event is triggered when the listbox entry is selected by libreoffice itself and not via a direct user interaction on the listbox
Comment 16 Commit Notification 2021-01-22 20:00:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8df14a82cee4fe0c4ca6f994c7c3f92373b411a3

tdf#135550 ListBox should triger an event when changed non-interactively

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2021-01-22 20:02:05 UTC
That should make this case work as it did originally in master, backports to 7-1 and 7-0 in gerrit
Comment 18 Commit Notification 2021-01-26 09:44:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/227ebe934127c64fc0b8089d426b44462c7eb739

tdf#135550 ListBox should triger an event when changed non-interactively

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-01-26 09:46:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/88ecd33f7b5a8f5ea876aef3281a086c753cae7e

tdf#135550 ListBox should triger an event when changed non-interactively

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.