Download it now!
Bug 135641 - ListBox in a table control - can't write into the cell without using the mouse
Summary: ListBox in a table control - can't write into the cell without using the mouse
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.0.5
Keywords: accessibility, bibisected, bisected, regression
: 135194 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-11 15:46 UTC by holger-s
Modified: 2021-01-17 20:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the form, set cursor on fiel "ID", press Tab and try to change "Listenfeld 1" by typing any value (11.89 KB, application/vnd.oasis.opendocument.database)
2020-08-14 15:15 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description holger-s 2020-08-11 15:46:02 UTC
Description:
I have various forms that contain tables with list box columns.
In the past ist was possible simple to write into those columns / cells.
Now you have to use the mouse to open the dropdown list before you can start to write into the cell.

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Robert Großkopf 2020-08-14 15:15:32 UTC
Created attachment 164317 [details]
Open the form, set cursor on fiel "ID", press Tab and try to change "Listenfeld 1" by typing any value

Could confirm this buggy behavior.

Open the attached document wit LO 7.0.0.3.
Open the form.
Set the cursor in the first row of the table control, field "ID".
Switch to next row by tabulator.
Press '1' to change the value of the listbox.
There is no possibility to change the value by typing on the keyboard.

If you do the same with LO 6.4.5.2 it works. You could change the value by typing on the keyboard.
Comment 2 Robert Großkopf 2020-08-14 15:17:30 UTC
Confirm the buggy behavior with LO 7.0.0.3 on OpenSUSE 15.1 64bit rpm Linux.

Works well in LO 6.4.5.2 on the same machine, so a regression.
Comment 3 holger-s 2020-10-10 11:59:28 UTC
Version 7.0.3 Bug still there ...

Holger
Comment 4 holger-s 2020-10-10 12:00:57 UTC
(In reply to holger-s from comment #3)
> Version 7.0.3 Bug still there ...
> 
> Holger

I meant 7.0.2
Comment 5 holger-s 2020-11-17 06:56:43 UTC
with 7.0.3 still the same

holger-s
Comment 6 Aron Budea 2021-01-02 08:37:08 UTC
Bibisected to the following commit using repo bibisect-linux-64-7.0. Same commit as in bug 135550. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8477bbf8d6867e656b8132f0ddd682d08590a547
author		Caolán McNamara <caolanm@redhat.com>	2020-05-13 16:57:07 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-21 09:53:46 +0200

weld ListBoxControl
Comment 7 Aron Budea 2021-01-03 01:09:29 UTC
*** Bug 135194 has been marked as a duplicate of this bug. ***
Comment 8 Stang 2021-01-11 19:49:04 UTC
With this problem, even when the mouse is used to select a new item, the "SelectedValue" does not change until focus is lost.  This currently does not occur in a list box control not in a table control.

Information can be lost for macros seeking to know this information before updating.  I.E. Select item cannot then use keyboard to move to different field.  If mouse is clicked on different record, data before updating is not accessed.
Comment 9 Stang 2021-01-11 20:19:49 UTC
Sorry.  My previous comment may be a different issue as it also is a problem in earlier versions.
Comment 10 Commit Notification 2021-01-15 19:58:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/405aa1b6a226c58966d319f25e4ebf2e400d5e50

tdf#135641 update DataBrowser has-focus when child widget gains focus

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2021-01-15 20:00:40 UTC
I believe the original reported issue is fixed with the above in master now. Backports to 7-1 and 7-0 in gerrit. There is probably some overlap with bug tdf#137694 in the 7-0 case.
Comment 12 Commit Notification 2021-01-17 20:40:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/3812a2678c8aeba6ea980e3df5ee63792a217199

tdf#135641 update DataBrowser has-focus when child widget gains focus

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-01-17 20:40:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/51c7c4ddb884703907759918f0541f9ad1f1fd98

tdf#135641 update DataBrowser has-focus when child widget gains focus

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.