Bug 135732 - Cutting image in frame in table saved as DOCX doesn't work
Summary: Cutting image in frame in table saved as DOCX doesn't work
Status: RESOLVED DUPLICATE of bug 135149
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-08-13 20:15 UTC by Telesto
Modified: 2020-12-04 04:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (55.58 KB, application/vnd.oasis.opendocument.text)
2020-08-13 20:16 UTC, Telesto
Details
The docx versions of the original file in 7.0 and 7.2alpha after cutting the frame (249.99 KB, image/png)
2020-12-03 14:54 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-13 20:15:52 UTC
Description:
Cutting image in frame in table saved as DOCX doesn't work

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload
4. Select the image frame in table (figure 1) & CTRL+X

Actual Results:
Image still present

Expected Results:
Disappearing


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

6.0

4.4.7.2

cut crashes in 4.3

export somewhat broken in 4.2
Comment 1 Telesto 2020-08-13 20:16:09 UTC
Created attachment 164282 [details]
Example file
Comment 2 Telesto 2020-08-13 20:16:51 UTC
I assume the flaw started somewhere around the crash or should at minimum give some pointer
Comment 3 Telesto 2020-08-13 20:18:02 UTC
Fine with DOC
Comment 4 NISZ LibreOffice Team 2020-12-03 14:54:13 UTC
Created attachment 167801 [details]
The docx versions of the original file in 7.0 and 7.2alpha after cutting the frame

Seems to work now in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e63ec27b69fa01ff610c894c9fbf05c377a6179
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

Was bad in:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 5 NISZ LibreOffice Team 2020-12-03 15:50:37 UTC
Seems to be fixed since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=da4f9b77a6cd39b1ae5babdd476d1575c8b9371c

author	Miklos Vajna <vmiklos@collabora.com>	2020-09-07 21:23:07 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-09-08 09:11:24 +0200

tdf#135149 sw: fix deleting textbox of as-char shapes

Thanks Miklos for fixing this one too :)

*** This bug has been marked as a duplicate of bug 135149 ***
Comment 6 Telesto 2020-12-03 15:56:48 UTC
@Xisco
Is a separate unit test required for this case or is this covered by the unit test for bug 135149.
Comment 7 Xisco Faulí 2020-12-03 16:19:56 UTC
(In reply to Telesto from comment #6)
> @Xisco
> Is a separate unit test required for this case or is this covered by the
> unit test for bug 135149.

noup, see the commit

    // Without the accompanying fix in place, this test would have failed with:
    // - Expected: 0
    // - Actual  : 2
    // i.e. the fly frame of the shape and the inner Writer image was not deleted.
    CPPUNIT_ASSERT_EQUAL(static_cast<sal_Int32>(0), nActual);