Download it now!
Bug 135733 - Crash undo paste & cut (swlo!SwDoc::IsInWriterfilterImport) since 7.0 or 7.1)
Summary: Crash undo paste & cut (swlo!SwDoc::IsInWriterfilterImport) since 7.0 or 7.1)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-13 20:35 UTC by Telesto
Modified: 2020-10-26 16:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (55.56 KB, application/vnd.oasis.opendocument.text)
2020-08-13 20:35 UTC, Telesto
Details
Screencast (817.36 KB, video/mp4)
2020-08-13 20:36 UTC, Telesto
Details
bt with debug symbols (9.98 KB, text/plain)
2020-08-14 10:49 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-13 20:35:36 UTC
Description:
Crash undo paste & cut (swlo!SwDoc::IsInWriterfilterImport)

Steps to Reproduce:
1. Open the attached file
2. Select the table
3. CTRL+X
4. Paste above
5. CTRL+Z
6. CTRL+Z

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

not in
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 92d1b0d10ec04f17d116bc54aada652f1c2cac4a
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-08-13 20:35:49 UTC
Created attachment 164284 [details]
Example file
Comment 2 Telesto 2020-08-13 20:36:07 UTC
Created attachment 164285 [details]
Screencast
Comment 3 Julien Nabet 2020-08-14 10:08:36 UTC
Just for the record, on pc Debian x86-64 with master sources updated today, after having selected the table with "menu table/Select/Table", Ctrl-X is not possible for me because it tells me:
"Read-Only Content
Write-protected content cannot be changed.
No modifications will be accepted.
"
Comment 4 Telesto 2020-08-14 10:19:24 UTC
(In reply to Julien Nabet from comment #3)
> Just for the record, on pc Debian x86-64 with master sources updated today,
> after having selected the table with "menu table/Select/Table", Ctrl-X is
> not possible for me because it tells me:
> "Read-Only Content
> Write-protected content cannot be changed.
> No modifications will be accepted.
> "

Have bug report about that too :-). Depends bit an how you select things. If you enter A1 and drag to right corner it should work (skipping one cell; but doesn't matter for problem here)
Comment 5 Telesto 2020-08-14 10:27:39 UTC
(In reply to Julien Nabet from comment #3)
> Just for the record, on pc Debian x86-64 with master sources updated today,
> after having selected the table with "menu table/Select/Table", Ctrl-X is
> not possible for me because it tells me:
> "Read-Only Content
> Write-protected content cannot be changed.
> No modifications will be accepted.
> "

To be more specific: bug 135734
Comment 6 Julien Nabet 2020-08-14 10:49:36 UTC
Created attachment 164306 [details]
bt with debug symbols

Indeed! :-)

Here's a bt retrieved on pc Debian x86-64 with master sources updated today.
Comment 7 Julien Nabet 2020-08-14 10:50:23 UTC
Notice it's not bt of a crash but bt of an assertion.
Comment 8 Xisco Faulí 2020-08-14 13:39:22 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=dc7e7b94a7211c576454267c09eb108e761e4487

author	Michael Stahl <Michael.Stahl@cib.de>	2020-07-03 17:52:28 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-07-06 10:07:21 +0200
commit	dc7e7b94a7211c576454267c09eb108e761e4487 (patch)
tree	50bf18bb2a183361bff168ecd8af4beb37441182
parent	9e2da576bd07a389599f833f2cf1b09e6ead962d (diff)
tdf#134253 sw: fix SwUndoInserts::UndoImpl() if inserting before section

Bisected with: bibisect-linux64-7.1

Adding Cc: to Michael Stahl
Comment 9 Commit Notification 2020-10-16 19:47:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7221b7638c74b13e229f7ff50349a253ebb74cfc

tdf#135733 sw: fix mistake in SwUndoInserts::SetInsertRange()

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Stahl (CIB) 2020-10-16 19:50:03 UTC
well that was an annoying mistake, fixed on master...
Comment 11 Commit Notification 2020-10-17 08:54:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ae6069c073365d8b5162a42b2618f077c7738caf

tdf#135733 sw: fix mistake in SwUndoInserts::SetInsertRange()

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-10-17 14:24:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/92de5455e3df5d160a756371fa1323e2348454b3

tdf#135733: sw_uiwriter: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2020-10-26 16:37:12 UTC
Unittest added. Setting to VERIFIED.

@Michael Stahl, thanks for fixing this issue!!