Bug 135816 - Tip of the Day should draw keycaps for keyboard shortcuts to be less confusing.
Summary: Tip of the Day should draw keycaps for keyboard shortcuts to be less confusing.
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2020-08-17 00:01 UTC by skierpage
Modified: 2021-08-12 16:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skierpage 2020-08-17 00:01:10 UTC
Some of the Tips of the Day that describe keyboard shortcuts are hard to understand because the keys aren't delineated.

#41: "Need to insert the date in a spreadsheet cell? Type Ctrl+; or Shift+Ctrl+; to insert the time."

Should I type Ctrl and the plus key, and the semicolon is punctuation?

#85: "To quickly insert or delete rows, select the desired number of rows (or columns) and press Ctrl+ to add or Ctrl- to delete."

This is inconsistent, it leaves out the +, probably because "Ctrl++ to add or Ctrl+- to delete" is hard to understand.

Expected results:
Ideally the Tip of the Day would use CSS that renders keycaps around keyboard keys, e.g. https://jsfiddle.net/7rg5pLs8/1/ . That might also address bug 130979, which talks of the difficulty of localizing the modifier key's name.
Using an HTML renderer might also allow a cleaner fix for bug 135790 by using HTML named entities &MOD1 and &MOD2; to represent Ctrl-Alt/Cmd-Option instead of performing string replacements in these tips, or using a templating engine.
It would also probably fix bug 135113 as HTML text is often selectable.

Additional Information:

I think the LibreOffice help documentation likewise doesn't draw keycaps for keyboard shortcuts, e.g. https://help.libreoffice.org/latest/en-US/text/scalc/04/01020000.html
Comment 1 Heiko Tietze 2020-09-16 08:26:01 UTC
CSS requires an HTML engine behind the style and that makes the simple text rendering a huge thing. Not saying it's impossible, even without HTML parts of the text could be replaced by graphical elements, but the effort is out of all proportion to the benefit.
Comment 2 Jean-Baptiste Faure 2021-08-12 16:43:44 UTC
(In reply to Heiko Tietze from comment #1)
> CSS requires an HTML engine behind the style and that makes the simple text
> rendering a huge thing. Not saying it's impossible, even without HTML parts
> of the text could be replaced by graphical elements, but the effort is out
> of all proportion to the benefit.

Ok, so closing as WontFix.

Best regards. JBF