Bug 135895 - Improve documentation about numbered lists without a list style (see comment 39)
Summary: Improve documentation about numbered lists without a list style (see comment 39)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All All
: low minor
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists Help-Changes-Features
  Show dependency treegraph
 
Reported: 2020-08-18 21:32 UTC by kitchm
Modified: 2021-03-25 23:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Basic Outline Doc (9.40 KB, application/vnd.oasis.opendocument.text)
2020-08-18 21:34 UTC, kitchm
Details
Basic Outline Doc showing results of only changing bottom outline (9.49 KB, application/vnd.oasis.opendocument.text)
2020-08-18 21:35 UTC, kitchm
Details
Numbering compared (153.08 KB, image/png)
2020-09-03 06:55 UTC, Timur
Details
First Document (10.69 KB, application/vnd.oasis.opendocument.text)
2021-01-26 20:49 UTC, kitchm
Details
Second Document (10.69 KB, application/vnd.oasis.opendocument.text)
2021-01-26 20:50 UTC, kitchm
Details
Third Document (12.55 KB, application/vnd.oasis.opendocument.text)
2021-01-26 20:50 UTC, kitchm
Details
proposed update to using_numbering.html (45.23 KB, image/png)
2021-03-19 13:01 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kitchm 2020-08-18 21:32:50 UTC
Description:
When selecting one of two outlines, and then applying a change to it, both outlines on the page are changed.

Steps to Reproduce:
1.Create simple numbered outline
2.Add blank lines
3.Create second numbered outline
4.Select all of second outline
5.Select Bullets and Numbering icon at bottom of page
6.Select a different outline style or type

Actual Results:
Bad

Expected Results:
Should have only affected the selected text area


Reproducible: Always


User Profile Reset: No



Additional Info:
gerrit.libreoffice.org / core / 04ba7e3f1e51af6c5d653e543a620e36719083fd

(S/B a button to select what you want, as in other major programs.)
Comment 1 kitchm 2020-08-18 21:34:15 UTC
Created attachment 164429 [details]
Basic Outline Doc
Comment 2 kitchm 2020-08-18 21:35:19 UTC
Created attachment 164430 [details]
Basic Outline Doc showing results of only changing bottom outline
Comment 3 Dieter 2020-08-19 06:12:37 UTC
I confirm it with

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Steps to reproduce
1. Put cursor in the second list
2. Change number style with toolbar button

Actual result: Style of the first list also changes
Expected resut: Only style of the second list should change

I consider this as a bug. I assume, that "Restart Numbering" option doesn't create (technically) a new list. But that's also one thing I would expect.
Comment 4 Timur 2020-09-02 14:05:26 UTC
I reproduce the behavior but I'm not sure it's a bug.
Lists don't have numbering style (can't say if that's bug by itself). But when they don't, there is no style break, so it may make sense to change all. If someone doesn't want it, s/he may use List Styles. 
Please search in existing bugs.
Comment 5 kitchm 2020-09-02 14:14:05 UTC
@Timur, I guess I can understand your reasoning if you believe that the intent of numbered and bulleted lists as well as outlines is to be a mechanism created for the benefit of the programmers being able to say that they did something or other.

However, if we are speaking about usability or intuitive design, this is most certainly a bug, or a programming flaw at the very least.  I can find no justification for such a thing in a modern word processor.
Comment 6 Timur 2020-09-02 14:33:47 UTC
We shouldn't go general, claiming this should be changed, without seeing LO option, documentation and other bugs. Looks the same as bug 128282, probably more. 

My take is to change this to Documentation bug, unless this is already explained. I couldn't find. I'd add the difference in https://help.libreoffice.org/7.1/en-US/text/swriter/01/05130004.html, where it's already explained that there are Numbering Style and Unnamed numberings.
Comment 7 Dieter 2020-09-02 15:17:40 UTC Comment hidden (obsolete)
Comment 8 kitchm 2020-09-02 15:39:07 UTC
@Timur, IMHO it would seem strange to use documentation to explain a convoluted process.  Why not make it easy from the start?  I really cannot comprehend your way of looking at it.
Comment 9 Timur 2020-09-03 06:55:10 UTC
Created attachment 165062 [details]
Numbering compared

(In reply to Dieter from comment #7)
> Sorry, but I can't follow. Open list styles in sidebar. Select for example
> List Style "Numbering 1" and choose "Modify" from context menu. There I can
> see the tab numbering style. So numbered list have a numbered style.
See attached. 

@kitchm: You comments are general, of no-value, please do not proceed unless you can add something specific. I see you have a few reports, mostly not a bug or invalid. Meaning that you report without checking status first, without looking for existing open and closed bugs and understanding a feature. So we don't know if you are aware of numbering styles at all.
Comment 10 Dieter 2020-09-03 07:14:49 UTC
(In reply to Timur from comment #9)
> Created attachment 165062 [details]
> Numbering compared
> 
> (In reply to Dieter from comment #7)
> > Sorry, but I can't follow. Open list styles in sidebar. Select for example
> > List Style "Numbering 1" and choose "Modify" from context menu. There I can
> > see the tab numbering style. So numbered list have a numbered style.
> See attached. 

O. K. To be precise: Using icon "Toggle Numbered List" creates a list witout a certain style (I assume, that is what you wanted to say with "Lists don't have numbering style"). If you work with list styles, the behaviour is not reproducible.

=> I changed bug summary

cc: Design-Tea for further input and decision
Comment 11 Timur 2020-09-03 11:27:12 UTC
See Also bugs have a lot of info. Maybe also others. After so long a discussion, conclusion was needed and at least documentation should be updated. So bug 128282 needs to be revisited and considered with this one. 
Note: I use Help and not Guides, they should also be checked. But I prefer to have really useful Help, with practical examples.
Comment 12 zionoto 2020-09-03 12:26:14 UTC
(In reply to kitchm from comment #0)
> Description:
> When selecting one of two outlines, and then applying a change to it, both
> outlines on the page are changed.
> 
> Steps to Reproduce:
> 1.Create simple numbered outline
> 2.Add blank lines
> 3.Create second numbered outline
> 4.Select all of second outline
> 5.Select Bullets and Numbering icon at bottom of page
> 6.Select a different outline style or type
> 
> Actual Results:
> Bad
> 
> Expected Results:
> Should have only affected the selected text area
> 
> 
> Reproducible: Always
> 
> 
> User Profile Reset: No
> 
> 
> 
> Additional Info:
> gerrit.libreoffice.org / core / 04ba7e3f1e51af6c5d653e543a620e36719083fd
> 
> (S/B a button to select what you want, as in other major programs.)

Absolutely this isn't a bug it is a well desired feature!!!
If they have the same style it is logic and normal behavior that they do such a thing: it is the wanted behavior. To have different styled outlines you have to make different styles!!! You just have to learn to work with them. The use of styles simplifies updates in very complex documents. For example let's suppose a scenario in which you have a very complex book you are writing. You apply a certain style in different parts of the text. Then at a certain point you notice that the style doesn't fit your new needs. You modify it once and all instances of the text that use that style will modify accordingly without having to modify them one by one.
If we don't have this behavior we have to modify all instances one by one creating incoherent formatting. We don't want that in complex documents.

But when you want a different behavior/formatting in different points of the  document than you create and apply a different style to those different parts you want different. It is simple as that.

Now it is easy to understand why this is not a bug but it is a useful and very much desired feature that is necessary to create a coherent design in complex documents by complex word processors. You just have the need to learn how to deal with it the right way.

So when you want a list to be formatted differently create and incorporate the new formatting into a new style. When you need to change all the instances you just change the style once and you'll keep complete coherence in formatting everywhere the same style is used.

Cheers.
Comment 13 kitchm 2020-09-03 15:39:24 UTC Comment hidden (off-topic)
Comment 14 V Stuart Foote 2020-09-03 16:00:46 UTC
Absent an assigned list style--lists receive a default defined in standard template, and so affect unstyled lists of the whole document when direct formating of default paragraph  with the "Bullets and Numbering..." dialog.

As noted, behavior is expected, reproducible and the norm. RTM for a better grasp of handling styled lists.

=> NAB
Comment 15 Dieter 2020-09-04 08:15:03 UTC
So in sum I think, there is a lack of information about numbered lists (and perhaps also bullet lists) without a style. Informations could be added here: https://help.libreoffice.org/7.1/en-US/text/swriter/guide/using_numbered_lists2.html?&DbPAR=WRITER&System=WIN

Missing information:
Using Toggle Numbered List icon creates a list witout a style. If you create several lists witout a style a change in one list would affect all lists. (Of course it should be in a more perfect English)

=> REOPEN and I change component to Documentation. Feel free to change it back, if you disagree.

cc: Olivier Hallot
Comment 16 Timur 2020-09-04 08:53:57 UTC
Let's follow QA logic. 
When a report is NAB, it indicates check in Help and often it really needs documentation update, so if's justified to set New for Documentation.
Reopen is when there was a fix that doesn't work, indicating more attention. 
This may be New or remain Reopen, but for Documentation, to clarify this important issue that comes every while in bug reports.
Comment 17 sdc.blanco 2020-10-01 19:29:33 UTC
I tried but failed to address this issue of documentation update.

Some questions.

1. Did 'kitchm' try to look in the online help?  (If not, then maybe this issue cannot be solved by adding a small notice somewhere) --> WF

2.  If it still seems worth addressing, then it seems wise to identify the place where someone (searching in online help) would look.  
My proposal (contra those already given):  
https://help.libreoffice.org/7.1/en-US/text/swriter/guide/numbering_paras.html

Probably an explanation under a new header like:  "Changing the Numbering Style of a List"

I looked in Writer Guide 6.0, but did not find any relevant text.  
I do not feel qualified to write an appropriate text.  
If a good, short description can be provided, then I am willing to add it to that page (or another one).

Possibly that text would include:

- preferred approach is to make lists using paragraph style
(NB.  Does not try to explain what styles are, but gives an idea of how to achieve intended effect.)

- if lists are made with Bullets and Numbering, then changing the numbering in one list will result in changes in all the others created that way.
Comment 18 kitchm 2020-10-01 21:56:08 UTC Comment hidden (no-value)
Comment 19 kitchm 2021-01-15 20:29:51 UTC Comment hidden (off-topic)
Comment 20 sdc.blanco 2021-01-16 07:47:21 UTC Comment hidden (off-topic)
Comment 21 kitchm 2021-01-17 20:11:05 UTC Comment hidden (off-topic)
Comment 22 sdc.blanco 2021-01-18 00:07:10 UTC Comment hidden (off-topic)
Comment 23 kitchm 2021-01-18 01:12:13 UTC
I think I understand what you are wanting.  So in the first comment, it had to do with numbered lists.  From what I can find in the very confusion documentation, these are included under Bullets and Numbering, as are outlines.  https://help.libreoffice.org/7.0/en-US/text/shared/01/06050000.html?&DbPAR=SHARED&System=UNIX

I guess the simple improvement is to tell the user that multiple, unrelated unnumbered lists on one page will be seen by Writer as all one list.  Any changes to one will automatically affect the other, and there is no way around it.

If a person wants another numbered list, they must start another document.

Hope that helps.
Comment 24 sdc.blanco 2021-01-18 01:54:13 UTC
(In reply to kitchm from comment #23)
> I guess the simple improvement is to tell the user that multiple, unrelated
> unnumbered lists on one page will be seen by Writer as all one list.  Any
> changes to one will automatically affect the other, and there is no way
> around it.
I continue having difficulty to reproduce this behavior.  

For example, among other things, I have done the following.

0. Start with New document.
1.  Type 4 lines of text and two blank lines.
2.  Copy and paste the first four lines after the two blank lines.
3.  Select first four lines, use menu:  Format > Bullets and Numbering - Outline tab, and select an outline.
4.  Select the second set of four lines, use menu again, select a different outline.

Actual (and expected) result:  Only second set of four lines changes.

(I have also used Tab to add levels to both sets of 4 items, and use Format-Bullets and Numbering -outline to change outline several times in the second list, without affecting the first list.)

If you can reproduce the procedure described here (which seems to accomplish what you want), then I need to understand better what procedure you are using that is creating the problem, so that the help can be improved.
Comment 25 sdc.blanco 2021-01-19 12:49:14 UTC
@kitchm - here is how to reproduce your case:

Make a Numbered List
  1. Put or take some lines in a document
     (can also have empty paragraphs in the list)
  2. Select all lines.
  3. Choose a numbering type  (e.g., Toggle Numbered List on toolbar)
     (expected and actual result: all lines, also empty paras get a number)

Break the List Visually
  4. Place cursor at end of line of any item in numbered list.
  5. Add one (or two) empty paragraphs, so that there becomes two lists.
     (result:  continuous numbering, but at least one unnumbered blank line 
       between the two lists). 

Renumber the "Second" List
  6. Place cursor at top of “second” list.
  7. Right-click, Bullets and Numbering > Restart numbering.
     (actual and expected result:  the second list starts at 1).

Change Numbering Type of "Second" List
  8. Choose another numbering type for the “second” list.
        Actual Result:  both lists change.

Reason:  the “second” list is still considered part of the “first list”, so changing the numbering type for one part of the list changes the whole list (as expected according to current design).

Same effect can be produced with a single list (and no blank lines)
1. Make a list with 6 items.
2. Restart numbering with item 4.
3. Change numbering type of item 4 (or 5, 6)
4. See whole list change to new type.

I do not see an obvious place in the documentation to mention about this situation.  Maybe you (or others) have a suggestion?

Alternatively, maybe you want this ticket to go back to UI, with a question about whether “breaking” a list with a blank line should also “break” the list id for the items that follow after the blank line (would need to assign a new list id for those items).  

iow, this is not an issue of "list style" or not, but an issue of when a numbered list ends.

Stuart?
Comment 26 sdc.blanco 2021-01-24 00:14:10 UTC
Moving Component from Documentation to Writer, and adding needsUXEval.

Inspired by last paragraph of bug 135871, comment 37 about making DF tools safe to use (and taking advantage of Style Inspector).

The question here is only about the behavior of DF tools, where the intention is to use DF tools.

Demonstration of current behavior

1. Take 6 lines, apply DF numbering (Toggle Numbered List)
2. Put cursor after third line, press Enter twice  
   (result:  still numbered 1-6, but blank line between 3 and 4 -- no problem)
3. Put cursor on item 4, restart numbering
   (actual and expected result:  last three items are now numbered 1-3)
4. With cursor in second list, select another numbering scheme (e.g, Roman Uppercase)

Actual result:  numbering scheme for "first" list changes to Roman Uppercase
Expected result:  "first list" stays unchanged, second list changes as applied.

Additional information:
SI shows that the "second list" has the same list Id as the first list, so the "actual result" is according to design.

"Workflow" that would create this situation:

- make a list  (step 1)
- decide (after item 6) that you want to "split" the list into two different lists.
- put in some CR (step 2) and restart the numbering (step 3)
- decide you want to use a different numbering scheme for second list (for whatever reason), and use dialog to change.

@kitchm -- maybe you can confirm that this was what you were doing when you encountered the problem, or could explain what you were doing when you encountered the problem.  

Question to UXEval

I would think -- from a DF perspective -- that there would be no reason to expect that changing the second list would also change the first list.  

(and without the SI, it would be hard/impossible to understand what is going on).

See comment 23 for clear expression of how OP interpreted this situation.

Meanwhile, comment 4 suggests that this behavior may not be bug -- and that one should use "styles" if this behavior is not desired.  Comment 12 suggests it is a desired feature, but also suggests using Styles.

But in this case, the user wants to use DF  (so the query here is motivated by the idea of making DF safe to use). From that perspective, it does not seem to be solution to just push this over into a documentation problem, or to tell the user to use styles, when it seems to be a design/behavior flaw -- at least that is what I hope can be clarified. 

Meanwhile -- an (unproblematic) DF workflow case for comparison. 

1. write 6 lines.  (decide that you want to make them into lists)
2. Select first three lines, toggle on numbered list.
3. Select last three lines, toggle on numbered list.
4. Change numbering scheme for last three lines, no effect on first 6

Actual and expected behavior are in agreement.  The point is, this case is  similar to the problematic case, but each list gets a different list id, even without a blank line between them, so the origin of the suggestion in comment 23 is understandable (even if it does not describe the actual situation accurately).  This example also shows that the suggested documentation change in comment 15 is incorrect.
Comment 27 kitchm 2021-01-25 20:32:50 UTC
@sdc.blanco, I think I see a flaw in your reproduction.  I do not create a document as you did.  Where I want an outline or list, I start with selecting the outline or list first, and only then do I add text.  That is the way we were trained from the 1980's.  It is a reasoned and common sense approach.

While there are times when a person may do it as you described, many people do not.

Perhaps this will show the difference in documentation and/or usage.
Comment 28 kitchm 2021-01-25 20:35:58 UTC
By the way, have you noticed any other times where the simpler, common sense approach is not used in the software?  Does the documentation force the user to conform to the software, or does the software serve the user's needs?
Comment 29 sdc.blanco 2021-01-25 21:59:35 UTC
(In reply to kitchm from comment #27)
> While there are times when a person may do it as you described, many people
> do not.
Precisely.  That is why I have asked how you have done it, so that I do not have to keep guessing.  There multiple ways to use LO. The documentation seeks only to document those ways, not to push users into a particular workflow.

The procedures I described in comment 26 were meant to reveal something about the behavior of LO (and then to ask the design team for feedback about whether it was intended). 

So let's look at your intended workflow....

> Where I want an outline or list, I start with
> selecting the outline or list first, and only then do I add text.  

For example, would this correspond to what you do? 

A.  Select Numbering First, Then add Entries

1.  On Formatting bar, use dropdown menu in "Toggle Numbered List" icon to select 1),2),3) numbering scheme.

Actual and expected result:  1) appears in document

2.  Make an entry, then press Enter
3.  Repeat for second line
4.  Repeat for third line, but press Enter twice after third line.

Result:  There is a 4) after the first Enter, and then an empty paragraph after the second Enter. 

5.  On Formatting bar, use dropdown menu in Toggle Numbered List to select another numbering scheme  (e.g., 1.2.3.)

Result:  The empty paragraph changes to 1. 

6.  Make three entries, without pressing return after the third.
7.  On Formatting bar (or Bullets and Numbering bar), use dropdown menu to change numbering scheme to Roman numerals.

Actual and expected result:  Numbering scheme on second list changes, but the first list does not change.

In other words, I have tried to follow your way of doing things (or at least I have guessed as closely as your description permits), but have not encountered the initial problem that you described.

Now here is another way that (sort of) follows your (general procedure) but does produce the problem you have indicated.


B.  Select Numbering First, Then add Entries

1. Format > Lists > Numbered List
2. Make three entries.
3. Then add a few blank lines after the Numbered List.
4. Format > Lists > Numbered List

Actual result:  4.  appears in document (with a few blank lines above it, and the initial list with three entries, 1. 2. 3.).

5.  Continuing from the 4., make some more entries in this "second" list.
6.  (then I followed steps 4 to 6 in comment 0, namely, select the "list" below the blank lines, used dropdown box in the Bullets and Formatting toolbar to select a different outline type, and now both lists use the same numbering scheme, which is the problem that you reported.

(You did not mention "Restart numbering" in your initial report, but, I suspect it is involved in someway in your workflow, which is creating the problem that you report. 

For example,  in version B, if we apply "Restart Numbering" after step 4 and before starting step 5, then it looks like the "second list" is separate from the first, but when you change the numbering scheme for the "second list", then "first" list also changes.  Is that what you did?

If you have used yet another procedure to produce the problem that you reported, then please describe it.  Thanks.
Comment 30 kitchm 2021-01-26 20:48:40 UTC
Thanks for your patience.  Yes, I totally understood you and get what you are trying to do.  No problem.

And yes, A is what I do.  You've got it.  Nicely described.  I might even go back up and demote a line, and create more entries with more sub entries.  But please do note that I wrote "Select a different outline style or type".

However, at this point in time, I cannot duplicate the original issue.  I have tried a number of various combinations, to no avail.

So instead, I have stumbled upon another issue.  This may give us insight into what is happening.  I will be very specific to detail the steps here.  First, please look at the attached files.

The first one is what I created initially by the method above.  The first list is from Bullets and Numbering>Outline tab>third layout style.  The second list is from >Numbering tab>eighth layout style.  The third list is from >Numbering tab>first layout style.

In second document, I selected all of the first list, then changed it to Bullets and Numbering>Numbering tab>second layout style.  Please look carefully at the demoted lines.  They did not change to the new style, but kept the first style setting.

In the third document, I select everything below the title and pasted it down the page.  Please note that the first list continued the same numbering when it should have been an exact copy.  That is odd.
Comment 31 kitchm 2021-01-26 20:49:25 UTC
Created attachment 169164 [details]
First Document
Comment 32 kitchm 2021-01-26 20:50:07 UTC
Created attachment 169165 [details]
Second Document
Comment 33 kitchm 2021-01-26 20:50:36 UTC
Created attachment 169166 [details]
Third Document
Comment 34 Heiko Tietze 2021-01-27 09:56:02 UTC
(In reply to sdc.blanco from comment #26)
> I would think -- from a DF perspective -- that there would be no reason to
> expect that changing the second list would also change the first list.  

Disagree, there are many cases where the split list should behave exactly like this. Restart Numbering is a property not a command. And to solve the confusion we need to add another command "New Numbering" next to it, which supports the equally relevant use case, requested here. Would be another ticket.
Comment 35 Dieter 2021-01-27 10:05:05 UTC
(In reply to Heiko Tietze from comment #34)
> And to solve the
> confusion we need to add another command "New Numbering" next to it, which
> supports the equally relevant use case, requested here. Would be another
> ticket.

Sorry, I haven't read the whole discussion, but I propose to add the entry "Start New List" instead (and that includes New Numbering)
Comment 36 Heiko Tietze 2021-01-27 11:04:50 UTC
(In reply to Dieter from comment #35)
> ...I propose to add the entry "Start New List"

Text is up to discussion, of course, but I tried to stay close to the similar "Numbering" feature to make clear that both have the same result.
Comment 37 sdc.blanco 2021-01-27 11:13:04 UTC
(In reply to kitchm from comment #30)
> However, at this point in time, I cannot duplicate the original issue.  I
> have tried a number of various combinations, to no avail.
Ok. Thanks for trying.  Imho this is a "good" thing that you have tried various combinations without producing the problem that you originally reported here -- because it suggests that -- for the most part -- you are able to use LO to do what you want, without difficulty or surprise.

These cases that you have encountered...where changes in what you think is one "list" but has effects on what you think is another "list" arise because of software's internal management of lists.  As noted in comment 34, and I agree, this is a positive feature for some purposes, but, as we can see, it can also cause surprise and confusion.

For present purposes, let's stay at the level of your own everyday use of the numbering and outline features -- without getting into a discussion about the pros and cons of the internal management of lists (because we have already agreed that LO has multiple ways to be used and users who use it in multiple ways).

The basic idea  -- correct me if I am wrong @Heiko and @Dieter -- is that when you encounter a "misbehaving" list (i.e., where changes in what you think is "a separate, independent list" has an effect on what you think is "another separate independent list")then you would do the following:
1. Select all the items in the "second" list, 
2. Choose this (not-yet-existing) "New Numbering" / "Start New List" command (name-to-be-decided) (from the Bullets and Numbering toolbar or Format menu).

If things work as we imagine, this "misbehavior" would stop.  That is, you can subsequently change the numbering scheme for the second list without it affecting the first. 

How does that sound?  That is, if you had (and knew) about such a command, would you be able to get on with your work, without surprise or frustration?

If this seems like a good idea, then comment 34 (from the Design Team) recommends that a new bug report be filed for exactly and only that one feature. 

I recognize that you might still have questions about the test files that you have uploaded -- but let's take one thing at a time, and start by getting this important piece of the puzzle resolved.
Comment 38 kitchm 2021-01-27 14:39:42 UTC
I believe I understand where everyone is coming from.  However, I remain confused as to why lists, of any type, are handled the way they are.  Why was it necessary to "re-invent the wheel" here?  Shouldn't intuitive design be the leading factor?
Comment 39 sdc.blanco 2021-01-27 17:24:02 UTC
(In reply to kitchm from comment #38)
> I believe I understand where everyone is coming from.  However, I remain
> confused as to why lists, of any type, are handled the way they are.
The appropriate place to pursue that kind of question is with the Design team. Look at the "Get in Contact" section of: https://wiki.documentfoundation.org/Design.

The Bugzilla here is for reporting and resolving specific, concrete questions about the software.

So, coming back to the matter at hand and with an eye on identifying concrete actions that can be taken, here is a summary of the situation.

1. You opened this ticket because you had a problem with using the software.

2. I only got involved (comment 17) because there was a consensus that there was a documentation problem –  but I could not identify what needed to be added or changed in the documentation – in part because I could not reproduce the problem you described, and in part because the "suggestions" made here for changes were not correct. 

3. Since then, you have not been able to formulate a systematic procedure to produce the problem, which is fine (no critique, just an empirical observation), but then it is hard to know what, if anything, should be changed in the documentation.

4. Meanwhile, also as an empirical observation, you occasionally encounter situations in your workflow where you create a list that is ‟linked” to another list (in the sense that changing one list seems to affect another, or the numbering seems to be linked) – without quite knowing how or why that happens.

5. It is already possible to ‟break” that ‟link”.  Use F12 (or the ‟Toggle Numbered List” icon on the Formatting bar) on the first item in what you think is the ‟second” list.  Maybe not elegant.  But it works, and not particularly disruptive either. (this advice is already found in the documentation, but the command name needs to be updated, so I will do that, and add a picture of the icon).

6. Comment 34 made a friendly suggestion that a new icon (command) (‟New Numbering”) could be created that would effectively accomplish the same effect as using ‟Toggle Numbered List”  (and might be even better, in that it might preserve the chosen numbering/outline scheme of the item – which is currently lost with using Toggle Numbered List twice).
 
7. If you think it is a good idea (i.e., it would be useful for you), then please open a new bug report to propose this idea.  (If you do that, then under the ‟Severity” field, set the dropdown box choice to ‟enhancement”). 

8.  From your (and my own) experiments with using Format > Bullets and Numbering dialog, I can see one situation that some persons might characterize as "unexpected", namely when a list item is copied and pasted to another location, then the list identity is maintained.  

So I will add a ‟note” to:
https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbered_lists2.html

with the text: 

    Copying an item from a numbered list and pasting to a new location will 
    continue the list numbering. To start a new numbering, 
    click Toggle Numbered List twice.

(This is the same page as mentioned in point 5, so if anyone has additional suggestions for that page, now is a good time to mention it). 

9.  In light of points 5 and 8, I will set the Component back to Documentation.
Comment 40 kitchm 2021-01-27 19:28:55 UTC
Thank you for your good help.  As mentioned before, I understand where you are coming from and appreciate your points.
Comment 41 Commit Notification 2021-01-27 22:20:45 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/72fb074096addac2c8cc732bb7a73f0fb45ee2a1

tdf#135895  improve explanation about copy and renumbering lists
Comment 42 sdc.blanco 2021-01-27 23:09:40 UTC
(In reply to kitchm from comment #30)
> In second document, I selected all of the first list, 
I could not reproduce this problem.  I copied the first outline from First Document to a New Document, then used "Outline", with changes showing up in the list. 

> In the third document, I select everything below the title and pasted it
> down the page.  
I could reproduce that behavior in 7.2.0.0.alpha0+  When two (or more) lists are copied, only the first of the copied list maintains its identity with its source, while the other copied lists get copied as new lists.  

And I can add that each list (or an item from a list) copied separately will keep its identity with its "source" list.
Comment 43 sdc.blanco 2021-01-27 23:21:20 UTC
(In reply to kitchm from comment #40)
> Thank you for your good help. 
You are welcome.

It usually takes a few days for the online help to be updated from the master, after which you can see the modest result at:

https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbered_lists2.html

fwiw, Chapter 12 in the Writer 6.4 Guide is devoted to how to make List Styles.
It provides an another way to work with lists, without using Format > Bullets and Numbering.

I will leave it others to decide whether to file an enhancement request for a "New Numbering" command.

I will close this bug as FIXED, but if there are additional suggestions in relation to "swriter/guide/using_numbered_lists2.html", then they can be sent here.
Comment 44 Timur 2021-02-22 13:13:00 UTC
Hi Seth, please see this if you can do something, I will not reopen. 

In bug 135895 https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbered_lists2.html was ammended with 2nd Note:
 "Copying an item from a numbered list and pasting to a new location will continue the list numbering. To start a new numbering, click Toggle Numbered List twice."
That's OK and thanks Seth for formulating. Here I would add: "Double click will reset both numbering and it's format". 

There, after the title "Adding Numbering", a sentence couuld be useful:
  "Numbering to a paragraph cane be added manually as direct formatting, as explained here, or with a paragraph style.
  Manually added numbering is called Unnambered and can be continued or restarted, while paragraph style is by default continued across chapters".

Not sure why, there's separate yet better expained difference at https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.html and Numbering Style at https://help.libreoffice.org/7.1/en-US/text/swriter/01/05130004.html.

Somewhere could be added all this:
 "Ti know if a list is new or continued with numbering restarted, click in front of the numbering so that all numbers which belong to the same list are shaded."

 "To make the further paragraphs belong to the existing default list, mark them and then use the command "Continue Previous Numbering".
 Alternatively, to add new items to Numbering list, select paragraphs with numbering and new paragraphs, holding Ctrl as needed for separate lists, and click Toggle Ordered List."
 
 "Note that up-bottom or bottom-up select of list that follows immediately the existing list will result in that list being started from 1 or continued from previous list"
 
As for this up-bottom or bottom-up there are different opinions, mine is that it's fine to have option, some think it's a bug, but regardless this should be documented as it is.
I don't find worth a bug to ask for a change.

Reading all those numbering bugs, some issues are reported (ability to restart numbering in style bug 95219, ability to Continue restarted numbering bug 113213, add "Continue Previous Numbering" and "Restart Numbering" to drop-down of F12 as bug 117233) and some may be reported: keep numbering style with double F12.
Comment 45 sdc.blanco 2021-02-22 13:46:49 UTC
(In reply to Timur from comment #44)
> please see this if you can do something,
Suggestions noted.

The following two pages are planned for adjustments soon, as part of bug 139667, which was motivated partly by this bug 135895.

> https://help.libreoffice.org/7.2/en-US/text/swriter/guide/
> using_numbered_lists2.html 
> https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.html 

Will try to take it all at the same time.
Comment 46 Timur 2021-02-22 15:21:53 UTC
In addition to Comment 44,worth mentioning is Continue Numbering because user may expect it to work differently. 
Still, with selection method from that comment, Continue numbering in bug 36220 would work both in step 5 and step 6.
Comment 47 Commit Notification 2021-03-15 11:31:02 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/1e37bc66a03bbc4b096147addcebfbe41030557c

tdf#139667 (tdf#135895) improvements/updating to making lists
Comment 48 sdc.blanco 2021-03-15 11:42:37 UTC
(In reply to Timur from comment #44)
> add: "Double click
Done in comment 47
> or with a paragraph style.
Also in comment 47. Added <tip> with link to page that explains how to use paragraph styles with lists.
 
> Not sure why, there's separate yet better expained difference at
> https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.
> html and Numbering Style at
> https://help.libreoffice.org/7.1/en-US/text/swriter/01/05130004.html.
The first page is a "guide" (how-to), the second is the help page for the "List Style" (formerly "Numbering Style") dialog.

>  "To make the further paragraphs belong to the existing default list, mark
> them and then use the command "Continue Previous Numbering".
I am making a new page for "Continue Previous Numbering" (nothing exists yet), which will give a step-by-step procedure. (see bug 140579 and https://gerrit.libreoffice.org/c/help/+/111325)

> Alternatively, to add new items to Numbering list, select paragraphs with
> numbering and new paragraphs, holding Ctrl as needed for separate lists,
> and click Toggle Ordered List."
Already exists:  
https://help.libreoffice.org/7.2/en-US/text/swriter/guide/join_numbered_lists.html

(will see if a link could be added somewhere).

Still waiting for other bugs to be resolved before I can finish updating https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.html, but then I can take care of the other issues that you mentioned.
Comment 49 sdc.blanco 2021-03-19 13:01:42 UTC
Created attachment 170569 [details]
proposed update to using_numbering.html

> https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.html
@Timur - here is my proposal for addressing the other issues that you have raised.
Comment 50 Commit Notification 2021-03-25 22:56:17 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/6f068cc382d085ade3ef7177cc06859fcce1cf2c

tdf#139667 tdf#141128 (tdf#124582 tdf#135895) num. lists,levels,styles
Comment 51 sdc.blanco 2021-03-25 23:08:11 UTC
(In reply to Timur from comment #44)
Ok.  Finally possible to finish the remaining issues. jThis bug is already closed, so this is just to note that the proposed changes are up-to-date now.

> Somewhere could be added all this:
>  "Ti know if a list is new or continued with numbering restarted, click in
> front of the numbering so that all numbers which belong to the same list are
> shaded."
Idea now appears in bulleted list in:
https://help.libreoffice.org/7.2/en-US/text/swriter/guide/using_numbering.html 

>  "Note that up-bottom or bottom-up select of list that follows immediately
> the existing list will result in that list being started from 1 or continued
> from previous list"
This is a good "heuristic" or "rule of thumb", but not exactly correct. 
See attachment 170657 [details] for full explanation.
  
> As for this up-bottom or bottom-up there are different opinions, mine is
> that it's fine to have option, some think it's a bug, but regardless this
> should be documented as it is.
It is not a bug. The intended design gives this impression, but the algorithm is more complicated. The attachment gives a full and accurate account.