Bug 135956 - Writer - Customize Toolbar use wrong item for "Character Styles"
Summary: Writer - Customize Toolbar use wrong item for "Character Styles"
Status: RESOLVED DUPLICATE of bug 88512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-20 18:09 UTC by David W. Snow
Modified: 2020-08-20 21:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of the problem (366.13 KB, image/png)
2020-08-20 18:09 UTC, David W. Snow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David W. Snow 2020-08-20 18:09:32 UTC
Created attachment 164505 [details]
Screen shot of the problem

When customizing my Formatting (Style) toolbar, I went to add "Character Styles" next to "Paragraph Styles" and what actully happens is that I get a 2nd copy of "Paragraph Styles".
See the attached screen shot.
Comment 1 Julien Nabet 2020-08-20 21:10:40 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this but enabling "Character Styles" seems to do nothing.
In fact, if you disable "Paragraph Style", a box disappears, and enabling "Character Styles" makes it appear again.

After some debug, "Paragraph Style" comes from:
officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu 3580
See https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu?r=12ff89af#3580

whereas "Character Styles" comes from:
sw/uiconfig/swriter/toolbar/textstylebar.xml
See https://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/toolbar/textstylebar.xml?r=55291868#48

Notice, that "Paragraph Style" has keyid not "Character Styles". Also notice singular/plural difference for "Style".

Heiko: thought you might be interested in this one.
Comment 2 Maxim Monastirsky 2020-08-20 21:47:00 UTC
Implementation of the "Formatting (Styles)" toolbar was never completed, and a paragraph styles control is indeed serving as a placeholder for a future character styles control. See comments in Bug 130228.

*** This bug has been marked as a duplicate of bug 88512 ***