Download it now!
Bug 136075 - Sidebar: Move List content back to the Paragraph section in Draw/Impress
Summary: Sidebar: Move List content back to the Paragraph section in Draw/Impress
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 136103 136104 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-08-24 14:06 UTC by andreas_k
Modified: 2020-09-17 08:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
separate list section in impress after area (17.42 KB, image/png)
2020-08-24 14:06 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-08-24 14:06:27 UTC
Created attachment 164636 [details]
separate list section in impress after area

I don't see an benefit when the Lists items has a separate section in the impress/draw section, instead have the settings in the paragraph section like in writer.

In addition that it is not consistent, for example the Lists section was shown in impress after Area section and not Paragraph section see attachment.
Comment 1 Heiko Tietze 2020-09-15 13:54:37 UTC
Would also value consistency in this case.

Might be related to https://gerrit.libreoffice.org/c/core/+/70276
Comment 2 V Stuart Foote 2020-09-15 22:56:46 UTC
*** Bug 136104 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2020-09-15 22:57:10 UTC
*** Bug 136103 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2020-09-15 23:25:45 UTC
Alternative for consistency as Heiko pointed out in comments on the gerrit commit--split out the SB Lists content panel for the other modules.

More work yes, but one or the other for consistency.  Which is the better UX? Split or merged back to paragraph?

Seems a special nature of lists in Impress/Draw--a Draw TextBox holding the list.

The List items are not handled (format or style) as paragraphs in Writer--a List of Paragraphs.

And because creating Lists is ubiquitous to authoring a presentation/illustrations maybe they are better kept on a SB content panel of their own? And for consistency do similar for Writer's List controls--a new List content panel for the Properties dialog there as well?
Comment 5 Heiko Tietze 2020-09-16 08:01:13 UTC
List style (or actually Bullets/Numbering) is part of the paragraph format/style. Since you define it in the same dialog it seems natural to not separate.
Comment 6 Heiko Tietze 2020-09-17 08:05:55 UTC
We discussed the topic in the design meeting and concluded to resolve as wontfix.

Lists are very special in Impress and have a much higher importance. Plus, in Writer the list is an attribute of the paragraph style but not in Impress. Moving back would mean to loose the option to bring up the list dialog per click at the upper right icon in the content panel (besides it makes not much sense). So rather moving in we think the list option should be moved out in Writer. However, that makes currently also not much sense. Separating the list style from the paragraph style is technically wrong but has the charm of easier self-evidence and intelligibility.